NFS mount fails after last kernel update (12.3)


Since the last kernel update (I suppose, at least), NFS is broken on 2 of my boxes. Both are OpenSUSE 12.3 64bit. Both had NFS working fine until last week or something.

Current kernel is Linux 3.7.10-1.28-desktop #1 SMP PREEMPT Mon Feb 3 14:11:15 UTC 2014 (c9a2c6c) x86_64 x86_64 x86_64 GNU/Linux.

Trying to mount the NFS share manually gives this error message:

tycho:~ # mount /data
mount.nfs: mount system call failed

And the following is logged in /var/log/messages:

2014-02-15T09:58:09.342154+01:00 tycho kernel: 2415.118850] NFS: nfs4_discover_server_trunking unhandled error -2. Exiting with error EIO

Yes, rpcbind is running and the nfs kernel modules are loaded. I’ve not changed the definition of the NFS targets in fstab on either machine. Also, one of them is a laptop that I use on different networks (home and office), and the NFS mounts fail in both environments.

Anyone else seen this ?


Cheers. Bye.

Ph. A.

Yes, it was reported multiple times and for different distros. It would be good if someone who experiences it and can provide information opened bug report for openSUSE. If you do it, post number here.

In the meantime the simplest workaround is to force NFSv3 (option vers=3) unless you really need NFSv4.

Thanks for the tip. It works.

Yes, I will open a bug report.

Ph. A.

Here is a bugreport about it:
With kernel 3.7.10-88.gabf8346 (KOTD) the problem is solved (NFSv4 -> NFSv3 autonegotiation).

Open problem: NFSv3 fallback when NFS-server is UDP only:

I both cases the work-around is to add nfsvers=3 to the mount options.

This bug is against 12.3, not 13.1. 13.1 has different kernel version.

I’m not convinced it is the same bug.

Just submitted bug:

(didn’t see previous post – will look at the other bug).

It looks like this is indeed a regression in NFS version autoneg brought about by some of the fixes included in 3.7.10-1.28.


If you considder upgrading from 12.3 to 13.1. I think nfs v4 in 13.1 is broken as well, I filed a bug report as well.

NFS works fine on 3 computers I have set-up as file-sharing servers on OS 13.1, so I would not agree proposing this as the general picture; these servers machines also work as clients. I manually mount them all though so the operational procedure might be different from yours, but they all do work. I have a forth machine running SuSE 9.1 as a NFS server on the LAN, and the three clients running 13.1 communicates quite fine that one as well.


NFS4 or earlier? Do you use any NFS4 specific features?


I have exactly the same problem: same Kernel update, same dmesg about nfs4 and the mount error.
All was running ok on the client side: firewall setup, rpcbind and nfs client.
The nfs server was the exact same one from a previous nfs mount on that pc so the server could not be the problem.
I was getting frustrated when I started to search the net and made the recommended version 3 option on the mount command. It worked.

mount -t nfs mhtt:/mnt/data /mnt/util  -v -o nfsvers=3,vers=3


Aha, sorry that may not be the case. I’m not quite certain what that entails either, however, NFSv4 seems to be enabled.