NFS mount fails after kernel update

After updating the kernel coming from 3.7.10-1.24.1-x86_64 to 3.7.10-1.28-x86_64 on KDE based opensuse 12.3 mounting of NFS v3 volumes fails.
Re-installing kernel 3.7.10-1.24.1-x86_64 solved the problem.
Is this a known problem? Something wrong with configuration?

Same here. Mount returns with

# mount -t nfs {HOST}:{PATH} /{MOUNTPOINT}/
mount.nfs: mount system call failed

dmesg shows

  296.593964] NFS: nfs4_discover_server_trunking unhandled error -1. Exiting with error EIO

Kernel 3.7.10-1.28-desktop x86_64

I (did) have the same problem here:

Client 1: openSUSE 12.3 64bit, kernel-update to 3.7.10-1.28
Client 2: openSUSE 13.1 32bit, kernel-update to 3.11.10-7.1

Server 1: openSUSE 11.4 Evergreen 32bit, NFSv4 enabled
Server 2: Netgear ReadyNAS Duo v1, NFSv3
Server 3: SUSE 7.3 32bit, NFSv2 (don’t ask :-))

After the kernel-updates (12.3 & 13.1) only the nfs-exports from Server 1 with NFSv4 would be mounted.
Mountig the exports from Server 2 & 3 i got this:

NFS: nfs4_discover_server_trunking unhandled error -1. Exiting with error EIO

My solution so far (using autofs) was to change my auto.nfs file and adding manually the NFS version:

server_2    -fstype=nfs**,nfsvers=3** server2:/exports # NFSv3
server_3    -fstype=nfs**,nfsvers=2** server3:/exports # NFSv2

I also reopened bug 811746, because i think that the patch was the problem:
Announcement ID: openSUSE-SU-2014:0204-1 (The kernel update for openSUSE 12.3)

  • NFSv4: Fix issues in nfs4_discover_server_trunking

Thanks. Learn something everyday: I didn’t know the nfsvers mount option. Solved all my troubles.
Also thanks for reopening the bugreport.

I have got the same problem here. Could you tell me how to re-install the 3.7.10-1.24.1-x86_64 kernel?
Thank you very much


Adding the option nfsvers=3 (in my case) works indeed. Thanks for the workaround and re-opening the bug.

I use YaST, software management -> search ‘Kernel’ -> select in the list of software at the right side your installed kernel -> find the tab ‘version’ in the lower detailed view.
Hier you will see the list of installed and installable kernels. You can uncheck the current kernel, install a kernel of your choice and mark the kernel (of your choice), e.g. as ‘never update’ through right-click at the check box.
This should be doable using zypper but I have no experience with that tool.
Good luck, and the workaround of Kieltux really works at least for automounting/autofs


Thanks for the fast reply. Re-installing the 3.7.10-1.24.1-x86_64 kernel works fine.