nfs-kernel-service error in exporting NFS directory

Updated 42.3 with an install of Leap 15. Previously had a directory exported, available to other machines on the LAN. Setting up NFS Server in Yast on Leap 15 (on two machines) I see an error message that nfs-kernel-service is not available. The n-k-s package is installed NFSserver show Enabled and Active on Services Manager. Showmount -e says the directory is exported. But can’t mount it from an NFS client. Using NFS 3 only–super plain.
The directory shows up in Dolphin, but a user (still on 42.3) sees “Only root can mount…” when clicking on either the mount point or the IP of the device in Dolphin’s Devices list.
Permissions for exported director is USER/users; same for the mount point on the client.
Hints appreciated.

That may be due to firewall changes.

I ran into a similar problem. So I turned off the firewall (on the server). And then I could mount. After that, I had to figure out how to configure the firewall for NFS.

According to my notes for the Leap 15 upgrade, I used yast firewall and set my Ethernet interface to “internal” and then set services for internal to include nfs, mountd, and *rpc-bind *(not sure if all are strictly required).

You can also use firewall-cmd from a shell (see its man page):

   firewall-cmd --zone internal --permanent --add-service=nfs
   firewall-cmd --zone internal --permanent --add-service=mountd
   firewall-cmd --zone internal --permanent --add-service=rpc-bind 
   firewall-cmd --reload

Too late to edit my last post - these commands will open up the ports for all the internal services I use:

   firewall-cmd --zone internal --permanent --add-interface=*eth0*
   # NFS
   firewall-cmd --zone internal --permanent --add-service=nfs
   firewall-cmd --zone internal --permanent --add-service=mountd
   firewall-cmd --zone internal --permanent --add-service=rpc-bind
   # Samba
   firewall-cmd --zone internal --permanent --add-service=samba
   # DLNA 
   firewall-cmd --zone internal --permanent --add-service=minidlna
   #kdeconnect requires:
   firewall-cmd --zone=internal --permanent --add-port=1714-1764/tcp
   firewall-cmd --zone=internal --permanent --add-port=1714-1764/udp

   firewall-cmd --reload

Where eth0 is my internal Ethernet from the output of *ip addr
I’m not sure if I’ve opened up more than necessary, but it’s on my internal network so I’m not overly concerned.

It is not the firewall. I stopped the firewall; the mount still failed.

Hmm. Here’s a hint. It appears to be using ipv6, and failing. 2002:c0a8:45f6::c0a8:45f6 is the ipv6 address of the server derived from

$ mount -v /u
mount.nfs: timeout set for Sun Nov 10 15:01:34 2019
mount.nfs: trying text-based options 'vers=4.2,addr=2002:c0a8:45f6::c0a8:45f6,clientaddr=::'
mount.nfs: mount(2): Network is unreachable
mount.nfs: Network is unreachable

$ ping -6 2002:c0a8:45f6::c0a8:45f6
connect: Network is unreachable