nfs-client service very slow to start or not starting

The nfs-client service isn’t starting after boot up. This is causing problems with the user as they cannot access the remote folders on the server.

The PC is a Thinkpad X60s with oS11.3 and KDE4.4.4. The problem started about a week ago after some updates (new kernel update, kde4 updates and some system files) were applied on the laptop.

After logging in none of the remote folders are available. Checking the nfs-client service under Yast>System Services (Runlevel) shows the nfs-client service is not running. If I enable and start the service I get the pop-up confirming the service has started but still cannot access the remote folders even after issuing a mount -a. Opening Dolphin just opens a blank grey window which needs to be terminated.

Trying to restart the nfs service using su -c ‘rcnfs restart’ sticks at
Starting NFS client services: sm-notify
Just leaving the PC for 10-15mins eventually sorts itself out and the remote folders become visible.

I cannot see anything obvious in the logs so am a bit stumped. Any ideas / suggestions on what may be causing the nfs-client service to not start properly?

When it worked earlier (before the last kernel update) we should try to search in that direction, but nevertheless and notwithstanding the fact that you did explain what you tried very well, it would have been even more informative when you had posted your CLI trials here completely (copy/paste). Thus not “telling” that you issue a mount -a, but “showing” a complete sequence with what you type and what you get (and between CODE tags), like:

cat /etc/fstab
mount -a

But then with all the output (error messages) included. That will explain what has to be mounted, what is mounted, what happened when you mounted and what is mounted after the trial in one clear message.
The same for

rcnfs restart

with all the output (and maybe a comment from you that between lines 2 and three it waited for 10 mins).

Question: is it switched off in YaST Runlevel again every time after boot?

OK I’ll paste the actual cli commands as requested but I’ll need to wait to get back onto the PC later, maybe over lunch. To answer your question, yes nfs-client is switched off after boot.

The problem has already found a solution elsewhere in the forums, here it is:

In /etc/nfsmount.conf, change


to :


Done so by doing

On Gnome: gnomesu gedit /etc/nfsmount.conf
On KDE: kdesu kwrite /etc/nfsmount.conf

Reboot to effect the changes.

This stops the three minute time-out.

Oh boy, that is one of those “let us change the default of things over night, nobody will get caught with it” things. Yes, very likely that the difference between NFS version 4 and earlier will give problems when one site is changed without further notice. >:)

On 2010-10-06 11:36, suse tpx60s wrote:
> The nfs-client service isn’t starting after boot up. This is causing
> problems with the user as they cannot access the remote folders on the
> server.

Is the network up? Are you using dhcp, perhaps? if-up or network manager? Best is traditional
network setup with fixed IP.

Are you using nfs 4 features? Some have reported problems in 11.3.

Also, check the firewall log for dropped packets, both on the client and server.

Two threads about nfs problems recently:

] <>

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Hi Carlos,

I’ve tested this “feature”. Happens with ifup as well as networkmanager, static IP and DHCP. It’s the client that times out for 3 minutes. It defaults to NFS4 now, since it doesn’t get the proper reply. Will test without changes as soon as I have the time to move my server to 11.3.

I had this very slow boot problem after activating NFS Client.

Making the change Knurpht suggested seems to have fixed the slow boot up, at least on restart.

Thanks Knurpht :slight_smile: