NFS and DHCP problem

I have NFS running successfully between two SUSE 10.3 boxes, except that my host address gets changed by the router periodically and then connections fail. The address changes beetween and I tried changing my network card setting (via Yast) from dynamic addressing via DHCP to static address This is outside the range that DHCP uses. But when I do my network is unreachable, my internet does not connect, and I cannot ping an external address.

Any pointers would be appreciated.

When you take matters in your own hands and assign a static address, you also have to take care of other things that DHCP did for you, namely the default gateway and the DNS resolver. There are YaST dialogs for setting those. In most cases the gateway and the resolver is the router itself.

Another way of doing it on some routers is to ask the router to pin the IP address given out to the particular MAC address used by the computer. Check the admin web pages to see if this feature is offered. Then you can continue to use DHCP but have the static IP address. Almost like having your cake and eating it too.

I am guessing you are using traditional method with IFUP? If you are using the Network Manager, don’t use Yast to configure a Static IP, use the modify connections in Network manager. And as the previous post said, you must specify the gateway and DNS settings or it won’t work.

Ah yes, “In most cases the gateway and the resolver is the router itself.” Once I set the router address as the default gateway everything fell into place. I was trying to set the static addresses to the MAC numbers, but I couldn’t do from my router.


Everything works now except that when one of the computers is powered down the other has no access to it’s own home directory. Konqueror says it is “stalled” and eventually locks up. I think I need to stop/restart my network services. What’s the simplest way to do that?


As root:
rcnetwork restart
rcnfsserver restart
rcnfs restart

Take a look at the perms in /etc/exports as well, Is it for 192.168.0.* ?

You mean that the /home directory of system a is NFS mounted from system B? and that then system B goes down?

Of course, as soon as a process on system A wants an I/O on its /home, there i a stall. And when other processes are doing likewise and/or waiting for the first process to continue everything grinds to a halt. I am afraid restarting the network interface will not help much. The effect is about the same as dismounting /home when it is not NFS but localy.

The permission is “rw”, so I don’t think this is the problem.

What you said sounds perfectly logical.

Perhaps I should describe the intent of this project and ask how you would do it. Two computers are involved. I want to create a file on computer A, have computer B access it for editing and saving on either computer. Then I want the reverse, create a file on computer B, have computer A access it for editing and saving on either computer.

What I did was set up both computers as hosts and clients. Is that a conceptual error?

Nope, that is allright. (you could even have more systems and/or create loops, not wise of course, the loop I mean).

But when you switch one of and the other still wants to access the data you have a problem.

Thanks for the confirmation. I think I just moved back 10 years; to the world of WinDoze. You remember…reboot, reboot, reboot…