nextcloud-client segmentation fault

my system is running opensuse leap 42.1 with plasma 5.8.0:
Laptop=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz
upgraded 13.2 to leap 42.1, using wolfi repos. I’m running KDE 4.14.18 and plasma 5.8.0, KDE frameworks 5.27.0, KDE applications 16.08.2, Kernel 4.1.31-30-default and nvidia drivers

after this threadI uninstalled owncloud-client and installed
nextcloud-client and all the nextcloud related
libnextcloudsync0
nautilus-extension-nextcloud
nextcloud-client-dolphin
nextcloud-client-lang
from here: http://download.opensuse.org/repositories/network/openSUSE_Leap_42.1/

but nextcloud-client start and after few seconds disappear, if I launch it by konsole it gives me segmentation fault

pla@suseST-pla:~> nextcloud
Segmentation fault

as I use wolfi repos I don’t know if I am in 42.1 or in tumbleweed I also installed nextcloud-client from here:
http://download.opensuse.org/repositories/network/openSUSE_Tumbleweed/
but the result doesn’t change
how can I have a working nextcloud-client ??
manythanks, ciao, pier

Well, mixing with other versions ( did you check what else was pulled in ?) is a recipy for breaking things, yes. We cannot see which package comes from which repo, so anything would be just shooting in the dark.

mmm, it’s true, no, I don’t know what other was pulled in… is there a way to know?

as your opinion, with wolfi repos, I’m with 42.1 or tumbleweed??

Opinion is not involved here, the system speaks :smiley:

cat /etc/os-release

Have to say though, all machines here run Leap 42.1 + Packman, except my own laptop, which has TW. Nextcloud client runs fine on my wife’s Leap ( the one from the network repo ), and on my TW ( from the distribution repo ), so I suspect your system has moved away from the stock packages enough to cause the client to crash.

Hi, insert the following code into /home/$USER/.local/share/data/ownCloud/owncloud.cfg:

[proxy]
type=2

From: https://github.com/owncloud/client/issues/5128

Hi, manythanks luciano, my owncloud-client works, it is nextcloud-client that gives segmantation fault… :slight_smile:
ciao, pier

pier andreit wrote:

>
>
> my system is running opensuse leap 42.1 with plasma 5.8.0:
> Laptop=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @
> 1.60GHz
> upgraded 13.2 to leap 42.1, using wolfi repos. I’m running KDE 4.14.18
> and plasma 5.8.0, KDE frameworks 5.27.0, KDE applications 16.08.2,
> Kernel 4.1.31-30-default and nvidia drivers
>
> after 'this thread ’ (http://tinyurl.com/zcfu5xb)I uninstalled
> owncloud-client and installed
> nextcloud-client and all the nextcloud related
> libnextcloudsync0
> nautilus-extension-nextcloud
> nextcloud-client-dolphin
> nextcloud-client-lang
> from here:
> http://download.opensuse.org/repositories/network/openSUSE_Leap_42.1/
>
> but nextcloud-client start and after few seconds disappear, if I launch
> it by konsole it gives me segmentation fault
>
> Code:
> --------------------
> pla@suseST-pla:~> nextcloud
> Segmentation fault
>
> --------------------
>
> as I use wolfi repos I don’t know if I am in 42.1 or in tumbleweed I
> also installed nextcloud-client from here:
> http://tinyurl.com/z7qf77r
> but the result doesn’t change
> how can I have a working nextcloud-client ??
> manythanks, ciao, pier

Use nextcloud instead owncloud
See comments at owncloud repo

Use it from here: server:php:applications

OneClick 42.1:
https://software.opensuse.org/ymp/server:php:applications/openSUSE_Leap_42.1/nextcloud.ymp?base=openSUSE%3ALeap%3A42.1&query=nextcloud

OneClick Tumbleweed:
https://software.opensuse.org/ymp/server:php:applications/openSUSE_Factory/nextcloud.ymp?base=openSUSE%3AFactory&query=nextcloud

I use it under Leap 42.1 many month without problems.

Regards
Eric

manythanks eric, but I’m looking for nextcloud-client, in the repo you suggested there isn’t the client

pier andreit wrote:

>
>
> ecsos;2796818 Wrote:
>>
>> Use nextcloud instead owncloud
>> See comments at owncloud repo
>>
>> Use it from here: server:php:applications
>>
>> OneClick 42.1:
>> http://tinyurl.com/h6nn5kt
>>
>> OneClick Tumbleweed:
>> http://tinyurl.com/hteg8kj
>>
>> I use it under Leap 42.1 many month without problems.
>>
>> Regards
>> Eric
> manythanks eric, but I’m looking for nextcloud-client, in the repo you
> suggested there isn’t the client

Yes.
Of corse there is nextcloud-client.

Or search nextcloud under
https://software.opensuse.org/search

Regards
Eric

pier andreit wrote:

>
>
> ecsos;2796818 Wrote:
>>
>> Use nextcloud instead owncloud
>> See comments at owncloud repo
>>
>> Use it from here: server:php:applications
>>
>> OneClick 42.1:
>> http://tinyurl.com/h6nn5kt
>>
>> OneClick Tumbleweed:
>> http://tinyurl.com/hteg8kj
>>
>> I use it under Leap 42.1 many month without problems.
>>
>> Regards
>> Eric
> manythanks eric, but I’m looking for nextcloud-client, in the repo you
> suggested there isn’t the client

Ah. sorry. My failure.
The links was for server. :slight_smile:

The right links are:
For 42.1:
https://software.opensuse.org/ymp/network/openSUSE_Leap_42.1/nextcloud-client.ymp?base=openSUSE%3ALeap%3A42.1&query=nextcloud-client

For Tumbleweed is the client in repo.
https://software.opensuse.org/ymp/openSUSE:Factory/standard/nextcloud-client.ymp?base=openSUSE%3AFactory&query=nextcloud-client

Regards
Eric

manythanks eric, yes, it is the same repo where I downloaded the one that doesn’t works
http://download.opensuse.org/repositories/network/openSUSE_Leap_42.1/

pier andreit wrote:

>> The right links are:
>> For 42.1:
>> http://tinyurl.com/j3sk5sk
>>
>> For Tumbleweed is the client in repo.
>> http://tinyurl.com/jfbyecj

> manythanks eric, yes, it is the same repo where I downloaded the one
> that doesn’t works
> http://download.opensuse.org/repositories/network/openSUSE_Leap_42.1/

I use it without problems under 42.1

I think you have a mismatch.

You write in first news:
==schnipp===
after 'this thread ’ (http://tinyurl.com/zcfu5xb)I uninstalled
owncloud-client and installed
nextcloud-client and all the nextcloud related
libnextcloudsync0
nautilus-extension-nextcloud
nextcloud-client-dolphin
nextcloud-client-lang
===schnipp===

For 42.1 there is no nextcloud-client-dolphin
This is only in 42.2, factory and tumbleweed.

So. Check your repo and update/change all nextcloud-things to this repo.

This is what i have installed:

zypper se -si nextcloud
S | Name | Typ | Version | Architektur |
–±----------------------±--------±-----------±------------+
i | libnextcloudsync0 | package | 2.2.4-9.2 | x86_64 |
i | nextcloud-client | package | 2.2.4-9.2 | x86_64 |
i | nextcloud-client-lang | package | 2.2.4-9.2 | noarch |

Regards
Eric