Newmoon / Palemoon crashes often in 15.1

I was having trouble with Newmoon crashing. I had thought it was something with setting my gtk2 settings so the scrollbar was big enough to click on. I have now done a fresh install, with minimal changes (dolphin settings). I added the network repository and went to add newmoon. When clicking accept, yast crashed. I restarted it, and installed newmoon ok. I added no addons, and went to scrolled down to the Shop by categories, moved my mouse over chainsaws, and it crashes every time I tried it. There’s other websites that crash also.

Is this a known problem or any suggestions to narrow it down? This happens on desktop and laptop. opens for me OK.

I had Newmoon crashing last May and again in December in KDE3. I emailed Newmoon maintainer and [opensuse-support] each time:
For me it was a theming failure.

rpm -q --changelog newmoon | head

will provide the maintainer’s email address.

Glad I’m not the only one. You’d think there’d be others.

I downloaded the gtk2-theme-oxygen package from KDE:Extra: and set my gtk2 theme to oxygen-gtk. Still crashes.
I found out it wasn’t just the chainsaws category, but of moving the mouse rapidly across the categories. They seem to blink but at the right rate, it crashes. I will try to e-mail the guy.

I’ve e-mailed him, updated to the latest version twice, and still crashes. If I go to, start scrolling down, it crashes.

Any other thoughts as to how to fix this?

Anyone who uses newmoon on 15.1 that doesn’t crash, could you tell me what your settings are, such as gtk2 theme, etc.?

Newmoon does randomly crash for me, but not terribly often, as I use it specifically for a limited selection of URLs that I keep open on virtual desktop 8, 99+% of the time I am logged in. I use KDE3 with oxygen-gtk. Most browsing I do with SeaMonkey, but I also use Firefox ESR for another selection of URLs that includes Facebook, various TV schedule sites, some web shopping, and certain URLs on my own web site.
loads without problem on Palemoon, Tumbleweed 32bit, IceWM.

I don’t know if this makes it the same as the IceWM, but I logged out, then on login, selected IceWM. Started newmoon, and it fails. I had updated to the latest version, 28.8.3-lp151.1.10-x86_64. I wasn’t using tumbleweed.

Does that match MakeTopSite’s condition excepting for the 32 bit and tumbleweed? If so, what could one conclude? Something with KDE or QT? If I updated it?

I got a response back from Alexei Podvalsk saying he no longer is working on this package. I tried one of the community packages, AndnoVember, and it failed also. I was ready to give up, but thought about trying to compile it myself. I went to get the source from, and came across this: It says, To use, “simply extract the tarball anywhere you like and execute the “palemoon” file inside it,”. I did, and it works. It was a newer version, so I then downloaded the sub version I was having trouble with, and it works, also. At least for the opensuse main page.

Any ideas what’s going on here, what is it that was compiled for opensuse doesn’t work, but a Linux binary that supposed to work for many different flavors works fine? It must has something that has been replaced in the opensuse install.

The installed rpm crashed on me again several hours ago, so seeing this thread’s latest addition, I uninstalled it, and unpacked the tarball. It seems to be working well.

I clicked, Help>Check for Updates and let it update it. The tarball still works for
Just wanting to see if the Network version still fails, I find the tarball update changed things elsewhere besides the local directory. In my menu, under Internet, it removed “newmoon” and inserted “palemoon”. I went to /usr/lib64/newmoon/newmoon-bin and it loaded the tarball palemoon evidenced by the version being 28.10.0 rather than 28.8.3.

I just want to understand what’s going on. I thought if you go to a directory, and explicitly run a program, it would load it. It appears that there is something set up so that it will transfer / forward to my local copy. I would like to know how it does it. Why? To understand how my system works.

Ok, I see what I did. I had the tarball still version running behind some windows, then went and attempted to start the Network version, but since there was one active, it just opened a new window for that version. Guess you run both at the same time.

I have openSUSE Tumbleweed with all updates to date. I opened bug report # 1180352 for Pale Moon and received this response:

Newmoon is n´t part of the distro and also not related to KDE, closing as invalid. If you know the maintainer of the package you installed, you can reopen this bug and reassign to the maintainer.

How should I do the right thing?

Test new release:

v29.0.1 (2021-02-06)
This is a security and stability update.

If you have problems - create report for developers: .

Спасибо за информацию.

Я поставил Palemoon из тарбола, сечас тестирую. Пока не падает.

Hello Arbichev,

You started this thread in the English part of the forums. Can you please keep it in the English language. I assume you are confusing this with the Russian part.

Sorry to break your rules. I installed Palemoon from tarball, now I’m testing it. Until it falls.