Newbie with new install, 11.1, GUI?

Just installed 11.1 and it all seemed to go okay bar 2 items that had changed that for safety I didn’t add.
After reboot I couldn’t login as user defined during setup but I tried ‘root’ as username with password and logged on, but while I can open YaST2 at prompt I can’t get GUI started.

Any help would be appreciated as it’s too steep a learning curve for me to familiarise myself with linux using commands.

Never login as root.

Try the failsafe boot from the menu
The issue is probably graphics. Failsafe uses a safe driver giving basic display, but should work sufficient to get you to the desktop. If it fails too, let us know and we can help more.

If you do get the desktop, then let us know about your graphics and we can help there too.

I tried failsafe but got same login.
It initiated runlevel 5 and won’t accept the username like before.
What do I try next?

Just log in as root or as you/user and try: startx or startkde or startgnome.

Sorry about delay getting back.
Desktop needed reinstall of windows due to faulty DIMM.

I logged into openSuse as root on laptop and typed startkde.
Got-:
kdecheckrunning: error while loading shared libraries: libSM.so.6: cannot open shared object file:No such file or directory /usr/bin/startkde: line 27: xsetroot: command not found
usr/bin/kde4-config: error while loading shared libraries: libQtCore.so.4:cannot open shared object file:No such file or directory

and on like this.

startgnome
-bash: startgnome:command not found

startx
No startx installed

> startx
> No startx installed

seeing that, and your first post which said: “Just installed 11.1” and
i have to wonder if you installed from 100% perfect install
media…that is, i wonder if you downloaded it and if so would please
have a look at this multi-post thread to learn how to ensure your
install media is ok: http://tinyurl.com/6jwtg9

i give you the whole thread because it is PACKED with good info for
folks new to openSUSE…so, overlook the stuff that may not be
important to this media question, which is easily found in steps 2, 3,
4 and 6 of posting number 2 with the permalink of:
http://forums.opensuse.org/install-boot-login/401696-newbies-suse-11-1-pre-installation-please-read.html#post1908008

once you are satisified that you used perfect install media
(downloaded from http://software.opensuse.org/ NOTE: there are a bunch
of different versions ‘out there’ and not all work the way the way
they should) then i have to tell you that something went wrong in your
install…because unless you made some changes (that is, if you
accepted the default install) then openSUSE 11.1 will boot directly to
the desktop without asking for either a user name nor a password…

however, since you said yours did, but it wouldn’t accept the user
name you gave during install…i have to wonder if you realize that
that if you specified (say) Baal_Azazel during install it will NOT
accept either baal_azazel or Baal Azazel now…

in a terminal, run this


cat /etc/passwd | tail -n5

and in the stuff that pops up, you should see (among other things) the
user name openSUSE is expecting to see…

but, my GUESS is your initial install is somehow damaged…


brassy

Just wanted to say that when I thought about it, I realised that I’d been having problems with other bitorrent d/l’s and it turned out to be a faulty DIMM. I removed it and redownloaded the installation DVD and reinstalled and everything went great.
Thanks to all for the help.

> Thanks to all for the help.

glad you ::SOLVED:: it


goldie