Newbie trying to get it right: swap ATI to Nvidia

Running opensuse 11.2, I want to swap my existing radeon 9600 card for an Nvidia 7950GT, because I just gave up trying to get the ATI drivers to work, so bought the Nvidia card. Current driver is Radeon.

One idea is to change the driver to vesa in xorg.conf, then swap cards. Since I do not currently have xorg.conf, would create one with sax2 -r -m 0=radeon and then edit the file. Or is there a command line that would change the driver to vesa: sax2 -r -m 0=vesa?

From another thread, Graphic Card Practical Theory, there are instructions for booting into level 3 and using sax2 to set the driver to the nv, open source driver, inwhich case I assume you must have the nv drivers in your repository.

Another idea is to just turn it off, swap cards and reboot, but I am nervous about that option.

Anybody got good advice for this move?

sax2 -r -m 0=vesa will work

But since you do not have a xorg.conf file I’d just swap the cards. NVIDIA cards are have many fewer problems then ATI at the moment.

I’m puzzled though that you do not have an xorg file because that is one of the things you do to get ATI stuff working???

The xorg.conf file may not even be needed for the nVidia 7950GT. Just try it and find out.

ie 1st familiarize yourself with renaming and moving files from a full screen terminal. Also, if you installed an rpm with “fglrx” in the name for the priorietary ATI, then you MUST remove that “fglrx” rpm.

Once you are happy you can do the file handling from a terminal, then shut down your PC, and change the graphic cards. Then when booting, press “3” when the grub menu appears to boot to run level 3. Then login as a regular user, and then type “su” (no quotes - enter root password) to switch to root permissions. Then move the xorg.conf to some other name. ie:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.ati.vesa

assuming it is for vesa driver and assuming my memory is correct that “mv” is the correct command (I’m not at a linux pc right now). Just be certain the xorg.conf file is no longer present to test the xorg capability to automatically configure for your new graphic card.

Then with no xorg.conf file in place, reboot (you need root permissions) by typing:

shutdown -r now

and see if your PC will run with no xorg.conf file. If that fails, then reboot, type “3” to boot to run level-3, log in again as a regular user, then switch to root with ‘su’ and then this time follow the practical theory guide using the “nv” driver using the “sax2” command: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Those drivers are in the xorg-x11-driver-video rpm which is installed with EVERY openSUSE install.

Well, just reboot to run level 3, and remove the xorg.conf file.

If necessary, you can run sax2 as described in the provided URL.

nVidia drivers (and the open source “nv” driver) are pretty good. Its highly unlikely you will need to use the vesa driver. Its more likely you will find the opensource “nv” driver works, but you will be eventually chomping at the bit to get the higher performance from the proprietary “nvidia” driver.

I don’t have an xorg.conf, per the default in opensuse 11.2. I had tried to get the proprietary ATI driver to work and that worked so well I had to reinstall suse. This time I just left everything at the default as far as graphics is concerned and ordered an Nvidia card.

So now, I think I should just swap boards and boot into level 3 and do: sax2 -r -m 0=nv to set up the nv drivers and reboot. First I will make sure the nv drivers are in repository, as you say they should be, and make sure the fglrx drivers are not.

After getting that working I will do “Nvidia the hard way”, not at all hard after what I have been through, because the whole purpose of this is to take advantage of the full features of the card.

Thanks for your help. Will post results when it’s done. This may be a few days.

Ok, finally did it. Since I had no xorg.conf file, I just turned the computer off and swapped cards and turned it back on. It booted up fine and recognized the card, with one of the open source drivers.

Next I went to the HOWTO page for nvidia cards and clicked the link to nvidia drivers. This page has everything you should need for iinstalling nvidia drivers (proprietary). The first section has the one-click instll which I have never used, so on a whim I did it. It went through just fine, but without any instructions. I knew, however, you must either logoff/login or reboot, so I rebooted. Sysinfo now shows the nvidia driver and kernel.

Now I am using desktop effects with no problems so far; could not do that before as it caused frequent freezeups. Also couldn’t get ATI proprietary drivers to work; had to reinstall suse after trying that. So, props to nvidia and the suse wiki.