Newbie - Needs to Network Wirelessly

so after that toungetwister of a title, Id like to introduce myself to everybody,
Hello My name is Martin,… Newbie on the Forum, Newbie to Linux, Well… sort of
I’m a Computer Engineer By Trade (10 years experience), i am very competent working with all aspects of Windows, Networking, wireless blah blah blah blah, you get the idea, basically i know my stuff, i’m also good on Apple Platforms

Linux is what i’d like to learn, so Howdy to all and i hope to speak to you all regularly
in short, I started with Ubuntu Linux about 6 months ago, Didn’t like it, i researched various distro’s and came across, PC Linux OS, it was really cool, But i couldn’t get it to connect Wirelessly, so i tried something else… the bottom line is i finally settled on SUSE Linux Enterprise Desktop 11, i seem to like it a lot.

Ok… now that introductions are out of the way

Background info: I’ve installed SUSE Linux Enterprise Desktop 11 on my Sony Vaio Laptop (VGN-NW15G) with no major issues, after a bit of mucking around, i got the LAN to Connect to the internet, after some more mucking around, i figured out how to get the WLAN to connect to the internet.

MY Goal: To be able to Wirelessly Network my Laptop with My PC. so that i can access the files on the PC, From my laptop, and Vice Versa, but the important thing is to first be able to access the PC files from the Laptop.

NOTE: My PC has 4 Hard Drives (1 for the O/s, 3 Backups) they are all configured and Shared correctly for Networking and Wireless networking, and all the permissions are set correctly.

Hardware and Software Environments:
My Laptop : Sony Vaio VGN-NW15G
Operating System : SUSE Linux Enterprise Desktop 11
Wireless Capable, and has no issues Wireless Networking when running of a Hard Drive Loaded with Win 7 Ultimate 32bit, Therefore all Hardware is Compatible

My PC (Custom Built)
Operating System : Windows 7 Ultimate 64bit SP1
Motherboard: Gigabyte GA-X58-UD3R Rev1.0
CPU : Intel Core i7 930 2.80Ghz (4Cores)
RAM : Kingston 6 x 2GB DDR3 1333Mhz Total 12GB Ram
Hard Drive 1 (Primary Hard for the O/S) Seagate Baracuda 500GB SATA
Hard Drive 2 (Backup Hard Drive) Seagate Baracuda 1TB SATA
Hard Drive 3 (Backup Hard Drive) Seagate Baracuda 1TB SATA
Hard Drive 4 (Backup Hard Drive) Seagate Baracuda 1TB SATA
Floppy Drive
Kick Ass Graphics card

Network Printer : Samsung CLX-6210FX IP Address Subnet
Default Gateway Network Name SamsungCLX6210
(Connected via Ethernet CAT 6 to my 16 Port Switch, Which is connected to my Router)

Network Name : BTO Server, IP Address, Subnet Default Gateway

there are a few other network devices which are not really relevant at this stage
PS3, Nintendo Wii, 2X Foxtel IQ2 Box

But, Basically all Devices in the House Connect directly to my 16 Port Switch (which is not faulty), Via CAT 6 Ethernet Cable, 2 Devices Connect Wirelessly
Now to achieve Wireless Capability, i have (on Port 1 of the switch), I’ve got a 4 Port Router/Modem (Netgear DG834GSP Firmware Version V1.04.05 )

so… after all that, the short story is
Everything works under Windows, the Hardware is fully functional and the Network is not Problematic,
When Running SUSE Linux Enterprise Desktop 11 2.6.27, from my laptop i am able to Connect to the internet Wireless of Lan, whichever i wish

but i can’t Seem to network my printer and My PC wirelessly with my Laptop
I want to be able to Print From Laptop to Printer
I want to be able to have full access to all Files , Pictures, Docs, Music Etc… that are located on my PC,… From my Laptop

I think this is just a question of , Me not knowing how to correctly Configure Network sharing under Linux,

Note:My Linux system is setup so that i have root priviledges but i’m not the root account, my login is “martin”
also note that i have gotten as far as … when i access Network File Browser, i can see the following icons BTOSERVER LINUX-80EK SFTP File Transfer on linux-80EK WINDOWS NETWORK

I figure some of these network locations need to be deleted.
When i open the WINDOWS NETWORK, I see WORKGROUP, when i open WORKGROUP i See BTOSERVER and LINUX-80EK once again
When i try to open BTOSERVER
It says “OPENING BTO SERVER” I Then have to wait a little
and then i get “Unable to mount Location” “Failed to retreive share list from server”
if i go back to Network Browser and click on BTOSERVER it does the same thing
at times when i click on BTOSERVER (from either location) a box pops up requesting authentication, the username is martin (looks ok) the workgroup is WORKGROUP (looks ok) and it asks for a password,
No doubt this is the password to access the PC, the problem is the PC is not password protected, i’ve tried all passwords that i know, passwords for the router, the sony laptop, nothing works

I’ve gotten somewhat familiar with YaST Control Center
and i’ve made some changes thus far which have allowed me to at the least “See the network locations” the problem seems to be mounting the location and / or Password authentication, but the passwords are definitely correct, the PC has not password, other than the homegroup password supplied by windows 7, Tried it, still does not work.

simply stated the changes /configurations in YaST that i’ve made are:
I’ve been to Firewall Configuration
Firewall auto start on start up is ON
Interfaces : Marvell Ethernet Controller eth0 No Zone Assigned
AR928X Wireless Adapter wlan0 Internal Zone
Custom String any External Zone

Allowed Services : CUPS, DHCP Server (Protect firewall from internal zone is UNchecked)
masquerading - there is nothing in here
Broadcast configuration : internal zone (there is blank field and to the right of it is checked “Log not accepted Broadcast Packets”
Demilitarized zone (there is blank field and to the right of it is checked “Log not accepted Broadcast Packets”
External zone (there is blank field and to the right of it is UN-checked “Log not accepted Broadcast Packets”
below this is an empty field “Accepting the broadcast reply”
IPsec - there is nothing here
Logging level - there is nothing much here
Custom rules - nothing is added here

other settings that i believe are relevant under “security and Users”
Local Security - there is nothing major here, Predefined Security is “Networked Workstation” Password Encryption is Blowfish (not too sure what this is) File permissions are “Easy”

then in User and Group managment everything seems ok
but… Authentication Settings read as follows
servers : Not yet configured
Domain : Not yet configured
Client Enabled : No

Base DN dc=example, dc=com
Client enabled :No
LDAP TLS/SSL Configured

KDC Server 9.5.0-P2
Default Domain : WORKGROUP
Default Realm :

Under Network Services
Windows Domain Membership Seems to be all ok

Host Names Seem a bit funny

IP Address Hostnames Host Aliases SonySLED11 WORKGROUP SonySLED11
::1 localhost ipv6-localhost ipv6 loopback

the IP addresses should be and
i’m not sure what all the ff00 stuff is

and finally under Network Devices
Network Settings
Global Options is “Traditional Method with ifup”
IPv6 is enabled

Overview has both adapter LAN and WLAN via DHCP+AUTOIP (LOOK OK)
Checked Change Hostname via DHCP
checked write Hostname to /etc/hosts

Default Gateway field is Empty
Routing table Indicates

Destination Gateway Netmask Device Options wlan

i can’t think of what else to do

Wireless Networking is not rocket science
Man i feel like such a Newbie

Can someone help me with this problem
Ahead of time : I greatly appreciate all assistance from anybody who is going to contribute to my Linux education from here on in

Thanks guys
Once again to recap, My Goal is I just want my Sony Laptop to be able to Wirelessly Access the Files on My PC (that are already configured correctly for sharing) as well as being able to print to my Network Printer


Welcome to the forums; however these are the openSUSE forums. SLED, as it says, is the Enterprise version which is different and has its own forums at SUSE PRODUCT DISCUSSION FORUMS

You may find that someone on these forums happens to know enough about SLED to be able to answer your question but you are more likely to get a response from the SLES/SLED forums.

Hi John, Thanks for that
Sorry for being on the wrong Forum
the Disc said Open Suse Linux Enterprise Desktop edition
therefore i thought it was ok to join the Open Suse Forum

i did make some progress, and i figure if i can get past this i’m right
What’s happening is that in the Network Folder (network///) (after some mucking around) i now have Windows Network and SFTP Fille transfer on Linux-80EK

When i open the “Windows Network” i get “WORKGROUP” (smb:///)
up until now, this seems like the normal procedure for adding a network location
Once Workgroup is opened i have “BTOSERVER” and “LINUX-80EK” (smb://workgroup/)

i then open “BTOSERVER” and i get a “Enter Password” Box
Username martin (seems ok, on the PC it’s Martin, I’ve tried both, doesn’t make a difference)
Domain WORKGROUP (Correct)
Password (the Pc doesn’t have a password)

I’ve tried the windows Home group password, I’ve tried the Router Password, I’ve tried the Network Password, I’ve tried no Password, I’ve tried Changing the username to Administrator and Admin with the above passwords

Nothing works

I’m pretty sure, if i get past this stage, i’m right
i mean Suse can see the Network and the BTOSERVER
it can connect to the internet, it seems to be just an authentication issue

Any Suggestions…

One other thing
after a few minutes , after having tried a password and failed
i get the following error

DBus Error org.freedesktop.DBus.Error.NoReply Message did not receive a reply (timeout by message bus)

Also John thanks for the link to the SLED forum, it took me a while to figure out how to post a thread, but i got it
and i’ve reposted the question there

thanks again mate, Be Cool