newbie needs help installing external graphics adapter driver

Hi Guys,

I’m trying to install an external graphics adapter for dual-monitor setup, and according to the installation instructions, the driver is libdlo, which requires libusb v0.13.

When I follow the installation instructions, I got an error saying I don’t have libusb on my OpenSUSE 11.2.

The exact installation instructions is as follows:

===============
libdlo README and Quick Start Guide

Prerequisites:

  • Install a compatible libusb version (0.13)
    • on ubuntu - “sudo apt-get install libusb”
  • Plug in a compatible DisplayLink USB device

To start the build process, open a shell prompt (as the user who’s home
directory the libdlo is installed into) and change to the libdlo directory
to run

$ ./configure
$ sudo make install
$ make check

Make check will do some basic drawing on the DisplayLink device.
The ‘sudo make install’ step will have installed libdlo.h, the main header,
in your local include directory, and libdlo in your local library.

(The error message comes out at $ sudo make install).

I noticed it mentioned Ubuntu, does this mean that it will only work in Ubuntu and wont work in OpenSUSE?
I hope not, I love OpenSUSE! I’m new to Linux and I’m not familiar with those commands in the instructions above, I can only guess them but don’t really know what each line of the instruction does exactly.

If libusb also applies to OpenSUSE, how can I get it installed on my system? Can anyone please help explain what will happen at each stage of the installation above, please? Any help would be appreciated :slight_smile:

Cheers!

Check what

zypper se libusb

tells you (run it in a console).
Or open yast software installer and serch for libusb to see if it is
installed. (Maybe you need the devel package also installed).

First things first. Welcome to these forums.

You say you got an error saying … We love to see errors in their exact wording. Please next time cut and paste (and put between CODE tags) any computer input/output that may be of value to those who try to help you in your thread.

You can check with YaST > Software > Software Management if you have libusb installed. On my 11.2 system I have
. libusb-1_0-0 version 1.0.2-2.2
. libusb-0_1-4 version 0.1.13-2.2
and as I can not remember that I did that on purpose I suppose it came in by default during the install.
According to the description the last one seems to be a compatibility layer of libusb-0 to libusb-1. Irtis all a bit cryptic and I do not know if the special version your software requires fits in here.