Newbie install of Tumbleweed

I’m currently running Manjaro KDE 20.0.3 testing build and want to test openSUSE Tumbleweed with the KDE Plasma desktop. What I would like to setup for the OS is the default EFI / boot patition and the rest of the drive a single BTRFS for Tumbleweed with a swap file instead of a swap partition. Would like to know if this would be a problem with Tumbleweed? Thanks

**System:    Host:** Secret-Computer **Kernel:** 5.7.0-3-MANJARO x86_64 **bits:** 64 **Desktop:** KDE Plasma 5.18.5  
           **Distro:** Manjaro Linux  
**Machine:   Type:** Desktop **Mobo:** ASUSTeK **model:** ROG STRIX B450-F GAMING **v:** Rev 1.xx  
           **serial:** <root required> **UEFI:** American Megatrends **v:** 3003 **date:** 12/09/2019  
**CPU:       Topology:** Quad Core **model:** AMD Ryzen 3 3200G with Radeon Vega Graphics **bits:** 64  
           **type:** MCP **L2 cache:** 2048 KiB  
           **Speed:** 1250 MHz **min/max:** 1400/3600 MHz **Core speeds (MHz):****1:** 1209 **2:** 1209 **3:** 1209  
           **4:** 1209  
**Graphics:  Device-1:** NVIDIA TU116 [GeForce GTX 1650 SUPER] **driver:** nvidia **v:** 440.82  
           **Display:** x11 **server:** X.Org 1.20.8 **driver:** nvidia **resolution:** 2560x1080~60Hz  
           **OpenGL:****renderer:** GeForce GTX 1650 SUPER/PCIe/SSE2 **v:** 4.6.0 NVIDIA 440.82  
**Audio:     Device-1:** NVIDIA TU116 High Definition Audio **driver:** snd_hda_intel  
           **Device-2:** AMD Family 17h HD Audio **driver:** snd_hda_intel  
           **Sound Server:** ALSA **v:** k5.7.0-3-MANJARO  
**Network:   Device-1:** Intel I211 Gigabit Network **driver:** igb  
           **IF:** enp4s0 **state:** up **speed:** 1000 Mbps **duplex:** full **mac:** a8:5e:45:55:75:ae  
**Drives:    Local Storage:****total:** 4.44 TiB **used:** 2.87 TiB (64.6%)  
           **ID-1:** /dev/nvme0n1 **model:** Viper M.2 VPN100 **size:** 238.47 GiB  
           **ID-2:** /dev/sda **vendor:** Samsung **model:** SSD 850 EVO 120GB **size:** 111.79 GiB  
           **ID-3:** /dev/sdb **vendor:** Western Digital **model:** WD10EARS-00Y5B1 **size:** 931.51 GiB  
           **ID-4:** /dev/sdc **type:** USB **vendor:** Seagate **model:** Expansion **size:** 1.82 TiB  
           **ID-5:** /dev/sdd **type:** USB **vendor:** Seagate **model:** ST31500541AS **size:** 1.36 TiB  
**Partition: ID-1:** / **size:** 115.62 GiB **used:** 65.37 GiB (56.5%) **fs:** ext4 **dev:** /dev/nvme0n1p2  
**Sensors:   System Temperatures:****cpu:** 40.0 C **mobo:** N/A **gpu:** nvidia **temp:** 31 C  
           **Fan Speeds (RPM):** N/A **gpu:** nvidia **fan:** 75%  
**Info:      Processes:** 318 **Uptime:** 12h 59m **Memory:** 7.76 GiB **used:** 3.43 GiB (44.2%) **Shell:** bash  
           **inxi:** 3.0.37

Hi, welcome to the forums,

Nope, that would not be a problem, though the swapfile would be somehing to do after the install. It’s documented here https://en.opensuse.org/SDB:Partitioning#Creating_a_swap_file

Agreed, should not be a problem.

Anyone new to openSUSE might find the slide deck for my openSUSE presentation useful…
Covers pre-install, install and some recommended first steps after install plus some misc other things to know.

http://slides.com/tonysu/opensuse

TSU

Please Tony, promote the openSUSE docs, wiki instead. Help out to improve those. The project and the community benifit from that.

This paragraph from openSUSE:Tumbleweed installation - openSUSE Wiki is puzzling, doesn’t work:

To verify the signature, download the .sha256 file and run gpg --verify on it. The file must be signed by opensuse@opensuse.org with fingerprint 22C0 7BA5 3417 8CD0 2EFE 22AA B88B 2FD4 3DBD C284. Then run sha256sum --check on the sha256 file to make sure the iso is intact.

Any idea?

Can you provide a link? Thanks

https://en.opensuse.org/Portal:Installation

It is out of date. That used to work.

Current procedure:

  1. Download the iso file that you want (file name ends in “.iso”).
  2. Download the corresponding “sha256” file (name ends in “.iso.sha256”)
  3. Download the correspnding “.asc” file (name ends in “.iso.sha256.asc”)
  4. Verify the gpg signature with
gpg --verify *.sha256.asc *.sha256
  1. Verify the sha256 checksum with
sha256sum -c *.sha256
  1. Burn the “.iso” to a DVD or write to a USB flash drive as needed.

That should work until they change things again :stuck_out_tongue:

karl@erlangen:~/Downloads> LANG=C gpg --verify openSUSE-Tumbleweed-NET-x86_64-Current.iso.sha256.asc openSUSE-Tumbleweed-NET-x86_64-Snapshot20200609-Media.iso.sha256
gpg: Signature made Tue Jun  9 19:16:49 2020 CEST
gpg:                using RSA key B88B2FD43DBDC284
gpg: Can't check signature: No public key
karl@erlangen:~/Downloads> 

I am clueless.

I meant to add that people who are not experienced with using “gpg” can just skip steps 3 and 4.


gpg: Signature made Tue Jun  9 19:16:49 2020 CEST
gpg:                using RSA key B88B2FD43DBDC284
gpg: Can't check signature: No public key

When I see that, I would do:

gpg --recv-key B88B2FD43DBDC284

That should download the signing key from a keyserver. And then repeat the signature verification. But this time you would get a message that the signature is okay, but not trusted. You would have to sign the downloaded key with your gpg key to avoid that.

In all honesty, using gpg isn’t for everyone. The learning curve can be steep.

I tried to improve on the introduction: https://en.opensuse.org/openSUSE:Tumbleweed_installation

I looked at the “Verify Download” section, where you get: gpg: Can’t check signature: No public key

Here’s the output I get, with a recent NET iso:


% gpg --verify openSUSE-Tumbleweed-NET-x86_64-Snapshot20200609-Media.iso.sha256{.asc,}
gpg: Signature made Tue 09 Jun 2020 12:16:49 PM CDT
gpg:                using RSA key B88B2FD43DBDC284
gpg: Good signature from "openSUSE Project Signing Key <opensuse@opensuse.org>" [full]

% sha256sum -c openSUSE-Tumbleweed-NET-x86_64-Snapshot20200609-Media.iso.sha256
openSUSE-Tumbleweed-NET-x86_64-Snapshot20200609-Media.iso: OK

The difference from your output is mainly that I have the openSUSE Project key on my gpg keyring, and I have set it as trusted. The “[full]” is a reference to that trust level I have assigned.

There doesn’t seem to be an easy way to migrate web content to the preferred openSUSE documentation (You’d think there should be).

Anyone is welcome to do the work manually if that’s what it takes, or to create their own.

Until something comparable is created,
IMO the content I’ve created is either provided or isn’t available at all.

And frankly…
Although I understand the reasons for way documentation is generated, it’s not practical or friendly to anyone who has better things to do than learn how it works (and set up properly).

TSU

Also quite frankly: I don’t see the URL you provided with the slides on a kind of cube gimmick would actually help people. A conversion from such proprietary stuff won’t happen anyway. Mind, I’m not saying a wiki page is easy to maintain, but you can see the source of any wiki page, copy it, create a new page, paste the content and edit to your needs. My issue is that you bind your wiki pages to your user:Tsu2 account ( same effort as using the official wiki ) instead of creating those pages on the official wiki. The difference is that your way contributes to user:Tsu2’s wiki, the other way to the openSUSE wiki.

BTW -
Some people may notice that when presentation slide decks are published individually on the Internet,
It’s very useful.
So, for instance the standard way of storing presentations in conventional form like Libreoffice Present would require a person to find the file (perhaps a link download), open the presentation (requires the app), and then click through each slide to the relevant slide.

Using the site where I store my presentation slide decks today…

  • They’re available to anyone on any machine running any OS that has an Internet connection and a web browser. I’ve given presentations on a borrowed computer without a problem, no sneakernet, no copying files, etc.
  • If only one slide is relevant to a conversation, it’s immediately available. No mess, no fuss, no complications and access with a single click.

If anything, openSUSE should consider purchasing an account (which might not even be required, but would help fellow FOSS) and recommend all presentations be created and stored at this site which would greatly improve accessibility for all openSUSE presentation content.

IMO,
I am just reluctant to backtrack from what I’ve found works better than old ways

TSU

Wiki pages are ok for other types of articles,
But don’t support presentation format or use.
It’s possible to force a round peg into a square hole by manually linking wiki pages in a sequential order, but that’s work, especially to manually create those links.

Assume you’re talking about the slides.com link I provided, and not from my openSUSE Wiki.

TSU

The pages in User:Tsu2 are NOT the openSUSE wiki. You don’t get my point. Yours are private personal projects in the openSUSE Wiki infra. NOT openSUSE Wiki pages. I think that’s a shame. And I don’t see any valid reason for doing things your way to be honest.

Me neither. The wiki pages are reasonably easy to contribute to, and designed to be reasonably succinct, and free of waffle.

At least in this Forum thread, I don’t think I’ve posted anything from my personal Wiki.

It’s true though about my personal Wiki,
The things I put in my personal Wiki are typically just random stuff I run into from time to time, feel it’s important enough to write about it, and post it mainly for my own reference so that I don’t have to look it up again months or years later. The things I post are my personal musings and not written with the kind of attention to detail I write for something that’s primarily for Community (like the SDB:VMware Tools I wrote).

The SDB went through many revisions both major and minor (you can see most of the changes in the History) and is the best I’ve seen written on that topic.
The articles in my personal Wiki don’t go through the same process, if they’re error free that’s more a matter of luck and definitely don’t go through any review. Additionally, I don’t feel any responsibility to update my personal Wiki articles up to date, a number of them are obsolete for various reasons.
You can compare the quality against the SDB, which has and continues to stand the test of time, completely accurate and relevant with hardly a change from when it was finished (and I’ve used it as a reference for other distros as well).

That’s why what is in my Wiki is not made to be a Community reference.
If someone wants to create a Community reference using content from my Wiki article, that’s fine with me… I don’t object to information I compiled from others to in turn be used for someone else’s article.
If someone wants to use the info in my Wiki as-is, that’s OK, too. I don’t know that Wiki articles are easily found in an openSUSE search anyway, and like almost anything else can be found in an Internet search.

In fact, I’d be tickled to think that someone might find content I created helped someone understand the topic well enough to create their own, high quality article.

TSU