Newbie! ATI Help!

This evening I sat down to finish the thing that has been my nemesis for three days straight:

“FIX MY ATI x1200 integrated video card on my Toshiba A215 laptop.”

-Taken from: “thereapers Personal Goals” c2009 -I Hate this Laptop Publishing-

I have tried everything I can think of. I have SaX2 -r -m 0=fglrx’d it. I have aticonfig --initial’d it, and I have even smacked it violently in its blank-screen-no-mouse face. Nothing has worked. Does anyone have a Toshiba A215 who has gotten their ATI x1200 to work? How about someone with an ATI x1200 in general? Can anyone give me a SIMPLE and CONCISE guide to installing the driver?!?

Thanks in Advance,

Have you visited ATI site to see if they provide a driver for x1200?

I have installed the ATI driver several times. It installs ok but after I do the

aticonfig --initial

and log out to init 5, I cant get back into the xserver. When I run


it cuts to a black screen where NOTHING is visible.

EDIT: Ctrl+Alt+F1 does nothing when screen cuts to black after “startx.”

I did all that including smacked it in its blank, rebellious face.

There is a very last resort before you burn the laptop. Use the command:

aticonfig --initial --input=/etc/X11/xorg.conf

but it’s REALLY important to set up the file “xorg.conf” with vesa settings first, before you run it, or it will just do a blank face.

Here’s the full deal: ATI works in 64 bit – doesn’t work in 32 bit - openSUSE Forums

but essentially you do this:
uninstall the fglrx RPMs so ati is out of the system
run sax2 and get vesa drivers going and squared away in xorg.conf.
Then get a GUI with command: startx
then reinstall the fglrx RPMs
then run the special init command: aticonfig --initial --input=/etc/X11/xorg.conf

Worked for me – maybe it will work for you. Luck.

Please explain “run sax2 and get vesa drivers going and squared away in xorg.conf.” I’m fairly new to linux and that means absolutely nothing to me. LOL, thanks in advance.

Guys, fglrx does NOT support x1200! And it never will. 9.3 was the last version to support it, but it doesn’t work with recent X. Now the only chance is the radeon or radeonhd driver. Or use Debian Stable, which has X old enough (1.5 I think). But in a recent distro, there’s no way to get it working. However radeonhd works out of the box for me (I have the same card), though I don’t get the performance I used to get with fglrx.

True but openSUSE 11.1 also comes with version 1.5.

radeonhd can be installed from Yast → Software

I don’t understand recent posts relative to version support, specifically “X old enough ver 1.5”.

The ATI Catalyst 9.3 page at ATI Catalyst™ Proprietary Display Driver claims support for X-1200.

It does appear that later Catalyst’s will not.

Catalyst 9.3 also supports up thru 7.4.
My x86_64 installation is xorg-X11 7.4-8.20.1

All that said, I can’t get the 9.3 fglrx running either, on my X-1250 integrated platform.

It appears that ATI continues to use fglrx name beyond Catalyst 9.3, which promises confusion into the future; but how much worse can it getlol! ?

HORYCOW! I got it working. I will post back shortly to let everyone know how!!!

Oh, sorry for the disinformation. My fault.
Anyway, when I realized that it could work, I’ve tried it (via the install script on ati website), but the computer just restarted when trying to run X. Probably it doesn’t like my 2.6.31 kernel…

I’m glad, thereaper, that you solved it and I’m looking forward to see how did you do it.

Well, at least I strongly suspect that building the catalyst 9.3 kernel module against 2.6.31 won’t work without patches (if at all).

Step by step instructions for installing the ATI Radeon x1200 integrated graphics card (proprietary driver installation) on openSUSE 11.1:

Note: This was done on a Toshiba Satellite A215 which has a 64 bit Archetechture CPU and HAS NOT been tested on a 32 bit CPU)

First, make sure you have the following software packages installed via YaST (go to Computer->YaST->Manage Software [then select packages in the “Available” tab that are missing from the “Installed” tab]):


Next, run the following commands in the command line (terminal) by pressing “Ctrl+Alt+F1” (this prepares the kernel for the installation):

# su
   # cd /usr/src/linux
   # make mrproper
   # make cloneconfig
   # make modules_prepare
   # make clean

After you are done, type startx to restart the X-Server.

Now, if you have tried to install the proprietary driver in the past, you should run the following in the command line:

# rpm -e $(rpm -qa '*fglrx*')

Even if you have not tried to install the driver in the past, gcc will have attempted to install it if you had to download gcc. Thus, it’s probably a good idea to go ahead and run that command anyway.

Next, prepare SaX2 by entering the following in the command line:

SaX2 -a

Now that we have SaX2 prepared, the kernel prepared, and any previous version of “fglrx” uninstalled, we need to download the driver. Go to

Select Linux->x86_64->Integrated/Motherboard->Radeon Xpress 1250 (yes I know you have an x1200), and select GO! When the new page loads go all the way to the bottom and download the driver. Now run:

su -
# sh ati*.run --listpkg
# cd /directory_where_you_generated_the_rpm
# rpm -Uvh fgl*.rpm

When the installer appears select Generate Distribution Specific Driver Package->SUSE Packages->SUSE/SUSE11.1 AMD 64. When that is done, run:

# aticonfig --initial --input=/etc/X11/xorg.conf

Now reboot. When the system restarts and you see the GRUB screen, press backspace to delete “vga=317,” (or whatever it may say) press “3,” and hit enter. This will take you to the command line that you are now beginning to love. Run the following:

# sax2 -r -m 0=fglrx

Now one more time, just to verify the xorg.conf file, run:

# aticonfig --initial --input=/etc/X11/xorg.conf

That should do it! If you want to double check though, open a terminal and enter:


This should show the card as an ATI x1200 and should also say “fglrx.” If it does not, you probably missed a step. If that happens run:

# rpm -e $(rpm -qa '*fglrx*')
# startx

This should remove the faulty driver installation and let you begin again from the X-Server.


Good Luck,
thereaper :wink:

Congratulations – that’s a fine achievement.

To: thereaper
Most promising update to the ATI mess in a long time.

Where did you find
expat-32 bit?

They don’t show on 11.1 repos

I downloaded all software packages that were similar to the packages you listed. If you install compat (expat is included in your installation and is a hybrid version of expat-32bit and expat-x86_64) you should be able to run the ATI software package no problem.