Newb with dual boot issues

Hello all,

I have been trying to get this to work for a few days now. I’m missing something in my config file that will make this work right.

I am going to dual boot from two different hard drives.
Suse is on hd0 and Windows is on hd1 I tried to map the drives but I think it is wrong.

Linux will boot fine, but when I try to boot windows it just reboots. I have attached a copy of my grub config.

Modified by YaST2. Last modification on Wed Apr 15 00:39:50 EDT 2009

default 0
timeout 30
##YaST - generic_mbr
gfxmenu (hd0,1)/boot/message
##YaST - activate
map (hd0) (hd1)
map (hd1) (hd0)

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 - 2.6.27.21-0.1
root (hd0,1)
kernel /boot/vmlinuz-2.6.27.21-0.1-pae root=/dev/disk/by-id/ata-WDC_WD5000AACS-00G8B1_WD-WCAUK$
initrd /boot/initrd-2.6.27.21-0.1-pae

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.1 - 2.6.27.21-0.1
root (hd0,1)
kernel /boot/vmlinuz-2.6.27.21-0.1-pae root=/dev/disk/by-id/ata-WDC_WD5000AACS-00G8B1_WD-WCAUK$
initrd /boot/initrd-2.6.27.21-0.1-pae

###Don’t change this comment - YaST2 identifier: Original name: Windows XP###
title The Hog XP – Windows XP Hard Drive 2
root (hd1,0)
chainloader +1
makeactive

We need to see

/etc/fstab

tell us which partition in the list is actually the XP install as opposed to any XP recovery partitions.

I’d be inclined to take out these three lines:

##YaST - activate
map (hd0) (hd1)
map (hd1) (hd0)

and to make the windows entry like this:

###Don’t change this comment - YaST2 identifier: Original name: Windows XP###
title The Hog XP – Windows XP Hard Drive 2
map (hd1) (hd0)
map (hd0) (hd1)
rootnoverify (hd1,0)
makeactive
chainloader +1

Awesome, now it makes sense how to set it up… thank you it worked great!:slight_smile: