New with OpenSuse, Help!

Hi, I’m new with linux and I decided to install OpenSuse on my desktop computer.

I downloaded the live cd to install it but there is a problem with it,
When it loads the menu I select the first option and… when it loads completely I get into a text mode (like ms-dos) asking me for my login

I see that the screen flashes about 4 times before enter in text mode

how can I get into graphics mode??

Thank you.

This is what it shows:

**starting smartd

gdm [3566]: Warning: GdmDisplay: display lasted 1,621771 seconds

X server log errors

Master resource Control: runlevel 5 has been
skipped services in run level 5

Welcome to Open…**

I try to login with root and I try to start the graphical mode but it gives me this message:

**Fatal server error:
no screen found
givingup

Xinit: Connection refused (errno 111): unable to connect to X server

Xinit: No such process (errno3): Server error.**

Sounds like you had a bad cd. Did you check the md5sum?
If you can download the dvd it’s more complete

/Geoff

Hi!!

Finally I installed it!! but now I have a new problem…

I have to put

  sax2 -m 0=vesa

and then I configure my screen :slight_smile:

but now… now I have other problem with the resolution of my screen once I change vesa to nvidia to activate 3d graphics, it only let me work with 800x600!

Here is my xorg file

Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “Module”
Load “glx”
Load “dbe”
Load “extmod”
Load “dri”
Load “freetype”
EndSection

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “es”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “10”
Option “Device” “/dev/input/mice”
Option “Name” “Logitech Cordless Desktop Optical”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
DisplaySize 305 230
HorizSync 31-64
Identifier “Monitor[0]”
ModelName “1280X1024@60HZ”
Option “PreferredMode” “1280x1024”
VendorName “–> VESA”
VertRefresh 50-60
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
EndSection

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1280x1024” “1280x800” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x1024” “1280x800” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x1024” “1280x800” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x1024” “1280x800” “1024x768” “800x600”
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
EndSection

Section “Device”
BoardName “GeForce 8600 GT”
Driver “nvidia”
Identifier “Device[0]”
Screen 0
VendorName “NVIDIA”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
EndSection

Edit: Didn’t see that you had reconfigured with nvidia driver

From a console, what does the following command report?

xrandr -q

Hi,

I said that the resolution was 800x600 but is 640x480

**
Screen 0: minimum 320 x 240, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
640x480 50.0* 51.0
512x384 52.0
400x300 53.0 54.0
320x240 55.0**

Have you tried adding a modeline for “1280x1024” as described in your other thread?

You could try:

Modeline “1280x1024@60” 114.98 1280 1312 1744 1776 1024 1045 1055 1076

I try this but it gives me the same problem. :frowning:

THe value 0 in the section device, screen, is normal?

Try changing the monitor via sax2 graphical utility. I’m guessing you’re using an LCD monitor. Try one of the generic options with same native resolution as your device, then save and restart X.

Something else worth trying: With recent Xorg versions, X probes your hardware to get available resolutions (as reported by xrandr). Sometimes it doesn’t work well, and it is necessary to disable EDID probe with

Option “UseEdidFreqs” “False”

Add this to your Screen section if required.

I try with the lcd default configuration, but all is the same. I will try now to add this line.

My xorg was:

Section “Module”
Load “dbe”
Load “freetype”
Load “dri”
Load “glx”
Load “extmod”
EndSection

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “es”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “10”
Option “Device” “/dev/input/mice”
Option “Name” “Logitech Cordless Desktop Optical”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
DisplaySize 305 230
HorizSync 31-81
Identifier “Monitor[0]”
ModelName “1280X1024@75HZ”
Option “PreferredMode” “1280x1024”
VendorName “–> LCD”
VertRefresh 58-76
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
Modeline “1280x1024@60” 114.98 1280 1312 1744 1776 1024 1045 1055 1076
EndSection

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1280x1024” “1280x800” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x1024” “1280x800” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x1024” “1280x800” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x1024” “1280x800” “1024x768” “800x600”
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
EndSection

Section “Device”
BoardName “GeForce 8600 GT”
Driver “nvidia”
Identifier “Device[0]”
Screen 0
VendorName “NVIDIA”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “Extensions”
Option “Composite” “off”
EndSection

Regarding my last post, that should have been Device section.

Adding this to device and nothing happens… :frowning:

My monitor is Benq FP71E+

I’m getting desperate xd

Why only let me get this resolutions? 640… and under :S ?

When I go to the screen configuration panel to change the resolution (640… etc) it put at the top Unknown, why?

Are you sure you’re using correct nvidia driver for your graphics chipset? What model card?

My model card is nvidia 8600gt. I didn’t install nothing by my own, only the predefined by the system. should I install any package?

I see one thing: I have the monitor set to 15" and when i change to 17 it shows me an error

Error saving the configuration
**
Sax library: succeeded
X configuration: Parse error on line 97 of section Modes in file /var/lib/sax/xorg.conf… parse error on line 98…**

When I put this into the gnome console shows me:

Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
Error: couldn’t find RGB GLX visual
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.

the parse error is in this line

Modeline “1280x1024” @60 114.98 1280 1312 1744 1776 1024 1045 1055 1076

Nvidia Installer HOWTO for SUSE LINUX users

Oh sorry!!, yes I have installed the drivers!!.. :frowning: :frowning: :frowning:

I’m getting crazy…

In the web it says that:

a) x11-video-nvidia + nvidia-gfx-kmp-(kernel_flavor)

or

b) x11-video-nvidiaG01 + nvidia-gfxG01-kmp-(kernel_flavor)

or

c) x11-video-nvidiaG02 + nvidia-gfxG02-kmp-(kernel_flavor)

But I have x11-video-nvidia and x11-video-nvidiag02 :S

HI guys
Actually i am new to this forum i don’t know how to start a new post (like ask question) can anyone help

the parse error is in this line

Modeline “1280x1024” @60 114.98 1280 1312 1744 1776 1024 1045 1055 1076

The syntax was wrong. Should be like this:

Modeline “1280x1024” 114.98 1280 1312 1744 1776 1024 1045 1055 1076