New user needs installation help

Greetings everybody! I moved to linux completely about six months ago. I have been a reader of this forum some time and have been using Opensuse on a live disk. This morning I decided to install it as my operating system. I have been trying to install KDE 11.2. This installation fails everytime near then end of the auto configuration. I have checked my cd for errors (there were none) and I do not have anything plugged into the computer. I did not mess with the setup settings (I totally wiped the hard drive of my former Linux OS). When I reboot the computer it goes from the boot process into tty1. What can I do? Should I try to download a new install disk or is there something I can try from tty1? Please help!

Maybe try logging in as root, then ‘sax2’, then ‘exit’ and log in as normal user, then ‘startx’. Or more likely same process but ‘sax2 -r -m 0=vesa’ instead.

What is the graphics card?

What command do I use to login as root? (I have only done that once in my brief linux career). It will let me login under the name I set up during installation. Right before it goes into the terminal it gives an earlyxdm error in stage 5 if that is relevant.
Please let me know and I will try the commands you suggested.

I am running AMD Athlon 64x2 dual processor 874.7 Mib memory.

I truly appreciate the help.

At the login prompt type:

root

Then hit enter. Then type in your password.

If you’re already logged in as a regular user, type

su. Then enter, then type your password.

Rifester wrote:
> What command do I use to login as root? (I have only done that once in
> my brief linux career).

ok, you wrote: “When I reboot the computer it goes from the boot
process into tty1.”

Confuseling wrote: “Maybe try logging in as root . . .”

so, to answer your current question:

when you get to the tty1 you mention, it show a prompt like:

[machine name] login:

all you have to do is type root and press enter…

then, it will ask for the root password (which is the same as your
password unless you did the RIGHT thing an assigned a STRONG password
for root when you were on this page during install
<http://en.opensuse.org/INSTALL_Local#Step_7:_Create_your_user>

when you type in your root password you will not see what you type,
but it is there…then press enter and the color of the prompt should
change to red (to remind you to be CAREFUL)…

following Confuseling remedy (which btw i’ve not vetted) when you get
to “log in as normal user”, that means to first type exit and
press enter (the red will go away) then type YOUR id, and give your
password when asked…

ok?


palladium
Have a lot of fun…

I feel real stupid about the root login, I thought it would say root when I logged into it. I should have realized what the red meant. Anyhow, I logged into root, typed in sax2, then logged in as myself and typed startx… And like magic I could see my beautiful, shiny KDE desktop (thank you so much!). I don’t know what all of this means but I tried rebooting and it brought me back to the terminal. So I assume, this means I need to make some changes from here. If you can help me with this and then getting my Broadcom 4311 wireless card up and running you will be able to add me to the OpenSUSE ranks! So, what should I do next?

PS my graphics card is an ATI Tech Inc., radeon express 200m.

Please Help!

Does logging in and running ‘startx’ without the sax2 bit work?

Afraid this one’s beyond me.

I would suggest maybe searching the forums for ‘lost gui’ or ‘black screen at boot’, and reading some of what turns up - you might find a clue.

Otherwise, someone will probably come along with an idea at some point…

Please don’t bump threads unless it’s been a day or two - the forums can be slow, but they tend to get there in the end.

It does get me into the desktop but still goes into terminal when I reboot (it is not saving the changes). Sorry to bump the thread but I am without an operating system on my computer and just need help. I just found via a search that there is a know problem with my graphics card and it seems it may be over my head to fix. I don’t know why this is as I have had no problems installing any other system… It saddens me because I was really excited about Opensuse 11.2.

Rifester,
Before you go any further we are going to have our Final Release of OpenSuSe 11.2 for that reason may I suggest that you go just a couple to 3 more days wit your Present OS. While in it download yourself the full Install DVD. Then burn that DVD on the 12th & install from that. You might have no problem with that.
One more thing make sure all your vital stuff is backed up on some other device or disk. A new install will take out everything.
Finally, Welcome to Opensuse & its forum hope that you’ll be here for a long time!
Sorry to see you have no OS there’s guys here that’ll get you going.

Will the DVD contain all of the drivers for my video and wireless card? I cannot seem to get the wireless card set up. I guess I just don’t understand why my card would work fine with the live cd and then it would break upon installing… I don’t have a drive to burn DVD, just CD. I am accessing the net right now off of a live CD from another linux distro. I guess I will sit tight for a few days and figure out how to get a dvd if you think that would be the easiest way to go. Thanks again everybody for your help.

If you get something like this,using mine as an example

 login

then I’d do this type in my username so it’ll look like this

login:robbie

Then I’D prompted for my user password as I do that password will stay blank.
Now after that if you get something about have a lot of fun your in.
then where in my case I’d type in

robbie@dapc:su

then I’ll get prompted for my root password give that.
Once that’s done the font will be red that means you are in root.
If that happens try this

sax -r -m 0=vesa

After that if all has gone well you’ll see a bunch of stuff go by
when you get back to a red font with something like this
robbie #
Then type in reboot if all has gone well you should have something to look at.
If you succeed please do 2 things:

  1. tell us if you made it
    2.when it comes out get yourself the 11.2 Final in a day or so, install that & as we say here Have a lot of fun!

Best way to answer your vid & wireless inquiry.
If there is no video card detected the install will use VESA by default. It’s happened to me enough.
Wireless I’m not sure.
If you have a friend that’ll download it for you then you’re on your way. My experience is that when the release is new the Download on a good broadband connection will take about 4 hours.

Have you installed the ATI video drivers?

When I run the Sax2 -r -m 0=vesa command in root then startx in my login name it does allow me in the the KDE desktop. When I reboot the computer it returns to terminal (it will not boot into the desktop on it’s own). I have not installed any extra drivers.

Rifester, the program “sax2” creates (or modifies an existing) /etc/X11/xorg.conf file.

Note, logging in as “root” to an ascii prompt, and then running sax2 is not the best way to do this. I know, that is what you were suggested to do, but the user who recommended that has superior knowledge to you, and IMHO your problem stems from following that advice. When logged in as root (which you were) one should NEVER type “startx”.

Rather, what you should do, when the initial grub boot menu appears (where you get to choose openSUSE-11.2, openSUSE-11.2 fail safe, MS-Windows …etc ) is to press “3” (no quotes) so that “3” (no quotes) appears in the options line. Then continue with the boot. This will take you to the login prompt. This is called “run level 3”. At this time log in as a regular user. Do NOT log in as root if you have any other choice. Only if a user account has not been created can you then log in as root and in that case, the 1st thing you should do is create a new user account (easy to do with yast > security and users ).

So, once logged in as a regular user, type “su” (no quotes - enter root password). You have now switched to user with root/admin permissions, but with a difference, as it is easy to get back to a regular user.

Now type:
sax2 -r -m 0=vesa
and configure your graphics. That will create an /etc/X11/xorg.conf file.

When complete from sax2, type “exit” and that will get you back to a regular user. Then you can type “startx”. Do NOT type “startx” as user root. Your problems came from that. Or instead of typing “exit”, simply type “shutdown -r now” with root permissions which will reboot and this time do NOT press “3” when the boot menu appears. That should boot your PC to X window using the vesa driver.

The vesa driver is slow. If you wish better performance, you should use an openGL radeon driver (either “radeon” or “radeonhd”). To use those, you would type (similar to above) in run level 3:
sax2 -r -m 0=radeon
or if that does not work
sax2 -r -m 0=radeonhd

For the above sax2 commands I am assuming your PC has only one graphic hardware device. If it has 2 the commands may be different.

Note that the program sax2 is being used less and less, and is getting less and less support. If you wish, instead of running “sax2” as descibed above, you could run:
aticonfigwhich will also create and edit your /etc/X11/xorg.conf file, probably in a manner superior to that of sax2.

Think you’ve misread the quote…

I’d love to meet the guy…

…but we’re all innocent.

:wink:

**

Indeed, … I did read the post too fast, and best advice was given by all.

I tried switching between sax2 -r -m 0=vesa;radeon, & hd. Vesa is the only one that did not mess up the desktop display when I logged in. When I logged in after using =radeon & radeonhd the tool bar at the bottom of the screen did not stretch all the way across the screen. Switching bewtween all three did not boot me into the desktop upon reboot, I still got the earlyxdm error in level 5. I do not understand how to get the aticonfig command to work, I substituted aticonfig for sax2 and it would not do anything (gave me a command error). My question is this:
I am still not clear if a DVD install would help me with my problem… Would it?
Is it possible this could be a KDE problem with my machine?
Should I try to download the gnome version or do you think I will still have the same driver issues?
Should I give up, live with, and re-install my old OS?

Its possibly my error, and maybe “aticonfig” ONLY works with the proprietary driver which you do NOT have installed.