New Tumbleweed install, apache broke

Install is fresh download from OS website.

Command line only install, no GUI.

I added yast2-http-server (apache+php7 was already working just fine)

I thought i’d use it to create aliases, i went through a setup for it, which seemed odd. at the end it asked to install mod_php5, which I said no to.

Now I can’t get to phpMyAdmin, or any other folder under /srv/www/htdocs/

I’ve never had this happen.

after i uninstalled apache2 and php7 using zypper, i reinstalled and restarted.

Now I get prompted to download php files, instead of apache running them. What in the world have I done by trying to use the yast module?

Ok, I have it working for every fold EXCEPT phpMyAdmin???

Nothing I do, adding index.php to the phpMyAdmin.conf file, etc makes it work?

I’m stumped.

You should first install Apache using the LAMP pattern which sets up Apache, Maradb and PHP.
You can finish setting up and making any adustments using the YaST http-server module.
By doing that, you’re starting from a known and working configuration with all essential components likely needed for a typical PHP website.

You need to describe how you installed phpMyAdmin, where you downloaded it from and what reference or guide you used to install… or if you installed it from an openSUSE repo which likely sets everything up correctly with the least amount of effort.


TSU,I appreciate the response.
I installed the web dev package on installaction of tumbleweed, which installs php and mysql. Then I installed phpmyadmin through zypper. It was all working fine on local and for remote.

Then I decided to add some aliases. I installed the yast http module, and when I ran it, acted like apache had never been setup. After I finished, none of the folders under document root would work. First it was document not found, for anything.

After copying over apache config files and directories from another tumbleweed install, the other folders under docroot work fine. Phpmyadmin still just prompts to download the php file. Yes, the other install has phpmyadmin installed using zypper. Its identical as far as software.

I can find no difference in the config files. I have uninstalled apache and phpmyadmin and reinstalled, all using zypper. It doesn’t change anything. I even added a mime type for phpmyadmin to execute php, same problem.

If you’re downloading the php file instead of recognizing the php file as a web content file, then it probably means the Apache php module hasn’t been enabled.

Try running

a2enmod php

Then restart your apache service.


I really do appreciate the responses, but youre not reading what I’m saying.

The other sub folders under document root are working just fine for php, its only the phpmyadmin folder that isn’t working.

A2enmod -l shows the php7 module as loaded.

Check permissions.

I did. They’re identical to the other folders.

Possibly something in the conf.d/phpmyadmin.conf? I keep looking at it but don’t see anything wrong.

In copying over files from the other install, I must have fixed it.

Still not sure why Yast broke my HTTP, other than it still expects things to be PHP5 and i’m using PHP7.

I still feel it’s likely that your Apache php module setting was not applied to your website somehow.
Possibly related to how your phpmyAdmin site was set up, it’s somehow not inheriting your main Apache website setup.
In any case, from what you describe it appears that a configuration was copied along with your other files so you’re working fine now.

Glad you found your workaround,


FWIW: YaST doesn’t care about the php version.