New to the forum. I can no longer boot after the latest update.

I have successfully booted with the “nomodeset” option in GRUB, and I am able to chroot into it. Have you any idea how I may boot in normally? Thanks.

P.S. I do not have Snapper, so rolling back is not an option, alas.

EDIT: I am able to boot with kernel 4.12.

So you’re saying kernel 4.13 is a no-go for you unless you add nomodeset, -or- select kernel 4.12?

What do you mean by “I am able to chroot into it.” How did you chroot? and into what?

Show the commands you used.

Have you any idea how I may boot in normally?

If I understand part of what you said, you are adding nomodeset to the end of the kernel line. You should just then press F10 to boot normally with nomodeset active and this should get you up to the greeter where you can log in to the GUI.

To help you get back to a “normal” boot, the users here are not clairvoyant, so we need to know what Desktop Environment you are using, and will then need information about your graphics card, possibly a few other details.

Without that information, my own reply would simply be: “Beats the heck outta me.”:stuck_out_tongue:

Correct. Do you know of any troubleshooting steps I can take to see if this can be resolved before I report this as a bug? (If I ever figure out how to report bugs. :P)

Wait… you’re telling me that the average user here isn’t telepathic? Outrageous!

I’m dual booting with Ubuntu on a 1TB hard drive. I was able to boot into Ubuntu with Tumbleweed’s variant of GRUB without trouble. To chroot into Tumbleweed, I entered:

sudo mount /dev/sda6 /mnt
sudo chroot /mnt

“If I understand part of what you said, you are adding nomodeset to the end of the kernel line.” You are correct. That is the only way for me to boot with kernel 4.13 that I’ve discovered. I would like to not boot with any sort of “recovery” or temporary option like “nomodeset.” Inside a halfway functioning chassis I call a “computer” is an R7 360, an i5-4690K, an Asus Z97-A motherboard, and a satisfactory eight gigabytes of RAM.

Thanks for the reply!

Sounds like you need to boot w/“nomodeset 3”, blacklist nouveau, run nvidia installer, mkinitrd, reboot – whoops sorry, I see that you have an R7 360, I’ll have to let the Radeon experts chime in. It’s FINE if you add nomodeset as a permanent option. It’s why it’s available, sometimes you need it with some video hardware.

If I don’t use nomodeset with the Live or Rescue ISOs, then mine doesn’t usably boot either, my 1050Ti causes the screen to show garbage and that’s all I get. So I too have to use nomodeset

You can make the ‘nomodeset’ persistent through YaST - System - Bootloader

IMO it would be helpful to know where the boot failed.

  1. When you boot using the kernel that fails the boot,
    Hit ESC so you can see the stdout of the boot process behind the splash screen.
    When the system errors or stops booting, use a camera to take a picture and post to something like a pastebin like and provide a link in your Forum post.

  2. If you can boot successfully booting another kernel, then do so.
    Then, from a console you can retrieve the bootlog from a previous boot by using the “-b -n” where n is the incremental number counting backwards. So for instance the following will write the <previous> boot log to a file called bootlog.txt

journalctl -b -1 > bootlog.txt

After you’ve created a file with the bootlog, you can then either copy the contents of that file into a pastebin or upload the file to that pastebin as an attachment… And then again, like for the camera picture above you can provide a link to your paste in a Forum post.


Thank you for the troubleshooting guide! Fortunately, I have figured out that using the kernel module “radeon” as opposed to “amdgpu” allows me to boot without trouble.

Linux distros are frustrating sometimes, good job on the solution. rotfl!

I’m having a similar problem. I added nomodeset to boot but I’m still unable to (although I can boot into 4.12.9).
After adding nomodeset and ctrl + x I get the following message (which seems to confirm an alternative to amdgpu would do the trick):

[drm:amdgpu_init [amdgpu]] "ERROR" VGACOM disables amdgpu kernel modesetting

How can I go about switching from amdgpu to radeon on 4.13 if I can’t boot into it?
Thanks in advance for any help you can provide!

Can you boot to a terminal? You can run zypper or yast from command line

… you can do this the same way you added nomodeset, just go to the end of the same line and add


When you see the login prompt, type root and hit enter (no password).

Then, run yast or zypper.

I presume you know all this, but I am adding this just in case, and also for anyone who looks into this thread and does not know this. :wink:

Hi! Thank you for your kind replies!
I’m sorry I haven’t answered sooner. I’ve tried booting into text mode with nomodeset (great idea!), adding radeon and blacklisting amdgpu, but it didn’t help. I still cannot boot into the 4.13 kernel.
I get several “possible missing firmware amdgpu/raven…” with amdgpu and no UMS support in radeon module.

I wonder if I should re-install something.
Thanks in advance for all your help!

You need to remove “nomodeset” again to be able to use radeon.

And you need to have kernel-firmware installed.

If it is, try to run “sudo mkinitrd” to add the firmware files and the amdgpu blacklist to the initrd.
plymouth intializes/uses graphics very early in the boot sequence, long before the root filesystem is mounted.

Hi! Thank you for your kind reply.

I created a file etc/X11/xorg.conf.d/20-radeon.conf containing

Section "Device"
   Identifier "Radeon"
  Driver "radeon"
  Option "DRI" "3"
  Option "TearFree" "on"
End Section 

and blacklisted the amdgpu driver at etc/modeprobe.d/50-radeon.conf

Then rebuilt the initrd with


and rebooted, (without nomodeset), but I get about the same problem and cannot get to the login screen.

Earlier this year I had a similar problem and that’s why I switched to the amdgpu driver. I have a Mullins Radeon R4/R5 card, and it worked perfectly until now. I wonder if I’m missing some crucial step.

Thanks again in advance! You are all very kind.

Ran into this tonight after updating and thought I’d share my findings (I have a Southern Islands R9 270x). It is caused by some new functionality added to kernel 4.13+, and Phoronix talks a bit about this and even goes into benchmarks of AMDGPU vs radeon on 4.13 here:

Their recommendation, which is corroborated elsewhere and working for me, is to add the following to your kernel boot line (GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub) and re-run mkinitrd:

radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1

Doing this will allow you to continue using the newer AMDGPU driver rather than the older radeon driver, though, performance is sadly still a bit lacking with AMDGPU. Hoping that will change but by the time it does I’ll probably have a new card anyway.

Worked perfectly! Thank you! (sorry I took a couple days to reply, but I was not at home and had taken a different computer with me)