New to Suse, no Wireless

frenchsquared wrote:
> I TRIED
> linux-4olk:/home/gordon # dhclient wlan0
> Internet Systems Consortium DHCP Client V3.0.6
> Copyright 2004-2007 Internet Systems Consortium.
> All rights reserved.
> For info, please visit ‘ISC DHCP’ (http://www.isc.org/sw/dhcp/)
>
> wmaster0: unknown hardware address type 801
> wmaster0: unknown hardware address type 801
> Listening on LPF/wlan0/00:1b:77:54:90:ae
> Sending on LPF/wlan0/00:1b:77:54:90:ae
> Sending on Socket/fallback
> DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
> DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
> DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
> DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
> DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
> DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
> DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
> DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
> No DHCPOFFERS received.
> No working leases in persistent database - sleeping.
> linux-4olk:/home/gordon #
>
> IT DIDNT WORK, OBVIOUSLY
> -WMASTER0: UNKNOWN HARDWARE ADDRESS TYPE 801- LOOKS INCORRECT?
>
> So, I am trying but I need your help again

Ignore wmaster0 as it is a master device setup by mac80211 and should
not be configurable.

What we learned is that your device is sending and receiving data.

The last thing to do is run YaST. Select “Network Devices” in the
left-hand column and “Network Settings” on the right. In the screen
that pops up, click on the “Global Options” tab and click on the “User
Controlled with NetworkManager” radio button. At this point, you can
click Finish.

Next, find the KNetworkManager applet in the lower-right hand corner
of the desktop. Click on it and select “New Connection” for wlan0. Go
through the various screens entering your Essid and encryption
settings. Although the “Connect and Save” button will be active all
the time, do NOT click it until the “Next” button is inactive. You
will need “WPA Personal” encryption with CCMP. Do not choose manual IP

  • let DHCP do it. On the last screen, select the Autoconnect button.

Larry

no luck,
the icon just stays grey and I am not connected to any networks

Freaking Yes

I change my router to use TKIP
and then change the network settings to match and I am typing this wirelessly,

Thank You

So does that mean that I will always need to use terminal to scan for networks. Since I cannot see a list of avalible networks?

then use terminal to set the wlan0 to look for that network?

If you configure the connection using NetworkManager the way I said,
it will autoconnect when you boot up, and no terminal action will be
required.

Larry

I configured network manager exactly how you recominded me to. When I restart the computer and run iwconfig it is looking for a differnet network. So I run iwconfig ESSID FrenchSquared an it will then connect to my network. Something is working between network manager and the iwconfig ESSID.

Im still very happy to be able to connect and very greatful to know a few of the iwconfig commands.

frenchsquared wrote:
> I configured network manager exactly how you recominded me to. When I
> restart the computer and run iwconfig it is looking for a differnet
> network. So I run iwconfig ESSID FrenchSquared an it will then connect
> to my network. Something is working between network manager and the
> iwconfig ESSID.
>
> Im still very happy to be able to connect and very greatful to know a
> few of the iwconfig commands.

If it is connecting to the wrong network, then you configured NM wrong!

in network manager it is set to connect to frenchsquared.
when I restart the computer in net work manager it is set to connect to frenchsquared.

when I run iwconfig after a restart is says another network

It does not matter what I do in Network Manager until I get iwconfig looking for the correct network.

Network manager isnt changing the iwconfig settings it is only assigning the wpa security.

you tried changing the channel on the router ? i had a problem where it would try to connect to another network & not mine, changed the channel & it was solved

Andy

That fixed it, strange that something so simple could have caused so much trouble.

Thanks Everyone

Cool, glad you got it sorted,now enjoy :smiley:

Andy