New to OpsnSUSE 11 — Linksys WUSB54G adapter, no wlan0


I’m fairly new to Linux (8 or 9 months) and brand new to OpenSUSE 11.1, which I just installed a couple of days ago. My computer has only a wireless connection (it has an ethernet port, but there is no ethernet connection on this floor) with a Linksys WUSB54G wireless adapter.

I’ve never found a distro in which this adapter would work out of the box, but usually I can get it running under ndiswrapper with little difficulty by opening a terminal, installing the driver, and then typing “sudo modprobe ndiswrapper && sudo ifconfig wlan0 up”. However, this is not working in OpenSUSE. Here is what happens:

linux-fqe5:~ # modprobe ndiswrapper

linux-fqe5:~ # ndiswrapper -l
wusb54g : driver installed
        device (1915:2234) present (alternate driver: p54usb)

linux-fqe5:~ # ifconfig wlan0 up
wlan0: unknown interface: No such device

linux-fqe5:~ # iwconfig
lo        no wireless extensions.
eth0      no wireless extensions.

So I tried lsusb, and the wifi adapter shows up:

Bus 003 Device 003: ID 1915:2234 Linksys WUSB54G 802.11g Adapter

I thought maybe that “alternate driver” thing (which I’ve never seen before) might be the issue, so I tried “dmesg | grep firmware” and got this response:

firmware: requesting isl3890usb
p54usb: cannot find firmware (isl3890usb)!

So it would seem that OpenSUSE is trying to use this p54usb adapter instead. I googled various permutations of “isl3890usb”, “linksys”, “openSUSE” for a long time, but turned up no firmware files of any sort to download. So I tried blacklisting p54usb in /etc/modprobe.d/blacklist, and rebooted, but it still shows up when I do ndiswrapper -l.

Also, there is no icon or listing of any sort for “network card”, “wireless lan”, etc. in YaST > Hardware.

I would be very grateful for any help!

IIRC that adapter uses the prism chipset & requires the prism firmware. Have a look here p54 - Linux Wireless should sort you out


> --------------------
> firmware: requesting isl3890usb
> p54usb: cannot find firmware (isl3890usb)!
> --------------------

The driver p54usb is a little strange in that the name of the firmware file is
not the same as what the driver requests. You probably need the firmware file that can be downloaded from

After you get that file using another OS or another system, just issue the command

sudo cp /lib/firmware/isl3890usb

After that, your device should work.


Thanks for the responses – downloading that .arm file and copying it to the /lib/firmware folder as “isl3890usb” did the trick, and I am now online without using ndiswrapper for the first time ever in my Linux adventures. Which is awesome. :slight_smile:

Of course, the next thing I did was install the NVIDIA driver via the “one-click” link on this page, which exploded my X server and left me in level 3 hell, but that’s a topic for another sub-forum, methinks!

Thanks again for the help.