New to OpenSuse troubles installing Mythtv.

I am not exactly a newbie, but I am having a lot of trouble installing Mythtv on OpenSuse Tumbleweed.
I have been running Mythtv on various flavours of Linux, starting with Mageia as (it’s known now) back in 1998.
Since 2007 I have been using various flavours of Debian, Ubuntu until they did the weird tablet thing when I switched to
Linux Mint, then ditched that for Kubuntu after Mint ditched KDE.

KDE have got very weird with their security lately and root access is problematic; when on another forum someone suggested OpenSuse.

I did try and gave up after stuffing around with it for a couple of days a year or so ago, some things seemed so alien about the opensuse way of doing things.
I have recently decided to try again and have run into the same sort of difficulties I had then.

I have tried Yast install, and that didn’t work, lots of unmet dependencies and conflicts, then tried a Zypper install, same thing.
Then I had a go with the git repository main package from mythtv and that didn’t work either.
I scrubbed it all and re-installed OpenSuse and tried again with Yast, but it did not create the Mythtv user account or group.

It seems to be tantalisingly close, but not quite there yet. Why is OpenSuse so difficult to install Mythtv? I can do a complete
Kubuntu install from scratch with Mythtv in about 3 hours.

Kubuntu works well for me and I love it, but nothing stays the same in Linuxworld, I want a back-up plan for when Kubuntu is gone.

Hello and welcome to the openSUSE forums.

I read through all of your post, but fail to see any factual data about what goes wrong.

You tell e.g.

I have tried Yast install, and that didn’t work, lots of unmet dependencies and conflicts, then tried a Zypper install, same thing.

but, as we are not clairvoyant, you better show what you did and got. And as you also tried zypper, that is easy enough (GUI screen shots are a bit more difficult to show). So please copy/paste that zypper command and it’s output into a post here, the best way to show what you did and got. We like it very much when you use CODE tags. As they are not easy to find, here is the explanation:

There is an important, but not easy to find feature on the forums.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.

I have mythtv on leap, tumbleweed and currently neon, which is 'buntu based, all with kde. I’ve had more trouble installing with 'buntu than opensuse so I suppose it’s what you get used to.
Opensuse doesn’t automatically set up user/group or the mariadb stuff. I don’t use a mythtv user I just do it all on my own user. I set up mariadb to take my username and password and then create the mythconverg database. Then when you run mythtv-setup it completes the process. The important part is making sure of the initial mariadb setup.
Perhaps if you come back with more detail of your attempts as Henk says we can offer further help.

Hi to hcvv and peteh- Thank you both for your replies. I did not make any notes when doing my attempts at the install, but I think peteh is right with his stab at the problems.
There is not too much documentation for Opensuse and mythtv, as there are so many more 'buntu users the documentation is much better.

I read as much as I could before doing my latest attempt, and nowhere did it mention about the mariadb thing in any of the notes.

So, where am I up to now? I have created a database and done the password thing. I have been able to populate the database with tuners and channels, the backend seems to be working admirably now. One thing I have noticed is the service name is different on Opensuse, it is mythbackend.service. The other thing I have noticed is the backend logs indicate the environment variables used by Opensuse take the path /var/lib/mythtv/.mythtv – this is nothing like any other distro I have used and it took me a while to see what havoc that caused with the database login procedure.
I deleted that file and created a symlink to my home version of ~/.mythtv/config.xml in all the other places, /root, /etc/mythtv, /home/mythtv/.mythtv

I can’t believe how hard I have found this whole thing, I do like OpenSuse as a distro, it does all I want so far.

I have written a how-to for installing mythtv in Kubuntu and it has been used hundreds of times by other users. Why do I find this so difficult?

You ask for screenshots etc. well here goes-this is the console output for mythtv-setup

tony@localhost:~> mythtv-setup -w
Invalid MIT-MAGIC-COOKIE-1 key2019-09-16 15:28:56.446383 I  Setup Interrupt handler
2019-09-16 15:28:56.446390 I  Setup Terminated handler
2019-09-16 15:28:56.446392 I  Setup Segmentation fault handler
2019-09-16 15:28:56.446394 I  Setup Aborted handler
2019-09-16 15:28:56.446396 I  Setup Bus error handler
2019-09-16 15:28:56.446400 I  Setup Floating point exception handler
2019-09-16 15:28:56.446402 I  Setup Illegal instruction handler
2019-09-16 15:28:56.446405 I  Setup Real-time signal 0 handler
2019-09-16 15:28:56.446408 I  Setup Hangup handler
2019-09-16 15:28:56.446444 C  mythtv-setup version:  [v29.1]
2019-09-16 15:28:56.446447 C  Qt version: compile: 5.12.3, runtime: 5.13.1
2019-09-16 15:28:56.446448 N  Enabled verbose msgs:  general
2019-09-16 15:28:56.446453 N  Setting Log Level to LOG_INFO
2019-09-16 15:28:56.456830 I  Added logging to the console
2019-09-16 15:28:56.608479 N  Using runtime prefix = /usr
2019-09-16 15:28:56.608483 N  Using configuration directory = /home/tony/.mythtv
2019-09-16 15:28:56.608541 I  Assumed character encoding: en_GB.UTF-8
2019-09-16 15:28:56.608560 N  Setting 'RunFrontendInWindow' being forced to '1'
2019-09-16 15:28:56.608824 N  Empty LocalHostName.
2019-09-16 15:28:56.608828 I  Using localhost value of localhost.localdomain
2019-09-16 15:28:56.608849 I  Start up testing connections. DB localhost, BE , attempt 0, status start
2019-09-16 15:28:57.627157 N  Setting QT default locale to en_GB
2019-09-16 15:28:57.627161 I  Current locale en_GB
2019-09-16 15:28:57.627178 N  Reading locale defaults from /usr/share/mythtv//locales/en_gb.xml
2019-09-16 15:28:57.629745 I  ScreenSaverDBus: Created for DBus service: org.freedesktop.ScreenSaver
2019-09-16 15:28:57.630083 I  ScreenSaverDBus: Created for DBus service: org.freedesktop.PowerManagement.Inhibit
2019-09-16 15:28:57.630632 I  Starting process signal handler
2019-09-16 15:28:57.631418 I  Starting IO manager (write)
2019-09-16 15:28:57.631424 I  Starting process manager
2019-09-16 15:28:57.631431 I  Starting IO manager (read)
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 key2019-09-16 15:28:57.682083 I  ScreenSaverX11Private: DPMS is disabled.
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 key2019-09-16 15:28:57.779000 N  Desktop video mode: 1920x1080 60.000 Hz
Invalid MIT-MAGIC-COOKIE-1 key/usr/lib64/ undefined symbol: _ZN11StringUtils6FormatB5cxx11EPKcz
2019-09-16 15:28:57.869438 N  Setting 'RunFrontendInWindow' being forced to '1'
2019-09-16 15:28:57.911586 I  Loading en_gb translation for module mythfrontend
2019-09-16 15:28:57.911815 E  LIRC: Failed to connect to Unix socket '/var/run/lirc/lircd'
                        eno: No such file or directory (2)
2019-09-16 15:28:57.911825 I  No joystick configuration found, not enabling joystick control
2019-09-16 15:28:57.914061 E  CECAdapter: Failed to load libcec.
2019-09-16 15:28:57.914070 I  UDPListener: Enabling
2019-09-16 15:28:57.915762 I  Binding to UDP
2019-09-16 15:28:57.916113 I  Binding to UDP ::]:0
2019-09-16 15:28:57.932863 I  UI Screen Resolution: 1920 x 1012
2019-09-16 15:28:57.981264 I  Using the Qt painter
2019-09-16 15:28:58.241175 I  MythUIWebBrowser: Loading css from - file:///usr/share/mythtv/themes/default/htmls/mythbrowser.css
2019-09-16 15:28:58.243319 I  MythUIWebBrowser: enabling plugins
2019-09-16 15:28:58.303978 I  Current MythTV Schema Version (DBSchemaVer): 1348
2019-09-16 15:29:04.981819 I  VBox: Using UPNP to search for Vboxes (3 secs)
2019-09-16 15:29:11.681277 W  DiSEqCDevTree: No device tree for cardid 1
2019-09-16 15:29:17.057785 W  DiSEqCDevTree: No device tree for cardid 1
2019-09-16 15:29:17.064468 W  DiSEqCDevTree: No device tree for cardid 1
2019-09-16 15:29:31.949724 I  VBox: Using UPNP to search for Vboxes (3 secs)
2019-09-16 15:29:38.648459 W  DiSEqCDevTree: No device tree for cardid 2
2019-09-16 15:29:42.774376 W  DiSEqCDevTree: No device tree for cardid 2
2019-09-16 15:29:42.779596 W  DiSEqCDevTree: No device tree for cardid 2
2019-09-16 15:29:55.708718 I  VBox: Using UPNP to search for Vboxes (3 secs)
2019-09-16 15:30:02.499172 W  DiSEqCDevTree: No device tree for cardid 3
2019-09-16 15:30:08.632781 W  DiSEqCDevTree: No device tree for cardid 3
2019-09-16 15:30:08.639381 W  DiSEqCDevTree: No device tree for cardid 3

And here is what I now get with the tuner setup-
*~/myth1.jpeg err… there doesn’t seem to be an image uploading thing on this forum-is that correct? Hopefully this forum doesn’t use the cloud dropbox type thing, that is so cumbersome.
For a slick interface take a look at the VW EOS forum-that has a brilliant interface and is so easy to use.

On every other distro this has been caused by an incorrect config.xml … but not this time.

Thanks for your assistance, Tony.

Hey guys-

Had a sudden thought-my.cnf bind address was not correct. I couldn’t find it where it normally resides /etc/mysql/mysql.conf/my.cnf I just did a Dolphin search and found it in some hidden corner of the system.

Anyway it all works now, even live tv which is usually problematic on Mythtv.

Thanks for all your help.

Cheers, Tony.

I am a bit at a loss here. I understood from your first post that you were not able to install the product because there were a lot of errors (warnings?) from YaST and/or zypper.

What you are now talking about is on taking the product into production by creatinf=g a database and configuring things. To me that means that you have installed things :question:

When you have installed successfully, I will quit from this thread because I know nothing about Mythtv, I thought I could maybe help with installation problems.

Henke- Yes, I had a lot of trouble installing via Yast and Zypper, but I was able to finally install by compiling the whole Mythtv from source.

My difficulties were compounded by my unfamiliarity with the “OpenSuse” way of doing things. Once I had manually created the database it was pretty straightforward.

Some of the commands are strange to me, the grub commands etc are different to the ones with which I am familiar. Google is my friend there…

Thank you for your input.


I’m glad I could offer a little help and it’s good that you’ve now got it going.

I did compile from source on a few occasions when I first wanted to try myth-29 (from myth-28) but it was very complicated in comparison with installing from the packman repo. i seem to recall that ansible made it slightly easier. Packman eventually updated to myth-29 so I’m sticking with 29 for now.