New to openSUSE no WiFi Adapter listed

Hi all,

I am new to openSUSE and am having trouble with WiFi on a 2014 Mac mini. The WiFi adapter is not even listed in the settings. I have tried a couple of simple things already trying to get it to work from old reddit posts but nothing has seemed to work so far. The Bluetooth is working fine strangely enough, just not the WiFi.

I have tried sudo rfkill unblock wifi - nothing happens
also:

/usr/sbin/rfkill list and only the bluetooth is showing up as unblocked and no wifi is listed.

I am unsure what to do at this point. Any help is greatly appreciated.

Thanks

my guess is you have a broadcom wifi - you have to get the driver from the packman repo for broadcom wifi - it is not distributed with the openSUSE images.

Here is how to find packman repo.

https://en.opensuse.org/Additional_package_repositories

Hi,

So I got “All of Packman” and then also ran “zypper dup” to switch over to that. What do I need to do to get the broadcom wifi driver?

install:
broadcom-wl
broadcom-wl-kmp-default

1 Like

I should have specified that I am also new to linux and do not know most of the commands.

would that be sudo install broadcom-wl?

You can also use Yast for this task.
Go to software and search for thos packages.Is sometimes handy to use.

zypper in broadcom-wl broadcom-wl-kmp-default

It is here to download for 15.4

https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/Essentials/x86_64/

here for Tumbleweed

https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/Essentials/x86_64/

1 Like

I got them installed but the option for wifi is still not showing up in settings?

When I run /usr/sbin/rfkill list the WiFi adapter now shows up however

Update: the setting randomly showed up after a second reboot. Thank you!

You are welcome. Glad it works now :wink:

You always have to reboot to get any *-kmp-default to be loaded. It is the kernel code to enable that module.