New to OpenSUSE - how is NetworkManager supposed to work?

I’m a new user of OpenSUSE 11.3 (after many years with Mandriva), and I’m finding the NetworkManager applet very confusing.

When I start up at a new location I can use the “Connect to Other Network…” menu item to bring up the list of available networks, and I’d expect that by selecting one of these and clicking “Connect”, then configuring and clicking OK, I’d get a connection. Instead the dialog just goes away and nothing else happens. Is something broken with NetworkManager, or am I misunderstanding how this is supposed to work?

By switching back and forth between NetworkManager and ifup I’m eventually able to establish a connection to a new access point, but it’s been a painful process.

I’ve also encountered a problem reported by others, where when my system fails to suspend/resume properly the /var/lib/NetworkManager/NetworkManager.state has NetworkingEnabled=false and I need to manually edit this before restarting networking… but that’s a separate issue, and I can work around it with the manual edit (or just add a startup script to do this automatically).

Just to clarify what’s going on (and perhaps help others struggling with the Network Manager), here’s the sequence I have to go through when I change locations and restart or unsuspend:

  1. Network Manager shows network unavailable
  2. Right-click Network Manager applet, click “Wireless 802.11 Create network connection…”
  3. List of all network SSIDs in range comes up, which also shows all the other networks I’ve connected to in the past (even if they’re not in range). Select the network I want to use, click “Connect”
  4. The “Add Network Connection - Network Management” dialog comes up populated with the information for the last connection I used, even if the connection I just selected is one I’ve used in the past. I have to go to the correct tab and manually select the same SSID from the dropdown list which I just selected in the last dialog.
  5. Click “OK”, and the “Add Network Connection - Network Management” dialog closes. Nothing else obvious happens.
  6. Run “service network restart” as root, which causes the Network Management applet to crash
  7. Restarting the Network Management applet from the menu, which finally starts the connection

No offense to the OpenSUSE developers, but Mandriva has the whole network management thing down cold. Can’t you just check their (open source) code for this, and perhaps use it in OpenSUSE? I like many other features of OpenSUSE, but this Network Manager thing is a bad joke.

No offense but … Mandriva has their MandrivaNetwork which is part of their system and maintained by them, and the knetwork-manager applet which is maintained by KDE and finally the linuxconfig-network CLI standard issue utility maintained by the Linux community. openSUSE distro is no different, it has it’s Yast-Network maintained by openSUSE developers, knetwork-manager by KDE developers, but does not include Linuxconf.

The mandriva version of KDE is not the same version (unless you upgraded) as the one used in openSUSE. So where you are having trouble with KDE knetwork-manager of openSUSE that does not exist in your Mandriva version, it would seam you should submit a bug report to KDE and be sure to note the version that works for you vs the version that seams to have the problem.

As a recent Mandriva to OpenSuse user, I agree with you.
Network Manager is used by nearly every other distribution. A few years ago, three or four?, everyone was on the ‘fix network manager’ bandwagon. But back then Mandriva already had it sorted out. And it is very simple and intuitive. Very easy to use. I would like to point out to everyone else that Mandriva uses it’s own tools, drakconnect, which has no relation to Network Manager whatsoever.

I only use one network, or have so far, so I’m not sure how well it does with roaming. But I do know that it took me quite a while to even get the stinking thing to connect. I had to type in my network passkey numerous times before it finally remembered it.

Also, I found out that knetworkmanager applet will not connect to a hidden ssid. This was very sad news for me. However, the gnome nm-applet will. So if you wish to run that instead of knetworkmanager you always could. When KDE4 came out knetworkmanager was rewritten. So everything that worked in KDE3 no longer worked in KDE4.

I really feel your pain. Just connecting to my own wireless at my own house that I set up was a pain in the rear. But once I got that sorted out the rest of the OpenSuse experience has been pleasant. I’m not sure how to help you. I just wanted to say to hang in there.

Thanks for the encouragement, Tubasoldier! I’m planning to stay with OpenSUSE, in any case, but I’ll remember the nm-applet alternative and give that a try if I get too frustrated with knetworkmanager. It’s a shame other distributions (or KDE) haven’t picked up on drakconnect.

My experience with OpenSUSE definitely beats that with Kubuntu a couple of years ago, where I kept running into known issues that nobody had bothered to fix. Aside from the network (mis)management, the only problem I’m having is a suspend/resume issue - which was also the case with Mandriva 2010.1 on the same hardware. I’m hoping either a kernel update or a new release of the ATI drivers will take care of this problem (I know you can patch things so the current ATI drivers will work, but it sounds like more hassle than I’m game to try right now).