new to opensuse and need some help...

i just downloaded 11.1 kde version, and im running it on a sony vaio. aside from a couple issues i love it.

whats bothering me is the fact that for some reason even though i have it set on aggressive power save, the second i dont have my laptop plugged in opensuse seems to mercilessly hammer through my battery. also, i tried to download something using kget, the out of the box torrent client, and for some reason no matter what i try i cant actually make the download start. i tried to use add programs and download a new torrent client, it claims to have downloaded it, but i cant find it anywhere.

i really think opensuse is a gorgeous distro, and want to stay using it, but i need to fix these problems. please help!

ctrl + F → 11.1 or openSUSE or whatever and then “search”

huh… wouldnt that just search on this page? the answer isnt here. i tried searching for the answers myself but i came up with nothing. maybe i just suck at the internet.

i know that someone here can help me, i believe in you, opensuse forums.

What the heck was that? I was still a little tipsy this morning and thought I just wasn’t reading right.


You should have a battery icon in your panel. Click on that and make sure that your computer is using aggressive power save mode when it’s not plugged in. Otherwise it will go through your battery power really fast if it’s still using the performance settings. If you click more… from the battery icon you can set what profiles are used when plugged in, on battery, etc… and you can make sure that all the settings are lowered for when you’re on battery.

As for torrents, the out of the box torrent application is ktorrent, not kget. You’ll have to set firefox or whatever browser to use ktorrent. It’s located in /usr/bin.

Good Luck,


kTorrent is a good BitTorrent client. I find it more than enough for all my BitTorrent needs.

To add to ijbreakey’s comment, make sure that the required ports are open on your firewall (both on your router and in Yast2 -> Security and Users -> Firewall -> Allowed Services -> Advanced)

Open firewall port only if KTorrent won’t download/upload. Personally I’ve never changed any firewall settings or ports and KTorrent worked.

ok as far as the battery goes i have it set to when im not plugged in its on xtreme powersave. also hoping to extend battery life i turned my screen brightness down.

as far as the torrents go though i need a step by step how to…

kget is the default client, and i dont really know how to set it to a different one. when i click on other, it takes me to a menu just displaying my files. where do i find my other programs in that menu? i hope i dont sound like a total moron from that question, but i have no other choice.

A Quick Bittorrent Guide (with screenshots) - openSUSE Forums

Are you sure that there is not something ‘up’ with your laptop? I run mine on Performance even when on Battery and it will run for a couple of hours before I have to think of doing something.
Maybe you have one of those crumby 4 cell economy batteries?

i really hope not, but maybe so. i just installed opensuse a couple days ago, and i was running mint and the battery was fine then so im leaning towards something with opensuse’s settings, however i guess it is possible that it is my laptop. its a sony vaio vgn-nr180e that i bought around a year ago so maybe…

anyone know a way i could test my battery?