New to openSUSE, after initial install, will not boot

Hey all,

Like I said, I am new to openSUSE, but have been using different flavors of Linux for years. Basically, if I can easily install this on my Zotac Zbox, I can seamlessly transition it to my desktop.

The Zbox specs are:
CPU - Intel Atom D525 1.8
Memory - 4Gb
Chipset - Intel NM10 Express
Onboard Graphics - Next Generation NVidia ION 512 MB DDR3

Looks like this:

Anyway, after installation I get to the splash screen and it starts to flicker back and forth between splash screen and a command line boot sequence and will go no farther. The only thing I can boot into is Rescue.

For the record this is the 13.1, 64bit iso that I dd’ed onto a flash drive.

I would suggest to install the proprietary nvidia driver.
See here:

You need the G03 driver, labelled as “For GeForce 8 and later” (or “GeForce 8xxx and newer”) on that page.

I actually have the one installed that is specific to the ION cards. Gotten directly from the NVidia page.

Do you think I should install the G03 driver anyway?

It’s not necessary as this should be exactly the same.

The RPMs have some advantages though. They take care of everything during installation (like the necessary nouveau blacklist) and don’t have to be reinstalled after certain updates (kernel f.e.).

How exactly did you install that driver? Maybe you forgot to blacklist the nouveau driver or something?
Does this give any output:

grep nouveau /etc/modprobe.d/*

Could you please do a normal boot, then reboot to recovery mode and post the file /var/log/Xorg.0.log.old ? (upload it to and post a link)

You could try to add “nomodeset” to your boot options. Does it boot then?
(Press ‘e’ at the boot menu, search for a line starting with “linux” and append “nomodeset” at the end, then press ‘F10’ to boot)

I installed the driver by downloading the *.run file from the NVidia website and installed it when I was in recovery mode by dropping into run level 3 then rebooting.

I will do this as soon as I get home tonight.

So boot up normally to where it flickers, then reboot into recovery? I will do this tonight.

I have done this and it still boots into a flickering splash screen and goes no further.

Thanks for your help, I will update tonight.

AFAIK this doesn’t do anything to prevent the nouveau driver from loading, so there can be problems.
But adding “nomodeset” to the boot options should have fixed them in that case.

You could also try “plymouth.enable=0” in addition to “nomodeset”.

I will wait for your Xorg log though, before giving further advise.

Here is a random question, since I have openSUSE on my desktop and it runs fine, I am wondering if I should just stick Lubuntu on this box since I don’t really care about the OS on it that much other than it needing to be really light weight.

All it is is a small HTPC that I use to run XBMC, connect to my NAS, and run rtorrent.

What do you think?

Alright, so I just got home, I appended ‘nomodeset’ and ‘plymouth.enable=0’.

It booted in fine, but now it has SUPER small text.

grep nouveau /etc/modprobe.d/*


/etc/modprobe.d/nvidia.conf:blacklist nouveau

Here is the Xorg.0.log.old:

Alright, so it seems to be fixed.

I appended the two options to the boot menu.

I fixed the small font size by adding a .Xdefaults (I’m running LXDE) file containing the line:

Xft.dpi: 96

Thanks for your help.

According to your Xorg log file, your monitor reports a wrong display size.
The log doesn’t specify the size that’s reported (you could check with “xdpyinfo | grep dim”), but it contains this:

    32.844] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
    32.878] (--) NVIDIA(0): DPI set to (30, 30); computed from "UseEdidDpi" X config
    32.878] (--) NVIDIA(0):     option

So the driver sets a DPI value of 30 (this is computed by the display size and the resolution), which of course results in tiny fonts.
You already found a work around for this, but you could also specify the correct display size or DPI in the X configuration.
See also here, where another person had a similar problem (just the opposite, his display size was reported much too small which resulted in a DPI value of 300 and huge fonts):
This would have effect system-wide, not only for the one user.

grep nouveau /etc/modprobe.d/*


/etc/modprobe.d/nvidia.conf:blacklist nouveau

In that case, the “nomodeset” shouldn’t be necessary.
But apparently plymouth (the boot splash system) has problems with your graphics card.

You could try to install the nvidia driver from NVidia’s openSUSE repository as already mentioned (but you should uninstall the manually installed one before you do that), maybe this would do something different which would prevent the problems with plymouth.

What could also help is setting NO_KMS_IN_INITRD=“yes” in /etc/sysconfig/kernel and running “mkinitrd” to recreate the initrd.
Maybe then your system would boot without “plymouth.enable=0”.
(Or maybe even just re-creating the initrd with “mkinitrd” would help already)

Now it boots up fine, but I have no audio.

I have followed a few of the guides, but I still don’t get audio.

I get sound when running

speaker-check -c2 -D plughw:1,7

Well, it shouldn’t matter really.
Just use what you like better or what works better.

The OS itself is about the same, the main difference is what runs on top. But since you’re using LXDE anyway, openSUSE should be just as light weight as Lubuntu.

OTOH, there’s nothing wrong with a dual boot system either… You could install both at the same time as well if you wanted to.

I think you mean “speaker-test”, right? :wink:

Hm, maybe you just need to configure the right default output device?
Try to run “pavucontrol” and set it there. (you may have to install that with YaST or zypper first)

You could also try to disable PulseAudio in YaST->Hardware->Sound->Other->PulseAudio Configuration, and try with plain ALSA.