New to Linux - ATI radeon 3870 installation help!

hello. I am VERY new to linux and i was wondering exactly what i need to do to install the ati-driver-installer-8.16.20-i386.run sitting on my desktop at /home/sean/Desktop/ati-driver-installer-8.16.20-i386.run

i am running opensuse 11.0
ANY help would be greatly appreciated.

Also - i installed cairo dock from the package installer - now how do I get it running? sorry for the noobness.

you might want to try the ati repo here by adding this addy to yast
Additional YaST Package Repositories - openSUSE

or if you want to install the drivers you downloaded, go into terminal cd /home/sean/Desktop/
then su to get root privileges then type ./ati-driver-installer-8.16.20-i386.run

I did what you said above and got:
CORSAIR:/home/sean/Desktop # ./ati-driver-installer-8.16.20-i386.run
bash: ./ati-driver-installer-8.16.20-i386.run: Permission denied

:s linux doesnt like me? :stuck_out_tongue:

when your in terminal type
su
then your root password
then ./ati-driver-installer-8.16.20-i386.run

sean@CORSAIR:~/Desktop> su
Password:
CORSAIR:/home/sean/Desktop # ./ati-driver-installer-8.16.20-i386.run
bash: ./ati-driver-installer-8.16.20-i386.run: Permission denied

just grasping at straws now but try moving the file to another folder instead of your desktop

and if that don’t work maybe adding that repo to yast2 would be better

If you are a noob, I would stay away from the installer. There are a half dozen other programs (dependencies) that have to be installed before the installer will work. But if you insist, at least read the instructions linked on the page where you downloaded the driver.

An easier way would be to go to YAST / Software Repositories / Community repostories and add the ATI repo.

Then go to YAST / Software Management and do a search for fglrx. Install the two files, then log out and log back in.

When you get back to the desktop run this command in the terminal

fgl_glxgears

If you get spinning 3d gears, you have succeeded.

Everything available from the ATI repository is installed, i restarted and ran the glxgears command and i get a draw error. What am i doing wrong?

What did you install exactly?

x11-video-fglrxG01
ati-fglrxG01-kmp-pae
ati-fglrxG01-kmp-default
ati-fglrxG01-kmp-debug

There’s your problem. You only need the x11 and one GO1 file, the one that matches your kernel.

Go to the terminal and run this command

uname -r

This will give you your kernel version. Remove the other two GO1 files that don’t match your kernel.

Then I would try a reboot.

thank you so much for your help! I found a link that was a 1 click install of the linux driver at ATI - openSUSE. I learned alot in the process of trying to figure it out though. thanks for your help in my mission to become windows free!

Try


chmod +x ./ati-driver*

in the directory you have the installer (after doing su. Then try running it again. It is probably because the file is not marked as executable.

So fgl_glxgears works now? If so, excellent.

So itried a fresh install of opensuse 11.0… did the updates, and when i used that same link i used before to install the ati drivers, now theres 3 linux options under grub. one just says opensuse, one says opensuse debug and one says failsafe. when i use the regular opensuse option the screen goes black and theres a stripe of random blue pixels when opensuse loads up. Right now i am under the debug option and fgl_glxgears as well as desktop effects all work. any ideas?

I’m not familiar with the debug option. Did you do any kernel updates? If so, these can cause you to lose your desktop until you install a driver compatible with your new kernel version.

I would hit control alt F1 to exit the gui. Then log in as root and run this command:

sax2 -r -m 0=fglrx

If that command does not work, try

sax2 -r

Hopefully sax2 will start. Click change settings and confirm you have 3d enabled and then save settings and exit.

When you get back to text mode hit control alt delete to reboot and try booting back into regular OpenSuse and see what happens.