New to linux and already have a problem!

I installed suse 2 days agao and everything seems to work fine except today I was taking some photos off a digital camera and I forgot to unmount before removing the device and I can no longer get the camera to mount… it works on a windows pc and all my other usb devices work in the same port its just that one camera that was working fine before I did this

when I go to access the camera it says unknown error cannot access superblock

I have rebooted… I tried to access as root… nothing… I read all I can about fixing it and found nothing helpful

the camera shows up on a hardware scan just fine when coneected just cant get to the files anymore

im sorry if this is a stupid question but im new to linux… so how do I fix it?

thanks in advance for your help…

Without the camera connected
Look in /media
Do you think you see a folder that would represent the previously mounted camera?
You could delete it if you do see it.


If you still can access a win pc. Connect the camera, get any info off the storage chip that you need, then format it.

try again in linux

I looked in media and only a file called disk with 15 free of 20 is there but noting is in it so I assume that is the boot partition because I have a dual boot with windows…

I did format the sd card from the camera and retried and still same

I even went into windows and tried the format and chkdsk on the card then started the camera and reset to default and formated the card in the camera and still no love…

I might try a different sd card but I cant see how that would matter much…

I cant believe its locked me out like this… I dont want to go back to windows just to get pictures off and back to linux again to edit and post them…

i will try that different card and if it works ill let you know…

thanks again… jon

Ok, I tried a different 2 gb sd card and same problem however If I remove the sd card and use only the limited camera memory it worked fine so its got to be eighter the camera or card itself that has issues with linux

at least I now know its the camera and not the os so I can take steps to fix the issue…

I have some old smaller sd cards and that might be the problem…dunno

or maybe its time for a shiny new camera…

sorry to bring the trouble here as it turned out to be hardware issues and not suse

If you have no other devices connected to your computer (usb drives, whatever…) /media should be empty.

Is what you see in there a file or folder?

Well I was wondering about that myself…

it is a folder called disk and when you click it it gives a warning that it could not be entered however the properties say 15.2 g free of 19.7 g

now all I can assume is it has something to do with the 20 g partition that was created when I installed suse cuz I what else is 20 g??

On a crazy note and related to partitions and mby u can explain or maybe this is related to that file… when I setup suse I had 3 HDD all NTFS on vista and after I split the C drive in 2 and put linux on I kept the D drive as ntfs for windows but moved the last drive over to linux ext4 now when that is formated and mounted it shows on system info that there is 4g of data on the drive even after it was freshly formated!!! I tried messing with that a few times but cant figure it out… then after all else failed I tired login as root and the drive was clear but back to my user and its got nearly 4g on again!! thats weird but its working!!

mby something is gone wrong with my user account and I will see if the file is there when I go to root… let me see and I will let you know…

Thanks so much for your time… Its real great that people will go out of their way to help a novice like myself through this stuff…

Open a terminal and become su

post result of

fdisk -l
cat /etc/fstab

but moved the last drive over to linux ext4 now when that is formated and mounted it shows on system info that there is 4g of data on the drive even after it was freshly formated!!!
This is normal

Ok… I went over to root and the folder was there but it let me open it and nothing was there and its properties said noting was there so I deleted it and it was gone on my login when I came back with no problem so far… I think that may be solved

anyways I had a look at that storage drive and it does show almost 4 gig above the amount of files on that drive even in the root

when I moved it over I went to partition manager and deleted partitions down to the drive itself and created a primary partion with ext4 formating and mounted it as /storage and I had some trouble at first but it came up… only issue was this 4 gig used… I even tried going back to vista and doing a complete format and removal of partions then back to linux to be partition and formated but I still had almost 4 gigs on it so I dont know…

I always worked with dos and windows and its a whole different system on linux cuz the mounting is kinda invisible and automated to the user in the windows gui…

I really like linux but like anything new its a challenge to learn and now that im disabled I have the time to do it…

here goes… :slight_smile: that noisy maxtor as you can see is what I moved over for files… would have been Ideal to install linux on the maxtor and kept windows on the WD 160 alone and maybe shared that seagate as NTFS but changing the default install was beyond my ability… maybe as I learn I will redo the setup so I can fine tune it better than stock install…

linux-z8k9:/home/jonathan # fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x20a61696

Device Boot Start End Blocks Id System
/dev/sda1 1 10760 86421667 7 HPFS/NTFS
/dev/sda2 * 10760 19457 69865661+ f W95 Ext’d (LBA)
/dev/sda5 10760 11022 2103491+ 82 Linux swap / Solaris
/dev/sda6 11022 13632 20972826 83 Linux
/dev/sda7 13633 19457 46789281 83 Linux

Disk /dev/sdb: 80.0 GB, 80000000000 bytes
255 heads, 63 sectors/track, 9726 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x66ea66ea

Device Boot Start End Blocks Id System
/dev/sdb1 1 9725 78116031 7 HPFS/NTFS

Disk /dev/sdc: 80.0 GB, 80000000000 bytes
255 heads, 63 sectors/track, 9726 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x9b599b59

Device Boot Start End Blocks Id System
/dev/sdc1 1 9726 78124063+ 83 Linux
linux-z8k9:/home/jonathan # cat /etc/fstab
/dev/disk/by-id/ata-WDC_WD1600JD-00HBB0_WD-WCAL93676007-part5 swap swap defaults 0 0
/dev/disk/by-id/ata-WDC_WD1600JD-00HBB0_WD-WCAL93676007-part6 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-WDC_WD1600JD-00HBB0_WD-WCAL93676007-part7 /home ext4 acl,user_xattr 1 2
/dev/disk/by-id/ata-WDC_WD1600JD-00HBB0_WD-WCAL93676007-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-ST380013AS_5JVFNPR6-part1 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/disk/by-id/ata-Maxtor_6Y080M0_Y24QFDHC-part1 /storage ext4 acl,user_xattr 1 2
linux-z8k9:/home/jonathan #


Are you saying you deleted what was in /media ?

And how is the camera situation?

Otherwise, it looks OK to me, unless I’m missing your plea for help?

In the media I could not open the folder but it showed it had stuff in and I could not delete it but I went to root and it was just an empty folder and it let me delete it… dunno what happend there…

the camera as I forgot to mention was a hardware issue… under windows the 2gb card was fine but under linux I need to use a smaller sd card and its fine… I plan to upgrade soon but it was the camera itself I think…

Im glad that looks ok… im just getting useto it all… I always wanted to learn but never had time well now I got too much time

Thanks for your help… again im sorry I thought it was a issue with suse when it turned out to be a hardware issue with that camera but I learned a thing or 2 so its not all bad…