new [sata] install can't find grub

My friend has had an HP Pavilion Slimline for about two years – recently he
suffered a power surge and had to replace his (dsl) modem and harddrive –
he can’t find the Vista media that may or may not have come with the PC, so
I offered to put opensuse on it for him.

I used a dvd I had burned last July with 11.3 on it, and the install went
without apparent problems. Then I tried an update, and was greeted with

Download failed:
File '/repodata/repomd.xml.asc' not found on medium

-  []

That was bad, as I was unable to update.

Then we tried a reboot and things got worse. Immediately after the bios
info the message

Error loading operating system.

appeared and the boot halted.

The drive is new, we wrote to it and read from it during the install (I
formatted it as ext3), but the box can't seem to find grub on it at boot, or
it finds it and doesn't like it.

If I reboot with the install DVD in the drive I can get a menu and "repair"
(I think that was the choice) which gives me a login prompt, which I can
tell "root", at which it responds with a shell prompt, but I don't know what
I can do at that point to fix grub, or the SATA driver, or whatever needs

Any help will be appreciated.


It sounds like a hardware issue. I’m speaking of the “Error loading OS” message. It sounds like the BIOS doesn’t see the drive, in which case it won’t matter what OS you try to throw on there. When you boot the machine go into the BIOS and see if it detects the hard drive. I don’t quite understand how you were able to run an update. Did the box boot up once? Seems like there was no Internet connection if it did. It would help if you would post back with the machine specs, model number, etc. and what kind and size hard drive you put in there. The more info, the better.

First, before installing, did you use the option on the boot menu to check the install media? A burned DVD can go bad in only 6 months, or this drive may have trouble reading one burned in a different drive.