New Sata drive is sda - computer doesn't boot (SuSE 11.2 64)


I had put a second Sata hard drive in my computer and was pleasantly surprised not to run into any problems. No BIOS changes, just start the partitioner, partition, mount, it worked.
And then… my computer didn’t boot today. I disconnected the new hard drive and it went a little bit further, allowing me to log in as root and remove some lines in /etc/fstab. After that, it booted without any issues.
I then remembered that the new drive was /dev/sda and the old drive /dev/sdb.
I assume this is the reason for not booting, there is no GRUB on /dev/sda.
How do I fix this? Can I simply plug in the cable for the new drive where the cable for the old drive was?

Thanks, Stephan

If there was just the one (old) drive there before, it wouldn’t be sdb it would be sda

Are you maybe confused by boot order in BIOS?

But regardless - You need to clarify Eg:

  • My old drive had this_old_install on it
  • I did this with the new drive


When you use the default mechanisms used by installation neither GRUB’s menu.lst, nor /etc/fstab will have /dev/sda. or /dev/sdb. mentioned. They will use the /dev/dis/by-id/…-part. symlinks that will use the correct disks always (even if it is /dev/sdz).


thanks for the quick replies.
I solved it by switching cables. Changing the boot order in the BIOS might have been easier, but I thought of it too late.
I want to clarify what I did: The old drive had SuSE 11.2 and nothing else. I don’t remember whether it was /dev/sda or something else.
The new drive is mostly empty and has only a few data. /etc/fstab doesn’t contain any reference to /dev/sda or /sdb, but I remember seeing it somewhere and I remember that I was surprised that the new drive was /dev/sda.
When I booted today - first time after formatting the new drive, I saw something about DMI pool and then nothing. Usually GRUB appears next, but with the new drive, nothing happened. I assume that it tried to boot from the new drive. What I don’t understand is that I could boot Linux with the second drive installed before I formatted it. Why didn’t it try to boot from it then?

Thanks, Stephan

Hard to say, you have the hardware and are in the best position to collect the clues.

My guess: with the old disk it was actually in the second SATA slot and the BIOS booted from that in the absence of anything in the first slot. Once you put a disk into the first slot, it tried to boot from that.