[NEW] - NetworkManager - Unable to authenticate

Hi everybody,

This thread means to find out the causes that lead NetworkManager to failure during a Wireless connection/authentication procedure.

I’ve just solved some problems involving my Wireless Card in this previous Thread
and now NM is able to see al the available connections.

The problem now is that, when I try to connect to my home wireless network, NetworkManager gets stuck in the ’ Configuring Interface ’ phase and can’t connect to the network.
Wired connections work fine.

I’m running:

  1. OS : OpenSuse 13.2

  2. Kernel:

matteo:/home/matteo # uname -r

  1. Wireless Card MEDIATEK MT7630e

matteo:/home/matteo # /sbin/lspci -nnk |grep -A3 Network
03:00.0 Network controller [0280]: MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter [14c3:7630]
        Subsystem: Foxconn International, Inc. Device [105b:e074]
        Kernel driver in use: rt2800pci
        Kernel modules: rt2800pci

Thanks in advance for any help or suggestion.

If you need more information just ask me and I’ll be able to provide it to you.

Have a nice evening.

Which desktop environment are you using: KDE, Gnome, MATE, XFCE, LXDE, something else?

Is there a polkit agent running. What’s the output from:

ps -ef | grep polkit

Are you using autofs?

What’s the output from:


Hi, thank you for your support.

I’m using the KDE Desktop.

Here it is the first ouput :

matteo:/home/matteo # ps -ef | grep polkit
polkitd    788     1  0 21:37 ?        00:00:00 /usr/lib/polkit-1/polkitd --no-debug
matteo    1682     1  0 21:51 ?        00:00:00 /usr/lib64/kde4/libexec/polkit-kde-authentication-agent-1
root      2196  2164  0 21:52 pts/2    00:00:00 grep --color=auto polkit

Sorry, I don’t know what autofs is… But I checked via YaST2 and the autofs package is installed.

Here the second output :

matteo:/home/matteo # loginctl
   SESSION        UID USER             SEAT            
         2       1000 matteo           seat0           

1 sessions listed.

That all looks good.

Let me fill in some explanation.

There are two kinds of authentication involved. There’s the authentication of the network itself. And there’s the authentication of the user to be able to execute privileged commands on the system (such as connecting to a network).

My questions were related to the second of those. The authentication to the system depends on “polkit” and on the systemd user agent. Your answers show that a polkit agent is running, and that systemd does see you as properly logged in. I asked about “autofs” because some reports have indicated that if “autofs” (which automatically mounts some network file systems) is running, that can interfere with systemd loginctl.

The other type of authentication, is for the network itself. So it now seems clear that your problem is there. I don’t have any magical solutions for that. My experience has been that this can happen when the WiFi signal is too weak, and if can happen with a misconfigured network.

Thank you for this explanation.

Do you think that changing the type of crittography used for the network colud be a reasonable attempt to make this connection/authentication work?

I’m assuming that you meant “cryptography”.

Changing that probably won’t help.

When I mentioned “misconfigured network”, I had in mind a personal experience. The network had two different routers, both using the IP address This conflict caused problems.


I’m really considering the idea of buying an external/portable Wireless USB adapter. Then I’ll try to solve this problem when I have more time.

What do you think about this?

Are there any compatible models with OpenSuse OS?

I’ve used one. It seems to work pretty well. But it’s a bit old by now so would not match the speed of newer devices.

I don’t have a recommendation for current USB wifi adapters.

Hi all

Whoever has problems like this, I solved the problem buying one of these mini USB adapters:


I installed the drivers found online for Linux and now I can connect to wireless network configured via YaST2 (wicked service).

Thanks everybody.