New Motherboard / Upgrade to Leap now no internet

Hi all;

Have just fitted a new motherboard - Gigabyte 970 gaming edition.
Took the opportunity to ‘Upgrade’ (using the upgrade function) from 13.2 to Leap 42.1.
Upgrade seem to go ok; only one error ‘Couldn’t retrieve plex repository’ but it did seem to pull through all other required repos, so I assume (rightly or wrongly) that it connected to the internet during upgrade - it did modprobe? on the network connection and gave no errors.
Anyway - now it’s booted everything works apart from the internet connection. Tried configuring from Yast but getting nowhere. Below is the output from some basic commands I see you guys ask for in other posts, hopefully you can give me a steer from here:

**nigsy:~ #** ip route 
**nigsy:~ #** ping 
connect: Network is unreachable
**nigsy:~ #** ifconfig 
lo        Link encap:Local Loopback   
         inet addr:  Mask:
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:65536  Metric:1
         RX packets:3905 errors:0 dropped:0 overruns:0 frame:0
         TX packets:3905 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0  
         RX bytes:469622 (458.6 Kb)  TX bytes:469622 (458.6 Kb) 
**nigsy:~ #** systemctl list-unit-files | grep -iE 'etwor|icke' 
dbus-org.opensuse.N**etwor**k.AUTO4.service    enabled  
dbus-org.opensuse.N**etwor**k.DHCP4.service    enabled  
dbus-org.opensuse.N**etwor**k.DHCP6.service    enabled  
dbus-org.opensuse.N**etwor**k.Nanny.service    enabled  
n**etwor**k.service                            enabled  
N**etwor**kManager-dispatcher.service          enabled  
N**etwor**kManager-wait-online.service         disabled 
N**etwor**kManager.service                     disabled 
w**icke**d.service                             masked   
w**icke**dd-auto4.service                      enabled  
w**icke**dd-dhcp4.service                      enabled  
w**icke**dd-dhcp6.service                      enabled  
w**icke**dd-nanny.service                      enabled  
w**icke**dd.service                            static   
n**etwor**                      static   
n**etwor**                         static   
n**etwor**                             static   
**nigsy:~ #** /usr/sbin/hwinfo --netcard 
34: PCI 400.0: 0200 Ethernet controller                          
 [Created at pci.366]
 Unique ID: rBUF.TzXRgypOXd7
 Parent ID: Rgik.DknfbwVt1O3
 SysFS ID: /devices/pci0000:00/0000:00:15.0/0000:04:00.0
 SysFS BusID: 0000:04:00.0                                                                                                                                                         
 Hardware Class: network                                                                                                                                                           
 Model: "Qualcomm Atheros Killer E220x Gigabit Ethernet Controller"                                                                                                                
 Vendor: pci 0x1969 "Qualcomm Atheros"
 Device: pci 0xe091 "Killer E220x Gigabit Ethernet Controller"
 SubVendor: pci 0x1458 "Gigabyte Technology Co., Ltd"
 SubDevice: pci 0xe000  
 Revision: 0x10
 Driver: "alx"
 Driver Modules: "alx" 

Thanks in advance.

That’s simply because you have a new network device, where the config of the old one is still present. Use Yast - System - Networksettings to remove the old config, then configure the new one with the proper values.

I’m not seeing anything in network settings to help??
I can delete the existing entry - Killer gigabyte card etc etc and add new Ethernet card; dynamic or static IP; but still no joy.
If I edit the existing killer entry I still get no connection…Is it easier to just do a fresh install of Leap rather than the upgrade?

I’m surprised that your hwinfo output didn’t show the link and driver status. I would have expected something more like the following to be reported

# /usr/sbin/hwinfo --netcard 
12: PCI 03.0: 0200 Ethernet controller                          
  [Created at pci.366]
  Unique ID: rBUF.GkSpXDNdaaB
  SysFS ID: /devices/pci0000:00/0000:00:03.0
  SysFS BusID: 0000:00:03.0
  Hardware Class: network
  Model: "Intel PRO/1000 MT Desktop Adapter"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x100e "82540EM Gigabit Ethernet Controller"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x001e "PRO/1000 MT Desktop Adapter"
  Revision: 0x02
  Driver: "e1000"
  Driver Modules: "e1000"
  Device File: eth0
  Memory Range: 0xf0000000-0xf001ffff (rw,non-prefetchable)
  I/O Ports: 0xd010-0xd017 (rw)
  IRQ: 19 (8801 events)
  HW Address: 08:00:27:ed:72:ae
  Link detected: yes
  Module Alias: "pci:v00008086d0000100Esv00008086sd0000001Ebc02sc00i00"
  Driver Info #0:
    Driver Status: e1000 is active
    Driver Activation Cmd: "modprobe e1000"
  Config Status: cfg=no, avail=yes, need=no, active=unknown

Can you confirm that the ethernet interface is connected properly? Is there a link light showing on the router?

What is reported by the following?

ip link

At least some of the AMD 970 boards need the kernel boot parameter iommu=soft to get both network card and USB3 working at the same time. I don’t know if your motherboard is affected but it might be worth a shot booting with that.

Your original “ifconfig” post should have displayed more than just a loopback address.
I see nothing, not even a MAC address.

So, you have a fundamental network card install problem which you have to resolve before you can even start to think about configuring it

  1. Look for a hardware issue like what deano is suggesting. Besides the link light on the router, look for the link activity light on your machine’s network card, it should shine steadily indicating a physical connection but not blinking because it’s not configured.

  2. Display the results of ip addr, it shows slightly different info

ip addr
  1. If all else fails, you can try re-installing. Since your system doesn’t have a network connection (do you have another adapter so you can do an online re-install?), you need to use a DVD.


Ended up doing a full clean install of Leap. Probably the easiest route TBH; cleared up a few other niggles I was having with 13.2 and some old stuff hanging around that I hadn’t removed cleanly. So all good and up and running now.

Thanks all.

Nice to read of your progress. Thanks for the update. :slight_smile: