New lvm errors after updating to opensuse-release-20220305-1477.1

After todays update to snapshot 20220305-1477.1, I got this error log:


> jctl-n -b -1 -p err
Mar 06 16:25:15 Mobile-PC lvm[757]: Udev database has incomplete information about device /dev/nvme0n1p8.
Mar 06 16:25:15 Mobile-PC lvm[757]: /dev/nvme0n1p8: Failed to get external handle [udev].
Mar 06 16:25:15 Mobile-PC lvm[757]: Udev database has incomplete information about device /dev/nvme0n1p8.
Mar 06 16:25:15 Mobile-PC lvm[757]: /dev/nvme0n1p8: Failed to get external handle [udev].
Mar 06 16:25:15 Mobile-PC lvm[757]: Udev database has incomplete information about device /dev/nvme0n1p8.
Mar 06 16:25:15 Mobile-PC lvm[757]: /dev/nvme0n1p8: Failed to get external handle [udev].
...

The update included the two lvm packages:


> zypp-hist | grep '2022-03-06 16:2' | grep lvm
2022-03-06 16:23:13 | install | liblvm2cmd2_03 | 2.03.15-1.1
2022-03-06 16:23:18 | install | lvm2 | 2.03.15-1.1

I reverted both packages to:


 zypp-hist | grep '2022-03-06 16:5' | grep lvm
2022-03-06 16:53:09 | command | root@Mobile-PC | 'zypper' 'install' '--oldpackage' './lvm2-2.03.12-4.2.x86_64.rpm' './liblvm2cmd2_03-2.03.12-4.2.x86_64.rpm'
2022-03-06 16:53:10 | install | liblvm2cmd2_03 | 2.03.12-4.2
2022-03-06 16:53:11 | install | lvm2 | 2.03.12-4.2

from http://download.opensuse.org/history/20220304/tumbleweed/repo/oss/x86_64/ and the new errors are gone now.

Is this worth a bug report?

Gene

Do you observe any actual problem or is it about log messages?

I use that lvm volume for virtual images, so I downgraded the packages before I tried to access it. The only way to find out is to test an image on the new lvm packages. If I do file a bug, it looks like lvm bugs are filed as Component “Other”? At least I can’t find a more appropriate Component in the drop down list.

Gene

Hi
It would be Base:System https://build.opensuse.org/package/show/Base:System/lvm2

You might want to look at the ChangeLog to see if any of the recent fixes is related…
https://build.opensuse.org/package/view_file/Base:System/lvm2/lvm2.changes?expand=1

Maybe this link will help? openSUSE:Submitting bug reports - openSUSE

Hi
Looks like it’s already created… https://bugzilla.opensuse.org/show_bug.cgi?id=1181242

Thanks Malcolm. I found that bug earlier and added a reply. Hemming Zhao’s reply to me in Comment 56 is enlightening. Eventually they will get things sorted out.

Thanks,
Gene

Hi Gene
Excellent, Tumbleweed by nature is bleeding edge at times, warnings are to be expected, likewise important to report bugs even if it’s just a placeholder for issues…