New leap final installation on laptop. On each login get twice Kwalletmigration agent asking for pa

Hello,

On the new install of Leap 42.1 on my Medion laptop, I get after every sucessfull login 2 times the same KWallet migration agent popup asking for password, before I get the popup “KDE5 asked to open the wallet” for the wireless internet connection. After entering my wallet password on all 3 popups the wireless connection starts working and everyting works as expected.

I do not understand why I get those 2 popups and how I can eliminate them.

Regards, Frans

I had that problem on one of my computers. So I looked at another one where I was not having the problem, to see what was the difference.

Here’s how to fix it. Insert the following three lines:


[Migration]
alreadyMigrated=true


at the top of “$HOME/.config/kwalletrc”.

That’s simple text file. Use a simple text editor. I used “vi” (really “vim”), but “joe” or “nano” or other simple text editor should be fine.

It’s probably a KDE bug, that this problem is sometimes happening. But I did not try to report the bug. I just “fixed” it for my system with the addition of those three lines (yes, the third of those lines is blank (empty).

Thanks for your reply.

I applied it and the problem is now solved

Regards, Frans

That worked for me, too. Much appreciated. For what it’s worth, my ~/.config/kwalletrc looks like this now:

[Migration]
alreadyMigrated=true

[Wallet]
First Use=false

Is this a way of opensuse to tell its users to go away and use a system that does not have such an amazingly stupid “feature”?

I did a “fresh” Leap 42.1 installation but without modifying the /home partition and keeping the previous users from OpenSUSE 13.2 64bits.
I got the same phenomenon.

The proposed solution worked for my configuration.

Thanks for your help.
Patrice (from France)

This is a general KDE problem, and nothing openSUSE specific.