New Laptop Screen Resolution Help Please

Running KDE desktop on new (to me) laptop with wide format screen but with same old eyes; sadly the writing on the screen is too small for comfort.

At present using System Settings>Display and Monitor, the settings are shown as 1920x1080 and the window fills the whole screen. Picture brilliant but just too small for working for any length of time.

How may I adjust so that everything on screen including text is a bit larger. If I change the resolution I get a smaller window with unused space at each side and grossly distorted light bulb on starting screen, so that is not the complete answer.

I know I should know this but too many things to remember!!!

Grateful for help please.
Budge

System settings>Fonts Try increasing each font by 2 points and see if that suits you.

Since you’re using KDE (I assume SDDM is the display manager), you should investigate enabling HiDPI support. (That should help take care of the eyes!) It can be invoked my an edit to sddm.conf

https://en.opensuse.org/Sddm
https://wiki.archlinux.org/index.php/SDDM#Enable_HiDPI
or refer to the man page

man sddm.conf

@Budgie2: There’s a much better one: System settings - Fonts - Force DPI for fonts. Set it to 120, Apply, logout, login.

I concur, but I still recommend to try enabling HiDPI support first, then restart the display manager.

Weird enough that works flawlessly on the Lenovo Thinkpad T460 I upgraded to 15.0 today, set the overall DPI for both KDE and GNOME proplerly ( FWIW upgrade was boring ). I’ll check if unchecking the DPI settings in Fonts, logout, login makes a difference. I’ll report back.

OK, I’ve learned something today. Unchecked KDE’s DPI settings, put this in /etc/sddm.conf


[X11]EnableHiDPI=true
ServerArguments= -dpi 120

and my desktop is exactly the same, where the SDDM screen is a bit more readable. Thanks, Deano

A 15.0" 1920x1080 screen is 146.9 physical DPI. sddm.conf or xorg.conf or xrandr can all be used to set any arbitrary DPI, while KDE systemsettings last I looked only allowed a limited selection from a select list. There’s a breakpoint with some apps at 144, such as Firefox. Actually setting 144 might exaggerate an intended change, while 143 will not, yet 143 will produce very close to accurate density, matching the display’s physics. Systemsettings changes the DPI differently than does xorg.conf or xrandr, and probably the same for sddm. Systemsettings uses the Gnome DPI knob Xft.dpi that by default is 96. If Xft.dpi is allowed to remain at 96 while the rest of Xorg is 120 or more, you should expect fonts to remain tiny in GTK3 apps. Do

xrdb --query | grep dpi

to see what Xft.dpi is set to.

My 13" laptop has 3840x2160 resolution, so I certainly appreciate the pain. My 70 yr. old eyes couldn’t handle that without a magnifying glass. I tried adjusting the DPI, etc… but the results were less than satisfactory.

Since you’re using KDE try this instead:
Configure Desktop > Hardware > Display and Monitor > Advanced Settings > Scale Display
Then move the slider to the right until you get a look you can live with. You should reboot at this point in order to see the full effect. I had to go back and fine tune the setting a time or two, but now I’m able to work without eyestrain in most apps. A few stubbornly refuse to scale, but most are consistently better. Chrome doesn’t scale page content well, so I still have to zoom in to a page on occasion, and Darktable is not fun, but I can live with that.