New Laptop + new SuSE = problems - help

I’ve bought a new laptop and am having some trouble. My old one was a Dell Latitude CPX366XT with Suse 8.2. I loved that old machine and everything worked flawlessly without work (even WiFi when 802.11b was big) but it was falling apart and with a maxed out ram of 256 MB I couldn’t do much nowadays. Well I bought an Acer Aspire 5050-3785 and installed 10.3 64-bit and some things do not work and for the life of me I cannot fix them.

First the sound. It is a Realtek ALC883 and ALSA isn’t working. I cannot download the newest version from their web site either. Everything I find tells me to download the new driver and try it but I have tried for a week and the download just sits their saying “Starting…”

Secondly, dual display. I have the ATi Radeon Xpress 1100 and there isn’t a Linux specific driver for it and so I cannot get a second display to work. It flickers when I try but nothing beyond that. When I try and run Xinerama there is a bar on the kicker with “Multiple Monitors” trying to open but it stops and disappears. I also cannot run youtube videos in full screen. I have updated Flash but it didn’t help.

Multimedia. I know this is a pain to get working. I tried the same RPMs I used on the Dell (played all videos save DVD since the machine only had a CD drive) but they don’t work on this Acer with 64-bit 10.3.

My main use on this machine is internet, watching videos on, NES emulation. I installed 10.3 the day I got it but gave up trying to get things working after a few days. I was using the Vista on it until what usually happens with windows happened, even with a good and up to date anti-virus. Vista never worked well anyway. I have most everything else I like straightened out but not these. Also my Linux knowledge is limited. I can start and stop stuff, basic DOS style commands in a shell, but that is it.

Any help would be much appreciated.

Good … stay away from their audio driver. Stick with alsa that comes with openSUSE (or can be updated from rpms that I can provide links to).

You could try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation.

multimedia is easy, once you know how. Thats the trick. You need to use 11.1 rpms. And I’ll show you how to do this, once we get sound working.

I know it may sound bad but how can you call openSUSE 10.3 new ?? It will lose updates support this year do you know that? I propose you install 11.1 or else you will be running an insecure OS else you will be forced to install a new openSUSE if you want to have security updates.

That command will only work on openSUSE-11.1 or later.

So instead for openSUSE-10.3, run the following command to get the diagnostic script to run (with your PC connected to the internet):

wget -O && bash


> Suse 8.2.

imo, there has been a notable shift in philosophy between 8.2 and
10.3: (paraphrased from elsewhere) while 8.2 was released when ready
10.3 was released on the date set for it to release seven or eight
months prior to the set in concrete release date…and is now only
six months into two years of updates, patches, etc…

remember, way back when SuSE was a little company in Germany making
software they worked until they got it right and THEN released as
stable and dependable a product as they could make…

THEN, Novell bought that little company and set up a community (like
Red Hat set up the Fedora Community) of folks who knowingly
participate in the PAIN and SUFFERING of beating buggy and BETA
software into submission…usually through several cycles or numbered
releases delivered according to a date certain and THEN Novell
release a commercial product (SUSE Linux Enterprise
Desktop/Server aka: SLED and SLES) for SALE when they are ready

what i’m saying is: openSUSE ain’t your granddaddy’s SuSE–you can be
certain it IS buggy and will take some fiddling to get to the same
level of stability and reliability you were used to in 8.2, the day
you first installed it…

> I bought an Acer Aspire 5050-3785

that machine is not listed on the community’s Hardware Compatibility
List at

there is a 5051 listed which states “Dual-head support out of the
box” with openSUSE 10.2

once you have solved your issues you would please be so kind as to
include your machine…

> installed 10.3 64-bit and some things do not work and for
> the life of me I cannot fix them.

two things:

as mentioned 10.3 ages out soon (31 Oct 09:

and, while 64 bit is getting easier and easier to use it still
requires more fiddling than i want to put up with…and, unless you
have specific programmatic needs for 64 bit (million line db,
crunching massive RAW photo files, video editing, and others), you
might find (as others have) the gains are not yet worth the extra
effort…ymmv, read around (there are numerous discussions on 43 vs 64
in these fora, and elsewhere)…

i think if i were you i’d download a 11.1 Live CD with gnome (caution:
KDE4 is a work in progress…and, it far too troublesome for my
time) and see what works and what doesn’t…then i’d install from the
11.1 DVD and choose any DE other than KDE4…

i mean, why go to the trouble of getting 10.3 working and then
(probably) have to do it all again when you move to 11.x in
November, or before…NOTE: there is currently no reliable, supported
way to ‘upgrade’ from 10.3 to 11.x, instead the community suggests to
backup/protect your /home and do a new install from the DVD (thereby
requiring all the fiddling, again!)

> First the sound.

if oldcpu can’t guide you to happiness with sound, then look no
further…just throw your new machine away, or try a different distro,
or [hate to say it] some other operating system…

some have instant gratification with either Ubuntu or others…[each
have their strengths and weaknesses]

> Secondly, dual display. I have the ATi Radeon Xpress 1100 and there
> isn’t a Linux specific driver for it and so I cannot get a second
> display to work.

sorry i can’t help (maybe others know a work around) but i just one to
point out that the current state of affairs is that nVidia provides
the best driver support today

it has been rumored that Intel will, but they haven’t proved that to
me, yet…

ATI and any others run a distant third…imo

so, lets say oldcpu can’t fix your sound and you throw that machine
away (or worse) switch to a game OS, then next time buy a machine with
known compatible hardware and nVidia supported graphics…

> Multimedia.

have a look at even if you are not a noob,
therein you will find a link multimedia which should do what you need
if you give up on 10.3 and install 11.1 instead…

if you stick to 10.3 you need to see here:

and carry a big sack of good luck with you!

> My main use on this machine is internet, watching videos on
>, NES emulation. I installed 10.3 the day I got it but gave
> up trying to get things working after a few days.

i’m on 32 bit openSUSE 10.3 with KDE3.5 and all of those things except
NES emulation work flawlessly…but, it took installing the latest
Flash, SUN Java, mplayer plugin and i’m don’t really recall what else
to get all of that working in Firefox 3.0.12

well, it IS almost impossible to get some of the netbanks which run on
M$ servers to play at all, much less nicely…ymmv

AND, i’m afraid to even try to ‘upgrade’ to FF 3.5 (mine ain’t broke, so!)

> Also my Linux
> knowledge is limited. I can start and stop stuff, basic DOS style
> commands in a shell, but that is it.

that puts you MILES ahead of many here…

> Any help would be much appreciated.

listen carefully to oldcpu…

some others may appear more experienced than they really are…backup
and take all necessary protective, track back measures you
need…this is a community of volunteer, not expertise vetted,
individuals with wildly differing understandings of the inner workings
of Merlin’s magic…

if you want a less fiddling, less beta and more stable, 8.2 type
experience i’d recommend you look at and seriously consider

caveat: i am not in any way connected with Novell and will receive NO
compensation from same even if you buy 10,000 SLED licenses

Note: Accuracy, completeness, legality, or usefulness of this posting
may be illusive.

Alright, I got the sound working. When I checked the installed packages alsaplayer was missing so I installed that and followed that guide a little ways. I deleted the old configuration with YaST and did a normal setup of the card and I now have sound.

Ok, now how about the multimedia…

P.S. I am not to woried about it being insecure. Up until a year ago I was using 8.2.

Congratulations on sorting the sound. This will likely be easier in openSUSE-11.2 GM release, as it will have 1.0.20 of alsa in the 2.6.31 kernel.

Please read this post: openSUSE Forums - View Single Post - sound problems on Gateway M-6874h

The “trick” is only 4 repositories (OSS, Non-OSS, Update and Packman). Many users ignore that (despite my advice), and they end up with codecs from videolan in directories that Packman players do not look, plus other problems. So just those 4 repositories, and replace Novell/SuSE-GmbH packaged applications with Packman packaged applications.

Please do yourself a favor and go for openSUSE 11.1 instead of 10.3
Chances are you would have met none of the hardware trouble: 11.1 was built around a much newer kernel, so more hardware supported.

BTW: I like the username. Somewhere from our eastern parts of the country? ojokwoslust.