New kernels -> a random 20% of nics remains off after loading the os


I’ve a new problem after updating Tumbleweed to kernel 13.8 or 14.
I use it on school’s computers. They have realtek network cards.

When I start the computers with updated Tumbleweed with kernel 13.8 or 14, I have this issue : there’s a random 20% (average) of the computers that have their network card off when Tumbleweed is loaded. It’s very curious.
When I restart one of these, the network card then always works after rebooting.
If I turn them off, then start them -> again a random of 20% (average) of them have the nic off.
When I do lspci, and the nic if off, it doesn’t appear in the list !

I tried these :

  • putting in grub some second to wait before starting the default system,
  • putting a wait time in systemd nerwork service before loading,
    non of these have solved the issue.

If I go back to my six month old install of Tumbleweed (I’ve got system images with clonezilla), the issue disappears.
If I come forward to the new 13.8 or 14 kernel, agains an average of 20% (average) of the started computers have their nic remaining off when tumbleweed loads.

It seems that the kernel part starts so fast that the nic isn’t detected… I really don’t have a clue…

I hope someone can help…
Thanks in advance.
Kind regards,

What model network cards?

/usr/sbin/lspci -nnk | egrep -A3 "Ethernet"

Hello Malcolmlewis,

Here it is :

01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
Subsystem: ZOTAC International (MCO) Ltd. Device [19da:8168]
Kernel driver in use: r8169
Kernel modules: r8169

I’ve in the school a ton of computers with this realtek card, and I can’t bye nics for all of them.
It seems that identical computers do not this with the same frequency : some do it 10% of the time, others a steady 50%. So it’s a time problem with kernel.
Surely, if I could delay loading grub, it could solve the problem.

When I restart, it solve the problem. So it’s a problem with powering motherboard’s nic before starting grub… I suppose.

Thanks a lot.
Kind regards,

I would report as a bug, openSUSE:Submitting bug reports - openSUSE it could be firmware related, but the r8169 seems to be buggy at times… Some users switch to the r8168 driver from user Sauerland’s repo…

Thanks Malcolmlewis,

I will try r8168.
I already checked the page, it blacklist the 8169 driver, seems to be the solution…

Thanks a very lot !!!
I will report asap.
I hope to try tomorrow or Friday.

Regards !


After a month of clonage of the Tumbleweed installation to various computer, I can report this.**

I used :

Then it solved the problem on various RTL8169 computer ! Great.
BUT it generated problem on others RTL8169 computers : their nic didn’t worked anymore.

So I did this : I installed these two r8168 rpms on my Tumbleweed installation, then replicated to all my computers, and then removed them on the few ones that lost connection to network.
Now my 200 computers are all working perfectly on the network !

Thanks for all your help !

Maybe some of the PC are getting only the blacklist.rpm and not the kernel.rpm for r8168???

That will prevent r8169 from starting and because of not installed r8168 properly also there is no network…

Hello Sauerland,

Thanks a lot.
I replicate my installation with clonezilla on all compouter in the school.
Then they should all have the same packages installed : r8168 et blacklist-r8169.

The ones that had connexion problems works well, somme other have the nic r8169 failing to start. They are few, so I manually uninstalled r8168 and blacklist-r8169, and they worked well again.
I don’t know why…