new Kernel, no more sound....

I just updated to the Kernel ( together with several upgrade for KDE (Version 4.2.90 - release 139), using Community and Factory repositories as well, and I lost sound on the next reboot. This is with OpenSuSE 11.1 over an AMD64 desktop with the NVidia HDA sound board built in the motherboard.

I tried to install the sound drivers again and the old message from alsaconf appeared: "No supported PnP or PCI card found".

This use to be a problem with older Kernels that did not included this sound board. I remember tried every workaround and nothing solved it until the next kernel version…

I tried with the drivers from:

Before this Kernel upgrade, I was able to install my sound board without problem using any of these drivers. Now, I get the old alsaconf error message. I get same behavior if switching on the BIOS from HDA to AC97 mode.

I guess many of us are having the same problem. So, should we wait for a new Kernel? or is there a functional workaround?

kind regards!

As you noted, some users have reported problems with the new kernel and sound.

My “self appointed” volunteer effort in openSUSE Linux has mainly been to help users with basic sound problems. I am not a developer, but just a regular user who feels badly for those who can not get their sound to work, so I help best I can within the limited knowledge that I have in this complex area. But I confine that effort to alsa that comes packaged with openSUSE (or provided by the SuSE-GmbH packager). I do not plan to make any effort to support the realtek drivers.

Waiting for a new kernel is unlikely to be necessary for users who use an alsa driver packaged by SuSE-GmbH. It may be necessary if you wish to continue on the realtek driver route.

In the case of alsa packaged by SuSE-GmbH, typically the SuSE-GmbH alsa packager (who is also an alsa developer) will package updated rpms for openSUSE specific to the new kernel. I have a wiki I created here providing guidance how to install those: Alsa-update - openSUSE-11.1

I note that as of today the SuSE-GmbH packager has made some alsa rpms available for that kernel version.

Note one must send SIX zypper commands to do the update, and then reboot after updating.

I do not know what impact, if any, your realtek drivers will have on the installation of that alsa update (to 1.0.20 of alsa) on top.

Hi OldCPU,
I followed your alsa-update wiki and it worked greatly.rotfl!
Now I have sound again.

For newbies (like me :wink: ) I would just add that the command lines you use to add the repositories, will not work unless they point to a repo file. So you can complete them to the repo file or just add the repositories with Yast.
I used the three first command lines and then the next three command lines according to the Kernel version (the closest you have). I have ( so I used the command lines posted for (

Then at the Konsole again (or the Terminal view of Konqueror or Dolphin fie manager), as root (-su) and used the ./install command for installing the “realtek-linux-audiopack-5.11”

This time alsaconf did recognized my sound board and configured it properly. Reboot and there was sound, crystal clear!

Thanks a lot OldCpu

OK, … thats all new to me, … but I’m happy to read it worked for you. Well done and thank you for sharing your solution.