New kernel fail to run

Out of curiosity, I decided to try the kernel-desktop-base-2.6.35-rc6.15.1.x86_64.rpm downloaded with 1-click install from here

Now my desktop can’t even boot and says

Want me to fall back to /dev/disk/by-id/ata-Hitachi_HD725016GLA380_GEK830RBTV12MA-part2? (Y/n)

Both options got me nowhere.
Can anyone tell me how to debug this situation?

Sorry I cant help you with debug, but have you tried to compile the kernel yourself from source?

I can’t use wget to download kernel. Can’t find home folder too. Resorting to repair DVD which is still downloading.
Any other options?

When you want to upgrade the kernel, there is more than one file that needs to be upgraded. That means that when using the 1-click method, you would need to load each separate kernel component. I can NOT recommend using the 1-click method as a way to update your kernel. Instead, you need to use/add a repository, making sure to upgrade all kernel version components installed on your PC. Also, the 1-click install says you are loading kernel 2.6.35, but it is VERY WRONG. Instead, you are loading kernel 2.6.36-rc3 at last look. I have found that the proprietary nVidia driver is not working properly with kernel 2.6.36 at this time. The only repository I have found still online that supplies an older version of kernel 2.6.35 for openSUSE 11.3 is located at:

Now to your problem. Once the kernel is screwed up you only have one possibility. That is, did you leave the older kernel there present, or did it get replaced completely? Does you grub file provide any option except the new kernel? If so, I would boot into the older kernel and use the link above to load 2.6.35.

If you do not have any other kernel left to load, then I feel you must reload openSUSE. The next question is, did you create a separate home area partition? If you did, reinstall openSUSE 11.3, but DO NOT Reformat the /home area partition and use the same user name as before. After a new install of openSUSE, but using an existing /home area will bring back most of your user settings including bookmarks, mail and other goodies that you did not lose.

Thank You,

If you have your original DVD or live CD I believe you can do an upgrade and just select the original kernel files from the list of files to upgrade.
It’s a while since I had to do that but I know it can be done. I’m not sure what you choose on the startup -it’s not full instal or repair that’s why I say upgrade. I think it’s obvious when you see that appropriate screen.


your signature says you’re using oS 11.3. does that mean i can use the above kernel for my 11.3 installation? i’ve been searching everywhere for 2.6.35 kernel, but couldn’t find it, short of git.

i understand that’s the only way to use nvidia propr. drivers w/o using the standard kernel, isn’t it?


Pete: as far as i know, only the full DVD has the upgrade option. liveCD doesn’t.


No No No, you do not need to change your kernel version to use the nVidia Proprietary Binary Driver. In fact I suggest that you instead use the repository to install the driver located at:

The only reason why I updated my kernel was due to the fact that USB3 external hard drives DOES NOT WORK with kernel 2.6.34 as shipped with openSUSE 11.3. However, unless the present kernel you have loaded on your computer has a problem for you, I highly recommend that you do not update it. You may be mixing up the fact that if you update your kernel after installing the nVidia driver the hard way (as in not using the repository I listed above), you must reload the nVidia driver. This is not true if you use the above repository and happen to get a kernel security update sent down to your system.

Thank You,

jdmcdaniel3: misunderstanding. i already upgraded to kernel 2.6.36 because my system was quite sluggish; Xorg consuming ard. 40% (of both) CPUs over extended periods (using nuoevo). response is much better with the kernel from HEAD, but now i can’t get nvidia to work. in several forums/blogs i read that it does work with 2.6.35; that’s why i want to down-, not upgrade.

i assume that “factory” in the repo name comes from a time when 11.3 was factory, correct?

thanks for your concern though,

OK then, you are very right that so far, the nVidia driver does not work with kernel 2.6.36. The link I provided would allow you to update (or downgrade) to kernel 2.6.35-rc3 which was not the final release. Once you add the repository, you go into YaST / Software Management and search for kernel. Go to the version tab and elect to use 2.6.35-rc2 for each kernel file that such a choice exists. Using this method will replace and not retain your old kernel, but that seems like not be a problem.

There is another way to upgrade your kernel by going to The Linux Kernel Archives and downloading the final version of the kernel for I think as a bz2 file. If you want, you can install this version, but since it was not compiled directly for openSUSE 11.3, some startup things will be missing such as the kernel green screen you get while it loads, over the normal kernel load. Here is the procedure if you want to try this:

Download the kernel source file linux- (or the current name) to your /home/user/Downloads folder. Open up a Terminal Session as a standard user such as Konsole (do not open terminal as root and do not become root before using these instructions).

To uncompress the files you can use these terminal commands:

bunzip2 -dv linux-
tar -xvf linux-
cd linux-

If this went OK, you should be located in the folder /home/user/Downloads/linux- and ready for the next step.

cp /proc/config.gz .
gunzip config.gz
cp config .config

You should not get any error messages. If you do, you may want to re-download the files and perhaps try a different way to uncompress the files. Now to create the kernel file.

sudo make modules_install install

The make command can take a LONG TIME to complete. When you run the sudo command, the only part that requires root user access, you must enter the root password. When done, your Grub menu.lst file will have two new entries and still have your old entries. Restart and give it a try. Pick your old setup if it does not work. If the compile fails, you will not get any new entries in your menu.lst file. Seems like I had to press enter a couple of times to accept a default setting for the final kernel make command.

Good Luck,

thank you for these very complete instructions. i’m quite familiar with yast or rpm installation of new kernels, but the option via is new to me. interesting, in case i’m not happy with the suse kernel for some reason. generally though i like to stick to suse; i think it’s more than the splash screen i would loose by using the vanilla version.

i was already thinking to clone the kernel git repo, but my internet connection is slow and this would take forever. moreover i’d like to avoid compiling the whole kernel; as you said, it’s a long process, even with 2 CPUs.

thanks again,

bingo! everything worked (almost) flawlessly. kernel installed, nvidia driver compiled, but somewhere on the way i lost my soundcard :frowning: ; IRQ conflict with the video card i guess. would be too much to expect that i can just use my computer now, without fiddling around for hours…

Xorg seems to use slightly more CPU than with nuoevo, but far less than with the standard kernel; doesn’t create a disturbance. i can only recommend this process for anyone finding that oS 11.3 acts too sluggish. works well with nuoevo & nvidia.


phanisvara says: bingo! everything worked (almost) flawlessly. kernel installed, nvidia driver compiled, but somewhere on the way i lost my soundcard :frowning: ; IRQ conflict with the video card i guess. would be too much to expect that i can just use my computer now, without fiddling around for hours…
Well at least you got a kernel back that works with nVidia. Hopefully, you figure out your sound problem as well.

Thank You,

sound problem solved itself, somehow. after a while sound was just back, don’t remember if a reboot was involved. there’s something like “irq-balancer demon,” i guess that’s what it does.

but there’s something else i’d like to share: looking anxiously at CPU load, especially in connection with Xorg, i found that my new configuration tended to get overly busy again; with a few larger apps. running, i saw Xorg using 40% of 2 CPUs once again. horror: all for nothing? not really.

the newer kernel seems to be able to manage applications better, in spite of high CPU load. but the most important thing (for me) i figured out was: don’t configure multiple monitors to use “separate X screens.” that multiplies the Xorg overhead, since there’s an X server running for each monitor. i changed nVidia config to “twin view” and am back to lovely low Xorg CPU figures.

another advantage is that running multi monitors with “separate X screens” and “panoramaview” enabled, you can’t use desktop effects; using “twin view” you can. so now my machine is fully functional, very responsive, even with a few select effects enabled.

(perhaps this experience helps someone, at some point; who knows…)


on the openSUSE mailing list (Re: [opensuse] Re: kernel 2.6.36 speeds things up) Philipp Thomas posted the patch below, which makes a small change to one file in the nvidia driver source.

(you can get the source easily from the file: “sh -x” extracts everything into a direcotry. the file “nv.c” is in folder kernel/)

for me—openSUSE 11.3 (x86_64) Kernel: 2.6.36-rc3-10-default, KDE Development Platform: 4.5.1 (KDE 4.5.1)—this patch works great. the patched driver compiles & works well–until now; have been using it only for a few hours.

**Re: [opensuse] Re: kernel 2.6.36 speeds things up**
From: Philipp Thomas <pth@xxxxxxx>
Date: Tue, 7 Sep 2010 14:11:13 +0200
Message-id: <20100907121113.GC6529@xxxxxxxxxxxxxxxx>
* phanisvara das (phani00@xxxxxxxxx) [20100905 20:50]:

> didn't work for me. "kernelmodule could not be built," or similar. in the log 
> file, it suggests doing things to the kernel source configuration. 

The patch I used is attached.


--- kernel/nv.c.original 2010-09-07 13:55:25.770456446 +0200
+++ kernel/nv.c 2010-09-07 14:08:34.681351694 +0200
@@ -423,7 +423,9 @@ static struct pci_driver nv_pci_driver =
static struct file_operations nv_fops = {
.owner = THIS_MODULE,
.poll = nv_kern_poll,
.ioctl = nv_kern_ioctl,
.unlocked_ioctl = nv_kern_unlocked_ioctl,


Thanks phanisvara for the information. I am thinking that unless I have a problem with the kernel I have loaded, I most likely will not load a kernel that has not yet made it to a final release. So far using kernel is working well for me. It is good to know that there is a way to patch the nVidia driver to also work with kernel 2.6.36, but perhaps nVidia will also fix this in the future as well.

Thank You,

definitely; no point in running after the latest available kernel for no good reason. i had problems with 2.34, came to 2.35 via 2.36, and somehow managed to make things unstable when everything seemed to be working with 2.35. i don’t think that’s the kernel’s or the driver’s fault; i was messing around with things i don’t fully understand, and that’s a pretty sure way to get screwed. now i’m using 2.36 again, with nvidia, and hope to stay that way until major updates / upgrades happen in my repos.