New issue UHD display upgrading to 15.0 and changing resolution to FHD cause may apps to be oversize

I have some Dell UHD laptops that I converted from 42.3 to 15.0 via the USB update image as the zypper dup from init 3 would not connect to WiFi and Ethernet was not an option.

The conversion went well but when 15.0 booted the 1st time the display was UHD (3840x2160) not FHD (1920x1080). I changed the display to the correct resolution as all my wine apps were too small to see. Now many apps are too big - VLC, Virtualbox and VBox machines are 4 times too big. My large monitor that I connect the laptops to cannot display UHD and I cannot see the mini fonts but something with the upgrade caused this.

How do I fix this - I cannot find the source of this -

HiDPI problems can be a sticky wicket to solve. :stuck_out_tongue:

Exactly how did you “changed the display to the correct resolution”?

What do

xrdb -query | grep dpi

and

sudo zypper in inxi; inxi -Gxx

in an Xterm or Konsole report?

Which DE and/or WM are you using?

Which DM are you using? If sddm you may need to refer to Sddm - openSUSE Wiki

If you create a new user, does using it change the behavior?

Are these UEFI installations?

Is 15.0 the only installed operating system? If not, what else is?

no UEFI - basic grub2 no NVIDIA drivers - nouveau.modeset=0 in /etc/default/grub or system hangs

xrdb -query | grep dpi

Xft.dpi: 95.923828125

inxi -Gxx

Graphics: Card-1: Intel HD Graphics 530 bus-ID: 00:02.0 chip-ID: 8086:191b
Card-2: NVIDIA GM107M [GeForce GTX 960M]
bus-ID: 02:00.0 chip-ID: 10de:139b
Display Server: X.org 1.19.6
drivers: modesetting (unloaded: fbdev,vesa,intel)
tty size: 80x24 Advanced Data: N/A for root out of X

changed display via System > Preference > Displays > in Resolution Box and choose 1920X1080 and accept (to go back I chose the highest resolution 3840x2160)

Desktop is Mate with GDM as display manager

Was only LEAP 42.3 upgraded to LEAP 15.0 (Windows 10 was completely eradicated and MBR changed to MSDOS from GPT) and Packman was removed before update and readded after update and allowed to replace openSUSE files with Packman for 15.0. Issue with VLC was there before it upgraded to Packman version.

Hard to add a new user as it is automated to autologon and start 6 VirtualBox Virtual Machines that are in use - will be Friday before I can try adding new user - If I VNC into one of the Virtual Machines rather than from the host machine - the display is the correct resolution.

Identical laptop with 42.3 answers (different vendor SSD’s as I don’t want then to die at about the same time again as some old WD 320gb did a day apart) both Dells - Have not tried this yet on one of the two HP UHD laptops - both in other states and I cannot do a remote upgrade - they will be overnight-ed to me do be done.

xrdb -query | grep dpi

Xft.dpi: 96.0419921875

inxi -Gxx

Resuming in non X mode: xdpyinfo not found. For package install advice run: inxi --recommends
Graphics: Card-1: Intel HD Graphics 530 bus-ID: 00:02.0 chip-ID: 8086:191b
Card-2: NVIDIA GM107M [GeForce GTX 960M]
bus-ID: 02:00.0 chip-ID: 10de:139b
Display Server: X.org 1.18.3 drivers: modesetting (unloaded: fbdev,vesa,intel)
tty size: 80x24 Advanced Data: N/A for root

Intel + NVidia = Optimus video, so there’s little more I can help with but to point to https://en.opensuse.org/SDB:NVIDIA_Bumblebee and say there are a lot of threads “here” (mainly in Install/Boot/Login and in Hardware) and elsewhere about solving problems with Optimus. HTH

Solved -

I restored user 1000 from last good backup before the update to another location in home <1000> is the username that is logged in.

cd /home
tar xvf /path/to/lastback.tar home/<1000>
cd /home/home
mv <1000> old1000
mv old1000 …/.
cd …/.
pwd (make sure you are where you want to be)
rmdir home
mv <1000> new1000 ; mv old1000 <1000> ; init 6

and everything looks like it did in 42.3 after the reboot.

Did you try adjusting the display scale?
System Settings > Display and Monitor > Displays > Scale Display (its right at the bottom)
there is a slider.

Sorry the above post was wrong - it went directly to UHD and wine is miniaturized

Back to the drawing board

It is a QT5 issue with MATE 20.

In MATE-Tweak under windows there is a HiDPI option - it was set to High - changed to normal and it fixed the problem

Found this in the Ubuntu MATE release document for release 20 MATE