New installation: going straight into grub2 command line on boot

I’ve installed Leap 15.2 on this new laptop and for some reason which I cannot figure out it goes straight into the Grub2 command line when it boots.

Secure boot is disabled in the UEFI settings, though I have tried with all possible combinations of secure boot enabled/disabled and grub2 secure boot support/no support.

I have tried doing a

grub2-install /dev/nvme0n1p2

No change.

This is the output of fdisk -l


Device           Start        End    Sectors   Size Type
/dev/nvme0n1p1    2048    1026047    1024000   500M EFI System
/dev/nvme0n1p2 1026048    1538047     512000   250M Linux filesystem
/dev/nvme0n1p3 1538048 2000409230 1998871183 953.1G Linux LVM

I can start the system by hand no problems from the grub2 command line by doing:


linuxefi (hd0,gpt2)/vmlinuz
initrdefi (hd0,gpt2)/initrd
boot

As you will have surmised by now, there is a separate /boot partition. This is because the LVM volume is encrypted.

Any ideas how I can get the system to boot directly? The only thing I haven’t tried is switching to BIOS mode, but I’d rather have it use UEFI.

Funny thing is that I already have another laptop (different brand) configured in the same way and that has always worked just fine. The only difference: it was initially a Leap 15.1 installation.

[QUOTE=licehunter;2989702]
I have tried doing a

grub2-install /dev/nvme0n1p2

I’m pretty sure it should be

grub2-install /dev/nvme0n1

It is not for the file system but for the nvme drive

You are of course entirely correct. My apologies, it was a typing error.

What’s the output from:

/usr/sbin/efibootmgr -v

rotfl!

It turns out that it was booting into the wrong EFI boot entry!


# efibootmgr
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0002,0000,0001,0003,0004,0005
Boot0000* ubuntu
Boot0001  UEFI OS
Boot0002* opensuse
Boot0003* UEFI:CD/DVD Drive
Boot0004* UEFI:Removable Device
Boot0005* UEFI:Network Device

The “ubuntu” entry is what came with the laptop, nothing of my doing!

This removes the spurious boot entry and gets rid of the problem:


efibootmgr -b 0 -B 0

The laptop, by the way, is a KDE Slimbook, a right beast! >:)

https://i.imgur.com/FtdnGu8.png

Seems like we crossed posts, but you were definitely on the right track. Thanks! :slight_smile:

I’m glad you solved it.

Thanks for reporting back.