New installation automatic opening of website using url from keepassxc not working

I am setting up a new installation on KDE desktop.
When I click on an URL in keepassxc this no longer opens in a browser.
Sorry if it is a dumb question but which of the many hundreds of settings and where and what do I change to have this work.
I ask because I have never had this problem before.

This is becoming more serious. If I click on an URL it does not open in my browser.

What is controlling the action of clicking on an URL. If I right click I only get copy link location nothing more. Left clicking does nothing.

I do not have this problem on other computers here so where do I look for the cause of the problem please?

Check System Settings > Personalisation > Applications…

Hi Deano,
That seemed credible but there is nothing I can see that needs changing except I don’t know if there is a file association missing and in which case which. Surely a url would be high on the priority.
The same problem occurs on all the new builds of Leap 15.3 I am working on.

I’m not familiar with keepassxc, but I suggest you check the guide…

Hi Deano,
I shall continue reading it but out of interest I changed my desktop to xfce and had no problem using keepassxc. Clicking on the link in keepassxc opened in a browser just like that!
I didn’t have to make any changes to anything.
I suspect KDE as the villain here but one on my Leap 15.3 machines does not have this problem. Of course it might be waiting for an update.

I had been using the appimage version. It works OK on TW but not on Leap 15.3.
I have deleted the appimage and installed from repo.
Now all working as it should.