New install of openSUSE 12.1 64-bit problems

I was new to Linux a year or two ago when I installed the openSUSE 11.4 32-bit OS
with the Gnome desktop. Yesterday (July 4, 2012) I tried installing the openSUSE
12.1 64-bit OS with the Gnome & KDE desktops & additional software off of DVD (as
I had done with openSUSE 11.4 previously). I ran into problems with the 12.1 install/
login/run. Because of these, I accessed the openSUSE forums to see if my issues had
already been reported and to find solutions. I learned a lot of information, but nothing
specific to my issues. I learned things to do, as well as things not to do, so I tried a
2nd clean install of 12.1 today. I got the exact same failures, so hence this posting.

What I did (some of which is based on what I read in the forums):

  1. Checked the DVD before install - md5 checksums matched and kernel reported OK
  2. Chose to install only Gnome desktop and no other add on software
  3. Disabled loading from images (I’m not sure what this is, but forums mentioned this)

The install went OK up to the point where it said it was going to shutdown in 10 seconds,
when it did so. At this point, the screen goes blank and the only thing that happens is
the power light button on my Apple display starts flashing every second. I let this go on
for about 4-5 minutes before killing the power (yesterday it occurred and I let it go on
for about 10 minutes before killing the power). Doing this kept the install from going
through it’s “auto configure” sequence, as it did when I installed 11.4.

Turning the machine back on, the machine came up and appeared to run fine.
I click on my name in the upper right corner which dropped down some menu
allowing me to log out, suspend, etc. and immediately had an error and displayed
the following:

Oh no! Something has gone wrong.
A problem has occurred and the system can’t recover.
Some of the extensions below may have caused this.
Please try disabling some of these, and then log out and try again.
Alternative status menu with a slider that said ON.

I clicked the slider to OFF and did a log out as requested.

I then logged back in. When clicking on my name again in the upper right corner
of the screen, this time the drop down menu was missing the two lines below
“suspend” which were for restarting and shutting down the machine. Now, I have
no way to shutdown the machine using the GUI. I can and did shut it down using
the shutdown command at the command-line.

I might also point out the following:

  1. I have an NVIDIA graphics card
  2. I have a dual-boot system with Mac OS X and Linux (each system has its own internal disks)

Thanks in advance for any and all help with my problems.


I might suggest you type in the kernel load option called nomodeset and then press the enter key to select the default load of openSUSE. I must do this due to also having an nVIDIA video card and I then later installed the nVIDIA proprietary video driver. I do not have an Apple system, but the nVIDIA GPU may require the same solution I use.

Thank You,

@James, this is not the issue. The OP has had some extension installed to expand the main menu for GNOME3.
EDIT: he should already have the NVIDIA driver installed. otherwise GNOME would go into fall-back mode, and the menu would be on the bottom left :smiley:

@rderosier: go to, using Firefox. Browse the extensions, and install the ones you like, the extended status menu is there as well.


I don’t think I understood when you meant for me to type “nomodeset”, I’ll let you tell me after I
explain what I did.

I put in the openSUSE 12.1 64-bit DVD and restarted my computer.
The first thing I see on my screen is what to boot from and I selected INSTALLATION.
At the same time, I see the BOOT options or something at the bottom of everything else,
so I thought this is where I was to type “nomodeset”, which I did. Then I proceeded with
the installation process. Everything proceeded just like in my original posting and it came
to the point of rebooting, which it did just like before. The screen went blank and the
Apple display start button started blinking every second, just like before, and nothing
else happens. After a couple of minutes, I killed the power and restarted my computer.


My Linux system comes up this time still in the install process and getting ready to
start the Automatic Configuration part (which it never did in the original posting). But
immediately a Yast dialog box appears telling me the previous installation failed and
that I might have to reenter some of the same information again if I choose to redo
it. And it asks me to proceed or not, to which I said yes. Now the Yast dialog box
disappears and the previous installation continues with the Automatic Configuration.
After finishing, I’m presented with booting into the normal 12.1 system or the 12.1
recovery system and I again see the BOOT options or something line below them
which I assume is where you actually wanted me to type “nomodeset”, but I was
caught off guard and hesitated too long to do so when the system rebooted using
the default.

I haven’t noticed any problems since, at least doing what I did originally, which is
minimal testing. At least clicking on my name in the upper-right corner of the
screen didn’t cause any problem, so far. I see the last two lines, Hibernate and
Power Off, which got deleted last time.

Getting that Yast error message concerns me, but everything seems to be working
properly, as far as I can tell, so I’ll keep testing and report back if/when I encounter
any problem.

If I did type “nomodeset” at the wrong place, what, if any, ramifications can be
expected, and why the change in behavior my 3rd attempt at installing 12.1 from
my previous 2 attempts?


Well, that didn’t take long. I quickly ran into the same problem again getting:

Oh no! Something has gone wrong.
A problem has occurred and the system can’t recover.
Some of the extensions below may have caused this.
Please try disabling some of these, and then log out and try again.
Alternative status menu with a slider that said ON.

I refused to click the slider to OFF because of what happened last time
when I did so.

I even restarted my Linux system and this time I did type “nomodeset”
when booting into 12.1. It made no difference and I soon got the above
error again.

What now?

So I am just not the expert on installing openSUSE onto an Apple computer. I would request a complete listing of your hardware, including video with makes and model and brand if anything is not Apple. IN the mean time I would read this forum message which might be helpful. I would read ALL of the posts here before I did anything else.

Thank You,

Should I just go ahead and try to load the latest NVIDIA drivers from the repositories
and assume doing so will alleviate all my problems? That is assuming you think that
is the cause of them in the first place.

I can do whatever anybody feels will help, ie, I’m not worried about any data loss
by experimenting with things. Just remember, I’m new to Linux, so you will need
to give me explicit instructions on what to do and how to do them.


Let me say that if you type in the number 3, instead of nomodeset, allow openSUSE to load, you will be at the terminal prompt. This is from where you would install the nVIDIA driver. You would download the nVIDIA driver first and I have a bash script you can use to load it. You must edit the bash script to tell it where you have placed the nVIDIA driver. You do these things first. If you can’t get a system to work long enough to do these things, it will be a problem. I would also say that if the issue is the graphic driver, when you switch to the terminal mode with no desktop loaded, the system should be rock solid with no lockups. You can even run YaST (just yast at terminal) if you wanted to. Here are some links to look at, but it would be nice to know exactly what nVIDIA card you have installed.

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.45 - Blogs - openSUSE Forums

Thank You,

My hardware:

Desktop Computer

Model Name: Mac Pro
Model Identifier: MacPro3,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.8 GHz
Number Of Processors: 2
Total Number Of Cores: 8
L2 Cache (per processor): 12 MB
Memory: 4 GB
Bus Speed: 1.6 GHz

Graphics Card

NVIDIA GeForce 8800 GT:

Chipset Model: NVIDIA GeForce 8800 GT
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0611
Revision ID: 0x00a2
ROM Revision: 3233
Display Connector:
Status: No Display Connected
Apple Cinema Display:
Resolution: 1600 x 1024
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported

3 Internal Drives

ST3320820AS_P: <<< 1 used for my Linux system >>>

Capacity: 320.07 GB (320,072,933,376 bytes)
Model: ST3320820AS_P
Revision: 3.BQE
Native Command Queuing: Yes
Queue Depth: 32
Removable Media: No
Detachable Drive: No
BSD Name: disk2
Medium Type: Rotational
Bay Name: Bay 1
Partition Map Type: GPT (GUID Partition Table)
S.M.A.R.T. status: Verified
Capacity: 136.37 GB (136,366,260,224 bytes)
Writable: Yes
BSD Name: disk2s1
Capacity: 181.47 GB (181,465,513,984 bytes)
Writable: Yes
File System: MS-DOS
BSD Name: disk2s2

WDC WD6401AALS-00E3A0: <<< 2 of these used for my Mac OS X system >>>

Capacity: 640.14 GB (640,135,028,736 bytes)
Model: WDC WD6401AALS-00E3A0
Revision: 05.01D05
Native Command Queuing: Yes
Queue Depth: 32
Removable Media: No
Detachable Drive: No
BSD Name: disk0
Medium Type: Rotational
Bay Name: Bay 2
Partition Map Type: GPT (GUID Partition Table)
S.M.A.R.T. status: Verified
Capacity: 209.7 MB (209,715,200 bytes)
Writable: Yes
BSD Name: disk0s1

I’ve been running a dual-boot Mac and openSUSE 11.4 for the past 1-2 years without any problems,
11.4 installed with no problem. In fact, I just tried installing LinuxMint 13 64-bit Cinnamon and Mate
in place of openSUSE 12.1 and did so without problem. I’m back to trying to do so again with 12.1
on my dedicated Linux drive (my other 2 drives are dedicated to Mac OS X). If I find no solution to
my 12.1 issues, I can move to LinuxMint 13 instead, or revert back to openSUSE 11.4.


Ron, the main difference is the kernel version with 3.1 in openSUSE 12.1 while you could update to stable kernel 3.4.4 if you wanted to. I can say that the nVIDIA 8800 video card is a good one and I owned one for a long time. I did install the proprietary video driver though and did not use the built-in one. So, to update just the kernel and use the default nVIDIA driver, here is another bash script you can use.

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.75 - Blogs - openSUSE Forums

Thank You,

Doing anything for more than a minute or two on my 12.1 system is causing me nothing but problems!
I keep getting that “Oh no! Something has gone wrong.” message and I have to log out.

SO, to do your LNVHM, I’ve used my Mac OS X system to put the following onto a USB drive:

  1. – downloaded by using the download button at your designated location
  2. – downloaded from NVIDIA

I then had to boot normally into Linux 12.1 (only way for the USB drive to be mounted) and quickly copy the
above two items to my home folder.

I then rebooted and did your runlevel 3 and logged in as root.

I then put the NVIDIA driver into my user Downloads folder and did chmod 777 on it.

I then did: cp /usr/local/bin/.
I then did: chmod 777 /usr/local/bin/
I then did: vi /usr/local/bin/ and changed the location to the NVIDIA drive to my Downloads folder.

I then did: /usr/local/bin/ and the splash screen came up and said it found no NVIDIA drivers.

If I did nothing wrong, what now?

So, basically, the script is just called lnvhw and the chmod command is +x, but you can do it all in one line from terminal with an internet connection when you use the command:

sudo rm /usr/local/bin/lnvhw ; sudo wget -nc -O /usr/local/bin/lnvhw  ; sudo chmod +x /usr/local/bin/lnvhw

I am thinking you did not read through the blog very well. Now I really know all of this is new and somethings do not make sense and I have had PC’s that don’t want to work and of course, I was newbie once upon a time. Further, its hard to say if you follow the instructions properly, if its going to work. Finally, when you go to run level 3, you also need to use the nomodeset command to get the driver to load which means you would type in the kernel load command nomodeset 3, press enter, wait for the terminal prompt (enter Ctrl-Alt-F1 if you don’t get one after five minutes) log in as root and type in the terminal command lnvhw. This assumes you already have the nVIDIA driver downloaded, you used the command above to get the lnvhw bash script and you edited the lnvhw bash script and set the line that says where you have downloaded the nVIDIA driver (IE: nVidia_folder="/home/YOURNAME/Downloads"). Nothing is ever as easy as it seems, so review these last few words to see if they help.

Thank You,

Hi James,

Well the command “chmod 777” should have worked for sure.

Humm… Can you not use this in your script:

# recreate initrd without KMS, if the use of KMS is enabled in initrd
if grep -q NO_KMS_IN_INITRD=\"no\" /etc/sysconfig/kernel; then
  sed -i 's/NO_KMS_IN_INITRD.*/NO_KMS_IN_INITRD="yes"/g' /etc/sysconfig/kernel

This is actually what the post-install scriplet of x11-video-nvidiaG02 does (when you install nvidia from the repo). You can see this code by querying the package:

**# rpm -q --scripts x11-video-nvidiaG02**

postinstall scriptlet (using /bin/sh):
if  -f etc/X11/xorg.conf ]; then
  test -f etc/X11/xorg.conf.nvidia-post || \
    cp etc/X11/xorg.conf etc/X11/xorg.conf.nvidia-post
# if configuration for proprietary driver already exists, bring it back
# (Bug #270040, comments #91/92)
if  -f etc/X11/xorg.conf.nvidia-postun ]; then
  mv etc/X11/xorg.conf.nvidia-postun etc/X11/xorg.conf
test -x usr/bin/switch2nvidia && usr/bin/switch2nvidia
# Bug #449486
if grep -q fbdev etc/X11/xorg.conf; then
  test -x usr/bin/nvidia-xconfig && usr/bin/nvidia-xconfig -s
# Bug #345125
test -f /usr/lib64/xorg/modules/drivers/ && \
  touch /usr/lib64/xorg/modules/drivers/
test -f /usr/lib64/xorg/modules/updates/drivers/ && \
  touch /usr/lib64/xorg/modules/updates/drivers/
if ls var/lib/hardware/ids/* &> /dev/null; then
  >  var/lib/hardware/hd.ids
  for i in var/lib/hardware/ids/*; do
    cat $i >> var/lib/hardware/hd.ids
test -f etc/sysconfig/displaymanager && \
. etc/sysconfig/displaymanager
if  "${DISPLAYMANAGER_XSERVER}" == "X.x11-video-nvidiaG02" ]; then
  # broken entry in /etc/sysconfig/displaymanager:DISPLAYMANAGER_XSERVER
  # use a sane default instead
sed -i s/REPLACE_ME/${DISPLAYMANAGER_XSERVER}/g usr/bin/X.x11-video-nvidiaG02
test -f etc/sysconfig/displaymanager && \
test -x /etc/X11/xdm/SuSEconfig.xdm && \
# recreate initrd without KMS, if the use of KMS is enabled in initrd
if grep -q NO_KMS_IN_INITRD=\"no\" /etc/sysconfig/kernel; then
  sed -i 's/NO_KMS_IN_INITRD.*/NO_KMS_IN_INITRD="yes"/g' /etc/sysconfig/kernel
exit 0
postuninstall scriptlet (using /bin/sh):
if  "$1" -eq 0 ]; then
  test -x usr/bin/switch2nv && usr/bin/switch2nv
  if ls var/lib/hardware/ids/* &> /dev/null; then
    >  var/lib/hardware/hd.ids
    for i in var/lib/hardware/ids/*; do
      cat $i >> var/lib/hardware/hd.ids
    rm -f var/lib/hardware/hd.ids
  test -f etc/X11/xorg.conf && \
    cp etc/X11/xorg.conf etc/X11/xorg.conf.nvidia-postun
  if  -r etc/X11/xorg.conf.nvidia-post ]; then
    mv etc/X11/xorg.conf.nvidia-post etc/X11/xorg.conf
  if test -x /opt/gnome/bin/gnome-xgl-switch; then
    /opt/gnome/bin/gnome-xgl-switch --disable-xgl
  elif test -x /usr/bin/xgl-switch; then
    /usr/bin/xgl-switch --disable-xgl
exit 0

In fact, nomodeset shouldn’t be necessary neither with nvidia nor with ati if the driver is installed “properly”, because KMS should have been disabled in initrd (in the post-install section of the rpm package or in the script used to install the driver).

  • I haven’t looked at lnvhw for a long time and don’t remember if it actually already does disable KMS. If if does, please disregard my comment. :wink:

So this code is not in my lnvhw script …

# recreate initrd without KMS, if the use of KMS is enabled in initrd
if grep -q NO_KMS_IN_INITRD=\"no\" /etc/sysconfig/kernel; then
  sed -i 's/NO_KMS_IN_INITRD.*/NO_KMS_IN_INITRD="yes"/g' /etc/sysconfig/kernel

So you are losing me on that one. The nomodeset command is required to get the nVIDIA driver to install the first time, but does not hurt after that and may not matter much after you have blacklisted nouveau driver from the /etc/modprobe.d/nvidia.conf config file. While I am not sure what is wrong on the Apple system for sure, the nVIDIA driver load method has worked many many times for me.

Thank You,

I know. Well … I guessed.

I just wanted to suggest adding it. It would disable KMS and make nomodeset unnecessary.

That’s the point. It should not be required because the installation script disables KMS in initrd - with the code above - and blacklists nouveau “earlier”. You can see it if you list the content of initrd:

#  lsinitrd /boot/initrd | grep -e nvidia

That’s right. I read that it might be a problem in some rare occasions but never encountered it.

Not sure either. And I don’t remember which problem has already been reported with 64bit installation on some Apple machines. But I would try to install the 32bit version out of curiosity. As for the nvidia driver, it should make no difference.

Is this machine a Mac Pro? Did you perform a UEFI or a legacy installation? If you have two hard disks and a Mac Pro, you should - in theory - be able to run the UEFI setup with Linux 64bit … although it wouldn’t work with Windows7 64 bit because the EFI version in Apple hardware is too old. If you performed a legacy installation, I’m kind of wondering how you dual boot? Are you using rEFIT? Or are you just using Mac OS X on non Apple hardware?

As I said, I can’t basically do anything from my Linux account and have to get everything from my Mac OS X
account, where “wget” does not exist. That is why I did the things I did. (I did read the blog.) I did happen to
misspell your script as lvhnw.sw, but that should not have had any affect, since I specified the path to it and
it was executable (my chmod command was fine). (i was going to follow what you said about copying and
pasting the contents of your lnvhw file BUT it contains line numbers at the openSUSE paste site, so that is
why I used the Download button to get it.) Also, I did not realize I had to also use the nomodeset command,
you didn’t say that where you told me to use 3.

Anyway, I renamed the script lnvhw and tried it again. It failed the exact same way, again. So, I thought
maybe your script didn’t like the name of the file I got from NVIDIA:,
so I dropped the trailing “.sh” and tried a 3rd time.

The 3rd time at least got things going. I chose option 1 and it started doing something and immediately
and I had to reboot.

Any suggestions?

please_try_again, you have much more experience than I with booting openSUSE on a Mac system. Since it has a good nVIDIA card, you would think that part would work the same, but I guess I don’t know.

As for your coding here (which I guess I missed you saying at first, its been a long day here):

# recreate initrd without KMS, if the use of KMS is enabled in initrd
if grep -q NO_KMS_IN_INITRD=\"no\" /etc/sysconfig/kernel; then
  sed -i 's/NO_KMS_IN_INITRD.*/NO_KMS_IN_INITRD="yes"/g' /etc/sysconfig/kernel

Would you need to reboot before this code would make any difference? How does this work after the main kernel has loaded, just because it is not in initrd? I am all for automating the process, but I am unsure how it saves time for sure over a more basic procedure that works. One thing is for sure, your mind is working above mind on this stuff, so bare with me and help me understand. And as always, your help in everything is greatly appreciated.

Thank you,

Well to answer the last part here is what you need to do load get the nVIDIA driver to install:

Open YaST / Software / Software Management - Select the View Button on the top left and pick Patterns. Now, you will see several Patterns listed and you want to select:


[X] Base Development
[X] Linux Kernel Development
[X] C/C++ Development

Then Press the Accept button on the bottom right and allow these applications to install.

Now these instructions are for the GUI version of YaST, but you can type in yast at the terminal prompt and perform the same tasks, though the menu system can be a challenge to get through.

Thank You,

Yes, it is a Mac Pro.
Yes, I’m using rEFIt.
I’m using Apple hardware.

Sorry I should have read the whole thread. So, you have a Mac Pro … and GPT disks. Then you should perform a UEFI installation and install with elilo (not Grub) and later grub2-efi. But if you got to the point where you would log in into Gnome, you must have managed to install openSUSE somehow.

But I noted this:

If you tried Cinnamon on openSUSE with the nvidia driver, it probably won’t work. The only way I’ve found was to compile Cinnamon (

In Mint, I guessed the nvidia driver get installed automatically (I’ve seen this in latest Ubuntu). Further Cinnamon works and the system uses Grub2. It makes of course a lot of things easier.