New install of 13.2 (still have 12.3 too), saw btrfs cautions, but additional grub problem

Have been using Linux for several years, but only lightly. Am familiar with basic terms and have done some fixing of things over the years (THANK YOU to helpers in these forums!) but am not an expert by any means.

Installed new 13.2 which gave me btrfs for root partition and xfs for home partition, and have seen cautions about the btrfs that got installed (considering re-installing with something more cautious, which is no problem because it’s still new and empty), but it’s all just academic right now because I can’t boot to it anyway.

A bit of background (as brief as possible); machine has some unused partitions at beginning of disk and then has an extended partition as /dev/sda4, and within that, logicals as follows: /dev/sda5 is everyone’s swap, /dev/sda6 is my old, current (12.3) SuSE (with the grub (not grub2) boot loader that I start up with (that is in my MBR) having always been configured from yast in this partition), and finally I have a Ubuntu (14.04) in my /dev/sda7. The Ubuntu has its own grub (again not grub2) boot loader within its own partition, and the initial MBR grub menu transfers to that grub menu with a menu section. This all works fine and has worked for a few years.

Then I wanted to install new 13.2, and keep my old SuSE until I copied the good documents, etc., out of it, so I did the 13.2 install, which gave me a root partition (btrfs) as /dev/sda8 and a home partition (xfs) as /dev/sda9. I told the install to put its (it looks like a grub2) loader into the /dev/sda8 root partition because I didn’t want to mess with what already worked in my MBR (and using the two-step, two-menu boot has always worked with my Ubuntu). I’ve mounted the /dev/sda8 partition and looked in it, and there is a /boot/grub2/grub.cfg in there.

I have not been able to put an entry into my initial MBR grub menu to transfer me to the new SuSE’s menu. I have tried a menu section with /dev/sda8 as root partition and the path as (hd0,7)/boot/grub2/grub.cfg, and I get:

root (hd0,7) filesystem type unknown, partition type 0x83
configfile (hd0,7)/boot/grub2/grub.cfg
Error 17: Cannot mount selected partition

Is there a way to be able to get from boot up to my new SuSE partition?
(Could I boot to it from the install disk?)
Ideas? Thanks in advance!

ok let us start. BTRFS is fine just a new idea. If you don’t want it installed use ext4. You must take control of the install since BTRFS is now the default. In addition to BTRFS is a new idea called snapper. That takes periodic snapshots of the BTRFS drive. This process takes additional space so you need to allow for it. 40 gig is now the recommended min for the root partition which is using snapper which is on and aggressive in the snapshots by default. So if you have allocated less then 40 gig you are much better off using ext4 or turn snapper off.

Your documents are normally stored in your home directory and you can simply mount the old home partition and then you have your old stuff in the new OS. So do not create a new home just use the old one. Note that previous home partitions were formatted ext4 (unless you did something different) so simply mount the home partition as /home using the ext4 format and DO NOT format it.

To grub. Is this an EFI BIOS machine or an older legacy BIOS machine?

I suspect the problem is that you have the two installed in different modes. You can not chain to a OS that is in a different mode then the one you are started in.

Without more info it is hard to say. Please show fdisk -l. Put the results in code blocks (# in the forums editor)

Is this GRUB legacy?
That old version does not support btrfs, therefore it cannot mount the partition and load the config file.
You could try to “chainload” to openSUSE’s grub2. If it’s installed in (hd0,7), a simple “chainloader +1” instead of “configfile …” might do.

Or use ext4 as / as gogalthorpe mentioned, or create a separate /boot for it with extX which grub can access.

And even if it did, grub legacy cannot interpret grub.cfg anyway.

You could try to “chainload” to openSUSE’s grub2.

yes, as long as grub2 is installed in partition this should work.

  1. Not sure about my BIOS, but found out that I could run a command called dmidecode and find the information in there; here is its output (first submission overloaded the submit, so only showing handles up through the one with the BIOS information):

# dmidecode 2.11
SMBIOS 2.4 present.
63 structures occupying 2994 bytes.
Table at 0x000F0000.


Handle 0x0000, DMI type 208, 12 bytes
OEM-specific Type
        Header and Data:
                D0 0C 00 00 01 05 FE 00 EC 01 01 02
        Strings:
                20040101
                00000000


Handle 0x0001, DMI type 218, 47 bytes
OEM-specific Type
        Header and Data:
                DA 2F 01 00 2E 14 33 09 0E 10 00 05 80 05 80 01
                00 10 F5 10 F5 00 00 00 80 00 80 01 00 02 80 02
                80 01 00 00 A0 00 A0 01 00 FF FF 00 00 00 00
        Strings:
                 


Handle 0x0002, DMI type 0, 24 bytes
BIOS Information
        Vendor: Dell Inc
        Version: 1.1.6 
        Release Date: 04/07/2007
        Address: 0xE0000
        Runtime Size: 128 kB
        ROM Size: 512 kB
        Characteristics:
                ISA is supported
                PCI is supported
                PNP is supported
                APM is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                BIOS ROM is socketed
                EDD is supported
                5.25"/360 kB floppy services are supported (int 13h)
                5.25"/1.2 MB floppy services are supported (int 13h)
                3.5"/720 kB floppy services are supported (int 13h)
                3.5"/2.88 MB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                CGA/mono video services are supported (int 10h)
                ACPI is supported
                USB legacy is supported
                BIOS boot specification is supported
                Function key-initiated network boot is supported
                Targeted content distribution is supported
        BIOS Revision: 1.1


Not sure where info is, in the above, or how it impacts my problem, but ready to be educated here :slight_smile:
Also ran the fdisk command:


Disk /dev/sda: 250.0 GB, 250000000000 bytes
255 heads, 63 sectors/track, 30394 cylinders, total 488281250 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000080


   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63       96389       48163+  de  Dell Utility
/dev/sda2   *       96390    29495339    14699475    b  W95 FAT32
/dev/sda3        29495340    81931499    26218080   83  Linux
/dev/sda4        81931500   488280063   203174282    f  W95 Ext'd (LBA)
/dev/sda5        81931563    84036014     1052226   82  Linux swap / Solaris
/dev/sda6        84036078   136488239    26226081   83  Linux
/dev/sda7       136488303   176863231    20187464+  83  Linux
/dev/sda8       176865280   204828671    13981696   83  Linux
/dev/sda9       260767744   336625663    37928960   83  Linux

In the above it’s only the partitions /dev/sda(5 through 9) that have been or are planned to be used right now.

Any insights shared are appreciated, and for now I’m going to do some quick reading about how to put together a chainload entry to test…

Some new info: Modified grub using boot loader module in yast so that I got another section that looks like this:


###Don't change this comment - YaST2 identifier: Original name: other###
title New SuSE Chainloaded
    rootnoverify (hd0,7)
    chainloader +1
 

Now I come up to a new menu, and taking the first option for my 13.2, I get a chance to log in. Some messages go by quickly, ending with a couple that look like:

MP-BIOS bug: 8254 timer not connected to IO-APIC
nouveau E DISPLAY][0000:03:00.0]01:0130 func 08 lookup failed, -2

(the above may be trivial; I’ve always gotten some errors in the log while my old SuSE was starting up but things worked fine once startup was finished; just mentioning the above because they are the last thing that I remember seeing for a moment before GUI starts up.)

Once GUI starts up, I get the familiar box with pictures of a hard disk, some tools, a globe, something that looks like a chart, and finally a “K” for KDE, all of which always went from blurry to sharp focus when my old SuSE started up, before I got a desktop.

With new SuSE, picture of hard disk goes from blurry to sharp focus, other pictures in box stay blurry (if they come on at all), and the whole thing freezes up and I have to re-boot.

But now there is one thing that I can do, which could be helpful in debugging: even after the graphical screen freezes, I can still do the Ctrl-alt-F# (in this case I did F2), and go to a text console and look at files. Looked at a boot log and an Xorg log in /var/log but didn’t find anything that I could see as helpful.

Please let me know if my problem should now shift into another section of the forums, as I have now gotten to the new SuSE partition and logged into it, before everything freezes. Thanks for help so far.

Yes, you should open new discussion with better subject now when immediate boot problem had been solved.

OK, I’ll start a new thread in a section that’s more for this new problem. Just to wrap up a couple of questions that I had from the questions that I was asked above,

  1. I’m assuming that if my grubs (other than the one that I got with the new 13.2 that I just installed) are not grub2, then they are what people are calling “grub legacy”. Is that correct?

and

  1. Is it possible to tell from the dmidecode sample that I posted whether my machine is EFI BIOS or legacy BIOS? (I can’t tell, and still don’t know)

Thanks again

  1. look at the /boot/grub directory. you can tell by what files are there if grub 1 or grub2. If you see a file menu.lst then it is grub 1 or legacy

  2. have no idea. Usually you check the computers specs. If older then say 5 years probably legacy BIOS if the computer has been made since Win8 was released it is EFI. If there is no mention of EFI in any BIOS screen then it is legacy. Note that an EFI BIOS can run in legacy mode emulating the old BIOS

Theoretically SMBIOS defines flag for UEFI support and I have seen some output with “UEFI is supported” in Characteristics list. This is not present in your case which lets suspect that UEFI is not supported (but in no case proves it).

Thank you for that clear-cut statement.

If one is familiar with the different versions of GRUB and their history then that may even be obvious.

But less experienced users may not even think about that :wink: