New Install of 11.2 and I can't connect to internet

Hello, I just finished a brand new install of 11.2 on a workstation and it can’t connect to the internet at all. I can ping Google and I can ping devices on my local network but I can’t browse any web pages. I am able to ping the workstation with my windows 7 workstation. I tried disabling the firewall and that didn’t seem to help either. I have it set to use DHCP.

I searched around the forums but I didn’t seem to find an answer that helped my situation.


I can connect to google via IP. So it appears to be a DNS type issue, is there some settings I am missing?

These commands can help in the diagnosis

route -n
cat /etc/resolv.conf

Did you configure your ethernet device with YaST yet? You may need to add a DNS manually.

I can’t cut and paste the results because the workstation doesn’t have internet access. Destination Mast eth0 for for the gateway (correct)

name server is set to

On 05/31/2010 10:56 PM, jhigg79 wrote:
> deano_ferrari;2171428 Wrote:
>> These commands can help in the diagnosis
> Code:
> --------------------
> > > route -n
> --------------------
> Code:
> --------------------
> > > cat /etc/resolv.conf
> --------------------
>> Did you configure your ethernet device with YaST yet? You may need to
>> add a DNS manually.
> I can’t cut and paste the results because the workstation doesn’t have
> internet access.
> Destination Mast eth0
> for for the gateway (correct)
> name server is set to

Both of those look correct, but just to make sure, the last routing line
should look like: UG 0 0 0 eth0

BTW, you can always copy and paste output into a file, save the file on
a USB stick, and get it to any computer.



will not only show if DNS resolving is working or not, but also which server it tries to use.

Try adding into the configuration for the network card, add the IP addresses of the Name Servers provided by your Internet Service Provider (or Google’s Name Servers

Here’s an example if your card is Ethernet: Adding Name Servers and a Gateway to your IP configuration

Yes thats what it looks like. Any ideas?

And what about the nslookup?

Also when you router is configured as your DNS server (see the resolv.conf) and this does not function, go for swernda’s suggestions.

more knowledgeable people here have given you some good advice, my thoughts run toward a problem i had with installing 11.2… ipv6 compatibility.

you might try adding “ipv6.disable=1” to the grub boot parameters at the grub boot screen and see if that solves your dilemma. If it does, then you can add this line to /etc/sysctl.conf to make it default:

net.ipv6.conf.all.disable_ipv6 = 1

as i recall, at the time the Yast2 ipv6 disable selection did not actually prevent the appropriate modules from being loaded so the edit of sysctl.conf was necessary. It may have since been fixed without my knowledge.

good luck.

jeramie@linux-5jwh:~> nslookup

Non-authoritative answer:

On 06/01/2010 06:36 PM, jhigg79 wrote:
> Code:
> --------------------
> jeramie@linux-5jwh:~> nslookup
> Server:
> Address:
> Non-authoritative answer:
> Name:
> Address:

OK, DNS and routing are both working. Have you tried another browser
besides Firefox?

Your network might be dropping packets. Try the following:

ping -c 100

Tell us how many packets were lost.

If using firefox, make sure ‘Work Offline’ is disabled in File menu.

As lwfinger says, DNS of your router is functioning. Try his suggestion.
And also revise your original idea: “Can’t connect to the internet”.
In your first post you said that you can ping Google, proving you have connection to the internet, and even that you have DNS resolution.

The only thing you couldn’t (from your first post) is that you “can’t browse any web pages”. Where you even do not tell what browser you use.

Now, after more then 24 hours we all together have found out that your network connection is functioning, that your router works as router ands as DNS server and that you thus have a connection to the internet.

Can you pleas specify now more precise what does NOT work. That is when you “can’t browse any web pages”, at least tell us:
. which browser;
. whch internet page (at least one example);
. if you tried another browser (there are at lerast two on your system when you use KDE, but you did not tell us what DE you use);
. what that browser shows when you try to display that page (any error messages).

Always keep in your mind that on Linux everybody can do things in a miriad of ways and that you should not take it for granted that we, lacking webcam behind you shoulders and crystal balls, can guess what/how you are doing.

here is solution if you are working with Mobile as modem(prefer Nokia), then the follwoing steps are to be followed…
1.Open the Terminal.
2.Go to /etc/wvdial.confg
3. You have to make copy of the same in another Directory and then Edit the the original file at the /etc required folder.
4. The thing are to over written as follows

[Dialer Defaults]
Init1 =ATZ
Init2 = ATQ0 VI EI SO=0 &C1 &D2 +FCLASS= 0
Init3 = AT+ CGDCONT=1,“IP”,“bsnlnet”,"",0,0
Modem Type= Analog Modem
New PPPD=yes

[Dialer BT]

[Dialer USB]

This is the code you have to follow…:wink:
I am using bsnlnet with my E63 set using USB connection, in the line of init 3, where bsnlnet is written; its optional…you have to write your Access point instead of bsnlnet, and if you are a bsnl customer you can just copy this thing and paste it.

5.Then open the terminal and go as superuser
to /etc and then wvdial USB
you get the connection done…

ist very easy…if any problem occur please revert…::|;):slight_smile:

@hardy007: What relevance has your post with the OP’s problem? If you’ve followed the thread, you’ll realise we have established internet connectivity via a broadband connection. The issue is apparent browsing functionality (or lack of).

Drive-by thought: the symptom seems to be a connection that works then falters . Sometimes this happens when a card is using the generic drivers but actually needs the manufacturer’s specific drivers.

So what’s the card?

Good point, although the OP has suggested that machine-to-machine connectivity is ok (but who’s to say its constant). I wonder if they are using a wireless ethernet connection?

More info on your ethernet connection please

/sbin/lspci -nnk

Just the ethernet related entries if you can

ip addr

I got it resolved, I had to manually enter my ISPs DNS server into the name server list. I thought this was pulled automatically via DHCP but I guess not. I am posting this in Linux…yay :slight_smile:

Thanks for the update. Glad you’ve got it sorted.

Well done (as suggested earlier in post #6):