New install fails to boot

^^^^^^^^ this … i guess no one else sees it … that;s the orig Win partition


I noticed that, but wasn’t sure if it was the cause. Do you think it needs to be deleted? Can I just remove it in Partitioner and try to reboot? Or do I need to remove and reinstall?

Also, this is the current error message I get when I try to reboot with the USB:

GRUB loading…
Welcome to GRUB!

error: …/…/grub-core/fs/btrfs.c:2156:file ‘/normal.mod’
Entering rescue mode…
grub rescue>_

@rgietzen When you boot from the Live usb device can you check the output from ls /boot/efi/EFI/opensuse/ and a file called grubx64.efi exists?

If so, then run;

efibootmgr -c -L "opensuse" -l "\\EFI\\opensuse\\grubx64.efi"

It should show a new entry in the output called “opensuse” and be first in the “Boot Order:” line.

It does exist. Here is the output from running that second command:

BootOrder: 0006,0000,0001,0002,0005,0003,0004
Boot0000* Hard Drive    BBS(HD,,0x0)2055534220466c617368204d656d6f7279312e303000
Boot0001* Network Card  BBS(Network,,0x0)49424120474520536c6f74203030433820763133363500
Boot0002* Hard Drive    BBS(HD,,0x0)50303a204869746163686920484453373231303530434c4133363020202000
Boot0003* opensuse-secureboot   HD(2,MBR,0x97be5b6a,0x35904800,0x81000)/File(\EFI\opensuse\shim.efi)
Boot0004* UEFI:  USB Flash Memory1.00   PciRoot(0x0)/Pci(0x1d,0x0)/USB(1,0)/USB(4,0)/HD(1,MBR,0x5d73befd,0xbec,0x246c)
Boot0005* CD/DVD Drive  BBS(CDROM,,0x0)50313a20484c2d44542d53544456442d52414d20474837304e202020202000
Boot0006* opensuse      HD(1,MBR,0x97be5b6a,0x800,0x35904000)/File(\EFI\opensuse\grubx64.efi)


I am listening. I think your idea is promising. I believe I’ll need to fully reinstall after deleting that partition, so I was trying these other quicker options first. If they don’t work, then I’ll do that for sure.

@rgietzen So reboot, check system BIOS it’s in the UEFI boot list and first and should be good to go…

@rgietzen I suspect you won’t need to re-install, some more command line foo from rescue and should be able to configure it as /home/username. Lets get it booting first…

I completed that task. When I try to reboot without the USB, it says no operating system found.

Do I need to install fresh again?

@rgietzen Ahh just notice, it’s MBR…

opensuse      HD(1,MBR,0x97be5b6a,0x800,0x35904000)/

That would probably be the easiest, but need to setup the disk prior as gpt as well…

I’m not sure how to do that. Does that require a new bootable flash drive?

Do you think I should delete that old Windows partition first?

@rgietzen Nope, you should be able to do it in rescue mode…

Ok. Got it.

I’ll search for some instructions in the forum and see if I can find a detailed explanation.


@rgietzen I normally setup the disk prior to install…

Clean out the partitions and disk with wipefs from the rescue mode;

wipefs -a /dev/sda4
wipefs -a /dev/sda3
wipefs -a /dev/sda2
wipefs -a /dev/sda1
wipefs -a /dev/sda

Then use gdisk to clean out the old mbr as well;

gdisk /dev/sda
gdisk /dev/sda

That cleans out the MBR, the second time around ensures it’s set to type gpt.

You can setup the partitions how you want with gdisk, or do that at the YAST Partitioner during install.

I have the system running with the live USB. Can I use these commands on that desktop? Or only in rescue mode?

@rgietzen Open a terminal and switch to root user and rock on :wink:

Do you want to pre-partition the device?

OH, unmount any mounted partitions on the disk…

Yes! I want to pre-partition. I usually use the default suggestions on install. I’ve only used the expert partitioner with guidance.

I think it would be easier for me to use the Yast Partioner on this live USB, so that when I do the install, it chooses the right ones.

Can you give some guidance based on what I posted above?

Good point about unmounting everything when I’m done!

@rgietzen That’s before you start… :wink:

Suggestions as follows;

sda1 type ef00 size 260MB /boot/efi
sda2 type 8300 size 60-100GB /
sda3 type 8300 size ??? (less swap amount) /home
sda4 type 8200 size 1.5 to 2x installed RAM <swap>

Or if the system doesn’t have much RAM you might want to use sda2 for swap (bit faster on rotating rust)

Then during the Install, select expert partitioning and use existing partitions and configure as required.

I would consider MicroOS Aeon/Kapla since it’s for your Parents, then they can use Flatpaks?

I Run Aeon on a Dell Tablet with 4GB of RAM, it rocks along fine (and no swap on MicroOS).

I’m open to another OS. I’ve been happy with how user friendly Tumbleweed is and I’m familiar with it, so if they ask questions it’s easy for me to help.

But if you think there are some benefits that outweigh those, then I’ll switch. Those are probably lighter running?

Also, if I just use the partitioning scheme you laid out, do I still need to clean out MBR and switch to gpt? Or can I configure that during the install?

Thanks for all your help. I feel I’m pretty close to getting this solved.

@rgietzen New concept, but follows Tumbleweed at present, self maintains with respect to system updates, end user Flatpaks so ideal for your scenario IMHO…