New install failing to boot after nVidia software added manually

HI hope you can help

I have returned to Tumbleweed after a number of years

For the past few years, I have been using Gnome based distros

I fancied trying KDE again having left it years ago

I downloaded and installed today with default options (aside from region) and the “Noveau” driver

My first boot was fine and very quick

However, I noticed my second monitor was not detected

So somewhat recklessly it now seems, I went into the software tool and selected some nvidia options (dock, bumblebee) and applied

When I rebooted, it froze about 10 seconds in

Same again when I tried recovery mode so I am unable to boot the OS at all at present

I have an HP Omen gaming laptop which I think has hybrid Intel and nvidia GPUs (sorry if I articulated this badly as I am not technical)

The laptop is connected to a Dell monitor via a Toshiba Dynadock and I have been using this set-up for around 3 years now

Windows and previous Gnome distros have no issues detecting the dual display

However. not having much luck with KDE

I first tried Manjaro KDE which ran beautifully in standalone laptop mode, but despite forum help over a period of months, I just could not get it to work with my second monitor which was a real productivity killer

Yours is thus the second KDE distro I am trying

If you can help me get past the boot issue, I will review forum / post again re the dual display issue

Grateful for your advice

Regards

R

Nvidia for optimus laptops aren’t exactly trivial. Right now the supported way is suse-prime but I put together a set of instructions for bumblebee https://forums.opensuse.org/showthread.php/537906-Cuda-Nvidia-bumblebee-codecs-quot-safe-quot-way

For now you should try to boot console mode and try to fix your Nvidia driver issue, you may need to set nomodeset in your grub.

Hey thanks for that quick reply!

Is there any guidance around how I get to console mode and commands I need to enter from there

Regards
R

Hello,
Welcome to openSUSE.

First golden rule in general is to find yourself a good guide or s Standard Procedure for setting up complex things instead of trying random things on your own and when you ask for help from others to post that guide. That enables others to have a general idea what your situation is.

If you’d like to try SUsE Prime (recommended over Bumblebee nowadays), there is an SDB article which follows. SDB articles are community created documentation that is considered authoritative, written by someone(s) that should know what they’re talking about and usually well regarded. Be aware though that not all SDB articles are well maintained, so you should always inspect the History of the article to see when the article was last reviewed/altered to keep up with the times.

https://en.opensuse.org/SDB:NVIDIA_SUSE_Prime

If you can’t provide a guide, then you have to meticulously describe what you did step by step.

In most cases,
It can also help to post as much detailed information about your hardware as possible if the problem might be related to your hardware.
So, for instance in this case although it’s good that you identified your hardware as an HP Omen laptop with an nVidia GPU, you need to provide details about what those are. If you don’t know or didn’t find commands to identify the hardware in your system, then an alternative which may or may not be sufficient is to describe the year your laptop was purchased and published technical specs like the CPU make and model, and the GPU (nVidia) model.

You have a couple of options now… To continue to configure Bumblebee or start over with SUSE Prime.
I would also recommend rolling back to your default settings using Snapper if you’re installed on BTRFS, try to avoid errors compounded on top of errors by mixing recommended guided procedures.

If you have questions about exactly what to do or what you’ve tried but didn’t result in what you expected, post again.

TSU

Thanks understood. Happy to dump Bumblebee and go with Suse Prime. My immediate issue is how to boot to command line and what commands I should enter so I can return to a desktop

OK. Found this via Google

https://en.opensuse.org/SDB:Nomodeset:Work_Around_Graphic_Upgrade%26_Installation_Obstacles

After I edited the entry and hit F10, it started booting and then froze

I took a photo via my phone and need to upload

I can’t add photo

Recurring error text along lines of:

"ACPI BIOS Error (bug): Failure creating named object _SB. PC10. XHC. RHUB. SS09. _UPC], AE_ALREADY_EXISTS, During name lookup/catalog (202009)

Then further down aborting then:

5.7835231 snd_hda_intel 0000:01:00,1:can’t change power state from D3cold to D0 (config space inaccesible)

Hi
Can you also add the grub kernel option;


snd_hda_codec_hdmi.enable_silent_stream=0

See if this helps…

Ref: 1180543 – kernel 5.10.4: Displays never wake up, though on one system it does... network is also dead

Cheers Malcolm
I had a look at that thread
Apologies not sure where exactly I enter that text
Grateful if you could clarify

Hi
Like you did previously, edit grub and add to the linuxefi line and press F10, if that works, then once at your desktop can fire up YaST -> Bootloader and add there so it’s permanent until the fix comes through.

Thanks again for your help

I dedcided to do a fresh install so happy to close this thread

Have a couple of otjher issues so will research forums and may post if required

Cheers
R