New install Error messsage: None of the authentication protocol specified aer supported

I did a new (hard drive format) OpenSUSE Leap 42.2 + MATE install on my old laptop Compaq nx7300 and I have some issues.

Release 42.2 64-bit
Kernel Linux 4.4.36-8-default x86_64
MATE 1.16.1

First, along the install I added MATE repo and installed MATE directly with minimal X. At 2nd reboot, I swiched to MATE
Could you have a look on my repos list and tell me if everything is OK?

sudo zypper repos
Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias                           | Name                                    | Enabled | GPG Check | Refresh
---+---------------------------------+-----------------------------------------+---------+-----------+--------
 1 | MATE__openSUSE_Leap_42.2        | MATE _openSUSE_Leap_42.2                | Yes     | (r ) Yes  | Yes    
 2 | Packman-Repository              | Packman-Repository                      | Yes     | (r ) Yes  | No     
 3 | download.opensuse.org-non-oss   | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes    
 4 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes    
 5 | download.opensuse.org-oss       | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes    
 6 | download.opensuse.org-oss_1     | Main Update Repository                  | Yes     | (r ) Yes  | Yes    
 7 | openSUSE-42.2-0                 | openSUSE-42.2-0                         | No      | ----      | ----   
 8 | repo-debug                      | openSUSE-Leap-42.2-Debug                | No      | ----      | ----   
 9 | repo-debug-non-oss              | openSUSE-Leap-42.2-Debug-Non-Oss        | No      | ----      | ----   
10 | repo-debug-update               | openSUSE-Leap-42.2-Update-Debug         | No      | ----      | ----   
11 | repo-debug-update-non-oss       | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No      | ----      | ----   
12 | repo-source                     | openSUSE-Leap-42.2-Source               | No      | ----      | ----   
13 | repo-source-non-oss             | openSUSE-Leap-42.2-Source-Non-Oss       | No      | ----      | ----   

Now, when I start Yast from GUI, I get a small window with the name xdg-su: /sbin/yast2
This window stays opend until I close Yast. I don’t get that in my desktop install 42.1.
This window shows an error message “Qt: Session management error: None of the authentication protocol specified aer supported”
After that Yast run fine. How can I fix this error? Will the window close if there is no error message?
I did some search and got few answers but all fixes are different, so I’d like a good solution for this Leap version.

Thanks

Nobody can help me with this issue?
As I start the application with the GUI, I can’t use different ways like with the CLI.

What should I do?

I can’t help because I don’t understand what is the problem.

MATE is working fine here, though I mostly use KDE. I did not add the MATE repo. I just installed MATE from the main repos. It seems to be working fine. But then, maybe you are wanting to do things that I haven’t tried.

Thank you nrickert for your answer.

In fact my question is about the error message I get when I click on Yast link in the menu. Why this error how to fix?
I have a desktop with 42.1 and I don’t get the same window with the name **xdg-su: /sbin/yast2 **when I start Yast. I don’t know why, any idea?

It might be a bug with xdg-su, or an incompatibility issue with your repos.

You could, instead, try:

 su -

in a terminal (mate-terminal or xterm or gnome-terminal should be okay). That should give a root command line. Then just run “yast2” from that command line.

On 02/11/2017 07:36 PM, nrickert wrote:
>
> It might be a bug with xdg-su, or an incompatibility issue with your
> repos.

I am getting the same error after recent updates in TW. I believe it is
a regression that has been fixed (for TW) and should be in an update soon.


Ken
linux since 1994
S.u.S.E./openSUSE since 1996

Thank you both, I’ll wait the update