New install Dual Boot MBR Grub2 not showing

Haven’t been active in the forum for quite some time. No real issues until now.

Going from 13.1 to 13.2 doing a clean install. I think the install takes, but Grub2 does not show up. So I am guessing I am choosing the wrong options somewhere along the line. Anybody set up similar to me have a successful install?

My desktop is dual boot with a physical hard drive for Windows and a physical hard drive for Suse.

Set up:

Bios – Legacy Boot (MBR)

Hard Drive 1 (sda) used for Windows 7 Home Premium

Hard Drive 2 (sdb) used for Suse (previously had 13.1)

External Hard Drive (sdc) used for certain backup data

Options used in 13.2 x64 Install:

Create Partition Setup:

  1. Hard Drive /dev/sdb
  2. Use Entire Hard Drive

Expert Partitioner:

  1. Do not format Partition
  2. File System ID: 0x00 Bios Grub
  3. Do not mount partition
  4. Size – 7.84 MiB
  5. Format Partition
  6. Mount Partition – swap
  7. Size – 2.01 GiB
  8. Format Partition – Ext4
  9. Mount Partition - /
  10. Size – 40.00 GiB
  11. Format Partition – Ext4
  12. Mount Partition - /home
  13. Size – 889.49 GiB

Boot Loader – GRUB2
Boot From Master Boot Record – Unchecked
Boot From Root Partition – Checked
Set active Flag in Partition Table for Boot Partition – Checked
Write generic Boot Code to MBR – Checked
Protective MBR flag – remove
Boot Loader Installation Details:
Disk Order - /dev/sdb, /dev/sda, /dev/sdc (external drive)

Post output of:

fdisk -l

and also:

parted -l

You can do that from the Rescue option of the install DVD.

Your using a bios_grub partition in a legacy MBR setup? Odd?

bios_grub is necessary if it’s GPT and EFI

For legacy mbr that you quote, I always set grub to mbr / and extended if it exisits. Belt and Braces

Not quite right. bios_grub is needed if the disk is GPT partitioned but using legacy BIOS booting.

We don’t know, as far as I can see, that “/dev/sdb” is not GPT. At a 1T capacity, it might have been partitioned that way.

If it is GPT, then booting from “/” probably won’t work. Best to boot from the MBR of that disk.


We need more information, output by the system instead of related 3rd hand, in order to know how to proceed.

How do I post the results of fdisk and parted? I found some Windows utilities that show Disk 0 / sda is MBR and Disk 1 / sdb is gpt.

Here is the stuff from windows.

Microsoft DiskPart version 6.1.7601
Copyright (C) 1999-2008 Microsoft Corporation.
On computer: WINDOWS13

DISKPART> list disk

Disk ### Status Size Free Dyn Gpt

Disk 0 Online 931 GB 0 B
Disk 1 Online 931 GB 0 B *

DISKPART> select disk 0

Disk 0 is now the selected disk.

DISKPART> list partition

Partition ### Type Size Offset

Partition 1 Primary 100 MB 1024 KB
Partition 2 Primary 302 GB 101 MB
Partition 0 Extended 629 GB 302 GB
Partition 3 Logical 629 GB 302 GB

DISKPART> select disk 1

Disk 1 is now the selected disk.

DISKPART> list partition

Partition ### Type Size Offset

Partition 1 Unknown 1024 KB 1024 KB
Partition 2 Primary 2061 MB 2048 KB
Partition 3 System 40 GB 2063 MB
Partition 4 Primary 889 GB 42 GB

DISKPART> list volume

Volume ### Ltr Label Fs Type Size Status Info

Volume 0 F DVD-ROM 0 B No Media
Volume 1 G DVD-ROM 0 B No Media
Volume 2 System Rese NTFS Partition 100 MB Healthy System
Volume 3 C NTFS Partition 302 GB Healthy Boot
Volume 4 D NTFS Partition 629 GB Healthy
Volume 5 E RAW Partition 2061 MB Healthy
Volume 6 H RAW Partition 889 GB Healthy
Volume 7 RAW Partition 40 GB Healthy Hidden

That already explains why you are having problems.

Boot from the MBR. If you still leave the disk order as “/dev/sdb, /dev/sda, /dev/sdc” then that means the MBR of your second disk (/dev/sdb). It won’t interfere with Windows. You probably have to tell the BIOS to boot your second disk in order to boot opensuse that way.

Thank you.

The only changes I had to make were in:

Boot From Master Boot Record – Checked
Boot From Root Partition – Unchecked

Boot Loader Installation Details:
Disk Order - /dev/sda, /dev/sdb, /dev/sdc (external drive)