New install: cd:/content Invalid signature


I tried to install the openSUSE-11.1-DVD-i586.iso via the virtual CDrom applet (HP iLO) onto a Blade in an enclosure and got the error message:

>>> Linux v3.3.22 (Kernel <<<

cd:/content Invalid signature
Installation aborted.

OpenSuse is new to me.

I found the problem.

The system date in the BIOS was set before the timestamp on the DVD. The error message given was misleading.

I changed the BIOS date from 11/2008 to 06/2009 and the install would run.

Yes, the error message doesn’t give enough details. There are validity checks on the digital signature and one of the criteria is that it should be within the validity period of the signature and if the current date (according to the BIOS) is before the start date, it complains.

Invalid signature suse 11.1 DVD/CD - openSUSE Forums

How do you change the BIOS system date?
I keep getting the same error as well…

It doesn’t mean every problem relates to date. Sometimes it’s just corrupted CD/DVD. You change the date either from another system like Windows (which doesn’t support UTC so when you boot back to Linux from Windows you got bad time unless You use NTP) or in the BIOS. It’s the menu you got before you are at the boot prompt so you press Delete, F2 or F10 or even other keys to enter that and then you look for date settings (they are mostly the first option to change).