new install 12.1 64bit ps2 mouse & keyboard not working after booting

Finished a new build pc:
cpu: Sandy Bridge pentium g870
Mb: asrock h61m/u3s3

tried installing **12.1 64bit dvd **xfce desktop environment,
I checked the md5sum before install.
installation seemed to go very smooth without any problems.
ps2 mouse & keyboard working in UEFI bios & the Opensuse installer

However when i start up, i get to the desktop screen … the mouse and keyboard do not work!


I tried running a live linux mint 13 64bit xfce install dvd also and i have the same problem get to desktop but no keyboard or mouse working

I tried ubuntu 12.04 lts 64bit dvd and it fails

i checked that linux should be okay with this motherboard:
[Phoronix] ASRock H61M/U3S3 Review](
they had it running** ubuntu 11.10** which has the 3.0 kernel

has anyone got any ideas? or have the same motherboard?

Many thanks

On 08/16/2012 02:16 PM, philipgardner wrote:
> has anyone got any ideas?

shutdown the power and unplug both the mouse and keyboard then replug
them into the opposit socket (switch them…because a PS2 mouse will not
work if plugged into a PS2 keyboard socket, and vice versa)

if that is on help: try a usb keyboard/mouse (maybe the PS2 sockets are
broken/not well grounded, etc etc etc…like, maybe there is no non-USB
keyboard controller on that MB…otherwise, how could it fail with ALL
tried OSes??)

well, if you have been plugging and unplugging the PS2 hardware while
the motherboard is powered up you may have shorted, burned our or
otherwise damaged the board’s mouse and keyboard controller!!


Hi, dd,

thanks for your reply.
It can’t be that the PS2 sockets are broken in the motherboard, as they work again in the UEFI bios and when booting with the install dvd.
I haven’t tried booting with a usb mouse/keyboard, i’ll try that tomorrow if i can borrow some from work.

On 08/16/2012 11:16 PM, philipgardner wrote:
> work again in the UEFI bios and when booting with the install dvd.

ah! i overlooked that UEFI comment in your original…and, i don’t know
what to think about it works when booted from the install disk, but not
once installed…

maybe it is a flat out incompatibility with your motherboard…but, i
think you need to try to attract the attention of a user/helper here
named please_try_again and get his views on the situation…

suggest you PM him and ask him to look in on this thread

(don’t ask him to answer your Q in PM–because we all need the benefit
of his advanced knowledge/understanding of UEFI…and, if he can’t help
you may need to post to the mail list…where the more technical capable
hackers hang…)


Had another try using a usb mouse and keyboard, rather than the ps2 , and it works fine with usb

I’m not sure if its a bios issue as i have 1.30 bios and asrock website recommends 1.60 minimum with my cpu.
I just assumed that if the bios wasn’t compatable nothing would start up…?

Bit scared of ruining everything if i flash the bios, they dont seem to have a downloadable copy of the old bios that i have, which i’d rather have as a fail safe.

i’ll have to think, maybe i can live with out ps2 for a while, and wait to see if anyone else with H61m/u3s3 has had this problem.
I am tempted to try a Gnome or kde install to see if its an xfce issue?


On 08/17/2012 11:36 AM, philipgardner wrote:
> I am tempted to try a Gnome or kde install to see if its an xfce issue?

given that you wrote “I tried running a live linux mint 13 64bit xfce
install dvd also and i have the same problem” i wouldn’t think that is

but, you might find that a 32 bit version of all of those work with your
MB and BIOS…


I don’t think you installed a UEFI/GPT system. Most likely your UEFI BIOS booted in CSM (Compatibility Support Module) and you have a tradional MBR/Legacy BIOS based system. But I don’t think it has anything to do with your PS/2 mouse and keyboard.

Are you able to type before booting or not at all? If so, type the following in the options line:

acpi=off 3

and see if you can log in (= be able to type your name) in a tty. Otherwise use a USB keyboard to enter this option.

Don’t unplug a PS/2 mouse and keyboard when the power is on!

But you don’t need to unplug them to add a USB keyboard. You can have more than 1 keyboard.

Could be that the installed kernel doesn’t have PS/2 support (unlikely though):

# grep "CONFIG_MOUSE_PS2" /boot/config-$(uname -r)

Could be that the udev daemon doesn’t recognize your mouse and keyboard and doesn’t create the device files.

Could be that IRQ12 is not available (acpi=off would help).

Could be that an older version of Linux (unlike the latest Mint release) would work.

Have a look at the devices found at boot with dmesg:

# dmesg | grep -i e mouse -e keyboard

Hi please_try_again,

Thanks for all the advice,
i’ll try your suggestions over the weekend,
Regards Phil

Tried your advice but i had kernel panic problem before i could get anywhere, so based on a newegg feedback review of the motherboard i upgraded the bios to the latest version.
Everything is now working…i am using linux mint til opensuse 12.2 comes through, as the newer kernels shave better sandy bridge support.

thanks for the help.
For anyone with an asrock h61m/u3s3 motherboard upgrade the bios to latest version…(currently as i write 2.20?)